Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-28-2011, 07:27 PM
Lee_T413 Lee_T413 is offline
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 950
Default Cruise control Problem

Hello, when i first bought my truck about 2 or three months ago, i had tested out to see if my cruise control had worked. Which it did, once. But when i tried it a second time nothing would initiate. When i hit any button on the column, on my cluster the Speed Cont. light blinks just once; very quickly then disappears. I made sure I was going over 30. I tried to read the manual, and there were no troubleshooting steps to try and solve the problem. so I was wondering if any of you had this problem and know of a quick solution.

Thanks
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
  #2  
Old 04-28-2011, 07:49 PM
Lee_T413 Lee_T413 is offline
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 950
Default Re: Cruise control Problem

Going to have a look at the Brake pressure switch
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
  #3  
Old 04-28-2011, 10:01 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Cruise control Problem

If you have some spare cruise toggles try swapping the, the on/off toggle may be bad
Reply With Quote
  #4  
Old 04-30-2011, 06:44 AM
Lee_T413 Lee_T413 is offline
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 950
Default Re: Cruise control Problem

they seem to work, they click when i hit the buttons and the lights flash when i press them. should i replace them regardless?
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
  #5  
Old 05-03-2011, 08:56 PM
kisportolt kisportolt is offline
2003 3.0 v6 xlt
 
Join Date: Mar 2011
Posts: 102
Default Re: Cruise control Problem

i have the same problem..cruise didnt work from the day i bought the truck though. if i press on and then set, the speed cont. light will blink but the cruise doesn't engage and nothing else happens. i know my on/off one works because if i press off then set, the light wont blink..
__________________
2003 3.0 v6 xlt supercab flex fuel

1995 Jeep Wrangler YJ, 2.5l 5 speed
Reply With Quote
  #6  
Old 05-04-2011, 05:33 AM
Lee_T413 Lee_T413 is offline
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 950
Default Re: Cruise control Problem

exactly, same problems i am experiencing, i am going to try a new brake pressure switch once i have time, then ill let you know if anything happens.

BTW, does anyone know how to test these with an ohms reading?
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
  #7  
Old 05-04-2011, 10:55 AM
navseawelder1 navseawelder1 is offline
Kentucky Wildcat Ranger
 
Join Date: Sep 2010
Posts: 27
Default Re: Cruise control Problem

I took mine to the Ford Dealership and had them replace both buttons and it cost me $445. I could have made a lot of mistakes for that price and still came out ahead.
__________________
2003 Ford Ranger XLT Ext. Cab. No Mods
4.0 SOHC (E), Auto.
2WD
Reply With Quote
  #8  
Old 05-06-2011, 05:19 AM
kisportolt kisportolt is offline
2003 3.0 v6 xlt
 
Join Date: Mar 2011
Posts: 102
Default Re: Cruise control Problem

wow for that price i think i'm going to stick with trial and error. heading to the junkyard today so im going to see if i can grab some cruise pieces and try to fix this myself
__________________
2003 3.0 v6 xlt supercab flex fuel

1995 Jeep Wrangler YJ, 2.5l 5 speed
Reply With Quote
  #9  
Old 05-06-2011, 08:10 PM
Lee_T413 Lee_T413 is offline
We'll fix 'er up.
 
Join Date: Feb 2011
Posts: 950
Default Re: Cruise control Problem

wierd phenomena today, travelling approximately 60 miles per hour on the high way i tried activating cruise control for the hell of it and it engaged... and when i had gone over a bridge it disengaged, as if theres a shortage somewhere.
__________________
2000 Ford Ranger (gen 4), XLT 4x4 OFF-ROAD package, 4:10's, Powerdome Hood, LOTS of mods.
Add me on facebook
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control cable problem 02 Ranger Black Ranger General Tech 5 03-31-2011 05:00 AM
Problem with cruise control cdiehn Interior Tech 5 03-26-2011 05:18 PM
Cruise control help 2002VertGT Electrical Tech 1 03-07-2011 06:42 AM
Replaced Cruise Control switches...Houston, I may have a problem! Tullphan Interior Tech 4 02-20-2011 02:54 PM
Cruise control EMB1230 Electrical Tech 0 09-29-2010 10:19 PM