Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-19-2011, 08:07 PM
wbirddog wbirddog is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 3
Send a message via AIM to wbirddog
Unhappy Electrical system anamoly

My 96 Ranger did a strange thing today. I drove about a mile to the grocery, parked and shopped, then drove about two miles to another place, and parked for about 15 minutes. Each time, everything worked perfectly. Then, when I turned the key on to leave this place, the chime started sounding. I fastened my seat belt, and the chime stopped. I noted that the display said my belt was not fastened. Then, I noted the ABS light was on, the fasten seat belt light was on, and I think another warning light. Then, I also noted that My A/C was not working. And, The fan did not run. I changed to heat, and it still did not run. I drove home and parked, thinking I have got to get this fixed. Well, I checked again about two hours later, and everything now works! Has anyone else ever experienced this? Is something fixing to fail, and cost me a lot of money to fix? I am the origonal owner, and have never had anything fail on this vehicle before this. (Except the odometer about two years ago. I broke it trying to zero the miles while in motion.)
Reply With Quote
  #2  
Old 04-19-2011, 08:56 PM
TerrenceStuart TerrenceStuart is offline
Old man driver.
 
Join Date: Nov 2009
Posts: 14,895
Default Re: Electrical system anamoly

welcome to FRF, Franklin!
__________________
some kind of vehicle.
Reply With Quote
  #3  
Old 04-20-2011, 01:51 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Electrical system anamoly

Welcome to FRF

Moved thread to electrical section. Please post tech questions in the correct section. You will get a better response.
__________________
2005 Edge

Reply With Quote
  #4  
Old 04-20-2011, 03:21 AM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Electrical system anamoly

Check the 4 harness ground points under the hood:
1 on each inner fender apron, left and right, about halfway back
1 on the firewall near the PCM
1 on the driver side of the radiator core support
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
  #5  
Old 04-21-2011, 09:01 AM
wbirddog wbirddog is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 3
Send a message via AIM to wbirddog
Default Re: Electrical system anamoly

Quote:
Originally Posted by rwenzing View Post
Check the 4 harness ground points under the hood:
1 on each inner fender apron, left and right, about halfway back
1 on the firewall near the PCM
1 on the driver side of the radiator core support
Thanks! I will check this out. Have'nt driven since this happened, but started the engine last night and everything worked. Am going to take a little trip today, and we will see what happens.
Reply With Quote
  #6  
Old 05-06-2011, 07:45 PM
wbirddog wbirddog is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 3
Send a message via AIM to wbirddog
Default Re: Electrical system anamoly

Quote:
Originally Posted by wbirddog View Post
Thanks! I will check this out. Have'nt driven since this happened, but started the engine last night and everything worked. Am going to take a little trip today, and we will see what happens.
Friday, 6 May: OK, its me again. I am at a loss to figure out what happened. I have been driving my Ranger almost every day since my post, and have not had a recurrence of my problem. I am inclined to do nothing to the electrical system, as long as it does not repeat the system failure. I'm keeping your comments available, in case it does act up again. Meanwhile, thanks for the comments.

Franklin
Reply With Quote
Reply

Tags
a/c blower, a/c compressor, abs light, chime, electrical problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical BACKWARDS? Gumcrew2 General Ford Ranger Discussion 14 03-13-2011 01:19 PM
Electrical Gremlin mocgap Electrical Tech 0 03-12-2011 02:47 PM
electrical bug FX4 Electrical Tech 1 10-13-2009 01:42 PM
need help 95 ranger electrical wigly1541 General Ford Ranger Discussion 1 07-19-2009 12:50 PM
Electrical Grimlins STL Electrical Tech 2 07-08-2009 06:07 PM