Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 09-24-2009, 05:43 PM
Recon Ranger Recon Ranger is offline
Like the Forums
Join Date: Aug 2009
Posts: 41
Default Starting has become a problem

I have a 94 Ford Ranger 3.0 liter 2wd manual Super Cab.
I haven't been able to start it for five weeks. The day my Ranger was running it seemed to be losing power. My gas showed me on empty so I stopped for gas, put in about 5 gallons, drove off, and then my Ranger stalled. I thought it was bad gas, but since emptying half the gas from the tank I don't think that's the problem. The pump is pumping with plenty of pressure, and I've changed the fuel filter.

So going back to my Ranger losing power prior to the gas, and thinking it's electrical. I've changed the spark plugs, spark plug cables, distributor cap, rotor button, and coil. I'm trying to find the ignition module, and now bbowler said he had a similiar problem that turned out to be the ground from the computer.

Now I'm trying to find both my ignition module and computer w/ground.
Semper Ford

Recon Ranger
94 Ranger XLT
Super Cab
Reply With Quote
Old 09-24-2009, 05:47 PM
STL STL is offline

Join Date: May 2009
Posts: 23,331

Ignition module I believe is in the cab around the steering wheel

Computer ground I am not sure of
2005 Edge

Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem starting my 2000 Ford Ranger Pickup? cakey1953 General Tech 12 11-23-2012 06:09 PM
Locks locking when starting crackeyes Electrical Tech 1 11-19-2009 12:55 PM
02 4cyl hard starting 02silvertina 4-Cylinder Tech 0 09-10-2009 08:03 AM
02 stuttering when starting/taking off crackeyes 3.0 Vulcan Tech 5 07-22-2009 09:04 PM
starting problems 1986 ford ranger 2.9 Liter Tech 1 06-27-2009 10:19 PM