Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-23-2011, 08:52 PM
mopar9012 mopar9012 is offline
Ford Ranger Driver
 
Join Date: Jul 2010
Posts: 518
Default my guage lights went out.

So yesterday I put in a new alpine head unit and everything went well and everything still worked. So today Im pulling out of a parking lot and my right speakers go out and then all my lights on the dash go out except the radio. So I take the alpine out and my right audio wire was disconnected(my friend advised I use these great wire connectors that work like crap) anyways, i get that back hooked up and my speakers work again. So in the owners manual there apparently is no one fuse thats for the dash lights that I could find, so I checked a couple that related to any kind of lights ont he dash and they are all fine.
Does this sound like a fuse problem? what gets me is I went to walmart with my lights inside the cab working, I crank it back up and they arent?
Not really a big deal but I would like them to work.
__________________
2002 3.0 Ford Ranger 4x2, Auto, 250k miles
Reply With Quote
  #2  
Old 03-18-2011, 11:37 AM
Kmartcivic Kmartcivic is offline
Like the Forums
 
Join Date: Feb 2011
Posts: 31
Default Re: my guage lights went out.

Make sure your illumination wire (orange wire on aftermarket plug in harness) and dimmer (orange/white) are insulated good. Sounds like its grounding out.
__________________
87 Ranger xlt $350 project
97 Civic - soon to be turbo'd
89 Kawasaki KZ650 - Cafe Project

I have too many projects.
Reply With Quote
  #3  
Old 05-16-2011, 01:21 AM
allathlete5 allathlete5 is offline
Ford Truck Driver
 
Join Date: Nov 2010
Posts: 88
Send a message via AIM to allathlete5 Send a message via Skype™ to allathlete5
Default Re: my guage lights went out.

Sorry to bump an old thread, but I'm wondering if this worked... I just put in a set 12" subs and tonight right when I turned the truck on and the lights on they went out... The only lights not working are in the cluster and the AC control things, everything else works fine! Should I pull the head unit out and make sure those two wires are insulated well and not able to hit anything??
__________________
1999 Ford Ranger, 3.0 L v6, 2 12" subs behind driver seat. Painted Black Rims. Body Lift on the way.
Reply With Quote
  #4  
Old 05-17-2011, 05:53 AM
mopar9012 mopar9012 is offline
Ford Ranger Driver
 
Join Date: Jul 2010
Posts: 518
Default Re: my guage lights went out.

It was just a blown fuse I overlooked.

----------

Btw mine blew when I was hooking up my new headunit as well. Check the fuse box under the hood. That should be it.
__________________
2002 3.0 Ford Ranger 4x2, Auto, 250k miles
Reply With Quote
  #5  
Old 05-17-2011, 02:18 PM
westtntrucker westtntrucker is offline
Ford Ranger Owner
 
Join Date: Jan 2011
Posts: 51
Default Re: my guage lights went out.

When your dash lights go out, you have no tail lights either. They are set up on the same fuse. This is a engineered safety feature.
You can see your dash lights out and replace the fuse. Most people never check to make sure thier tail lights and brake lights are working.
__________________
2004 Ranger XLT 4dr. 2wd
3.0 Auto
I put in a radio and a tool box
so it aint stock no more.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to Buy: Guage Cluster Prunedale 4x4 Interior Parts 5 12-23-2010 11:58 PM
Guage over full! harleygold General Tech 3 11-24-2010 07:59 PM
Temperature guage dweilmd 3.0 Vulcan Tech 5 03-20-2010 12:22 PM
02 2.3 temp guage problem rix71gt 4-Cylinder Tech 5 11-24-2009 05:12 PM
Instrument Cluster/Tail Lights/Fog Lights - NO Lights when Headlamps are on??? bwheeler Electrical Tech 6 06-05-2009 05:35 AM