Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Technical > Electrical Tech
Forgot Password? Join Us!


View Poll Results: Does anyone help me?
no 1 100.00%
yes 0 0%
Voters: 1. You may not vote on this poll

Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 02-23-2011, 07:07 PM
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Headlights won't work

Somebody please help.
My 94 is giving me problems. My headlights won't work. I put a new headlight switch in, a new turn signal switch .
I checked every inch of wire behind my dashboard and i can't get them to work.
I jumped a wire in the headlight switch and see the headlights do work but they do not work normally.

Any help out there?
Reply With Quote
  #2  
Old 02-23-2011, 07:11 PM
TRUCK SOLD!
 
Join Date: Feb 2011
Posts: 2,025
Default Re: Headlights won't work

Could it b the fuse?
__________________
1999 Ford Ranger XL
Vulcan V6, K&N 33-2106 Filter, 3:73 Gears,
FRONT 3'' Susp Lift/REAR 3'' susp.+ 3" blocks,06 Mirrors
31"/10.5"-15" BFG on AR-172 Polished Rims,Smitybilt Console
95 Mustang Saleen Seats,Alternating Blinker MOD
Pioneer CD/iPod/GPS,6.5 Polk Audio/6.5 Sub-Woofers,
Stainless Bed Extender,Throttle and Dome Light MOD,
12" Tool Box,Billet Grille,NightShade Tint,Projector Headlamps
6000K H.I.D. so i can see at night! LOL


JESUS is LORD!
Reply With Quote
  #3  
Old 02-23-2011, 07:35 PM
Banned
 
Join Date: Feb 2011
Posts: 754
Default

Bad switch?
Reply With Quote
  #4  
Old 02-23-2011, 07:38 PM
I am THE Hank Hill.
 
Join Date: Sep 2009
Posts: 1,085
Send a message via AIM to Jimmeh
Default Re: Headlights won't work

This is a dumb question....

Did you check the bulbs?
__________________
92 Ford Ranger Supercab XLT 4X4.
Not a ton done to it, but it's nowhere near finished
05 Chevy Silverado 1500 W/T 4X4
Way too much done to list and it's also not even close to done

"The only woman I'm pimping from now on is Sweet Lady Propane. And I'm tricking her out all over this town."
Reply With Quote
  #5  
Old 02-23-2011, 07:42 PM
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Headlights won't work

Quote:
Originally Posted by Ranger Down View Post
Somebody please help.
My 94 is giving me problems. My headlights won't work. I put a new headlight switch in, a new turn signal switch .
I checked every inch of wire behind my dashboard and i can't get them to work.
I jumped a wire in the headlight switch and see the headlights do work but they do not work normally.

Any help out there?
Well looks like the bulbs are good and he's replaced the switch... Can you explain what you did with "jumping a wire in the switch" since that little details will give us a direction to go. And yeah, fuses....?
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #6  
Old 02-23-2011, 09:43 PM
Learning to use the forums
 
Join Date: Feb 2011
Posts: 1
Default Re: Headlights won't work

I have the same issue since last week. Swapped out 2 multi-function switches (thought for sure that would do it) and still no headlights. Do you have same problem- bulbs good, high-beams work when pulling back on MFS, all other electrical good, no obvious fuse blown?

Any one have idea on additional trouble-shooting?

Double check what wires? what fuses?
Reply With Quote
  #7  
Old 02-23-2011, 11:01 PM
Banned
 
Join Date: Feb 2011
Posts: 754
Default

Do you have a test light? Check to make sure you are getting power to the plug
Reply With Quote
  #8  
Old 02-24-2011, 05:08 PM
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Re: Headlights won't work

Thanks for all the suggestions.
If you look at my avatar pic you'll see the ass end of my dashboard.
Fuses are good. As I in and out the 60amp fuse I can feel and hear the relay fire.
What started this whole thing was my wipers would turn on all by themselves and the gauges in my instrument panel went full north and then after a while it would fix itself.
I was good for awhile pulling the wiper fuse when it happened but gauges would stay north. When the gauges went south I would put the wiper fuse back in.
Finally it didn't fix itself. (time for me to fix it)
Also sometimes when I went to turn on my headlights they didn't turn on, I would play with the high beams and flash to pass and then they would come on.
I pulled the multi function switch (mfs) and noticed the high beam connector had an area that was melted (the yellow with red stripe wire).
Followed the wire to the headlight switch, noticed some lite burning on the headlight connector at that wire.
I pulled the headlights on(the parking and headlights work at this point) and wiggled the knob and the lights died. Sweet, that's it? I said to my self.
I put a new headlight switch in and no headlights. Damn. I put a new mfs in and no headlights but my wiper problem and gauge problem is fixed.
I pulled the dashboard and unwound the whole harness and inspected every inch of every wire and found nothing.
I installed everything back and still no headlights. The parking lights work.
I checked every fuse visually and with an olm tester.
I checked with a dc tester and found no juice at the headlight with the headlight switch in the on position.
In the headlight switch I jumped a wire from the yellow with red stripe wire to the connector that has two wires of a same gauge brown wire.
I pulled the knob to the parking light position and all the lights turned on, also checked the brights and flash to pass and they worked. I pulled the knob all the way out and get the same result.
I put the old headlight switch in and did the same thing and got the same result.
So here I am "WTF".
I think I went all out here , I don't really want to start unraveling wire harnesses apart under the hood.
My Rangers color is green. When I bought it for my son(his first car) he named it the BOOGER . The name stuck. Anytime the ranger is talked about it called the BOOGER. Hey dad did ya fix the BOOGER yet. Does the BOOGER have gas.
Thanks for the help.
Reply With Quote
  #9  
Old 03-01-2011, 03:01 PM
Learning to use the forums
 
Join Date: Feb 2011
Posts: 5
Default Re: Headlights won't work

Quote:
Originally Posted by eighty8rabbits View Post
I have the same issue since last week. Swapped out 2 multi-function switches (thought for sure that would do it) and still no headlights. Do you have same problem- bulbs good, high-beams work when pulling back on MFS, all other electrical good, no obvious fuse blown?

Any one have idea on additional trouble-shooting?

Double check what wires? what fuses?
what worked for me was wrong but it works. I spliced two wires together at the headlight switch. I tied the yellow/red wire to a brown that is right next to the yellow/red. the brown is two brown wires going to one connector.. my y/r had no juice going to it at either the headlight switch or the 'mfs'. the only thing that happens odd is in parking light mode your headlights are on.
good luck
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to Buy: Need headlights TMO Exterior Parts 0 01-12-2011 01:30 PM
headlights ec_dago_ryder Exterior Tech 3 02-02-2010 09:02 AM
signal wont work with headlights on? DangerRanger2.3ltr Electrical Tech 4 01-05-2010 06:14 PM
Will these headlights work? Darkside926 Exterior Tech 11 01-05-2010 03:24 PM
headlights Ranger_EDGE Off Topic 11 12-11-2009 11:49 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.