Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 02-20-2011, 07:14 AM
TheCaptain TheCaptain is offline
Learning to use the forums
Join Date: Feb 2011
Posts: 1
Default electrical question

I just bought a 94 ranger 4x4 with a 4.0 and auto trans. do these trucks have 2 ecm's? it looks like there is one on the firewall on the driver side and it is unplugged but there is no sign of any wires that been cut and nothing with a plug on it that would fit it. I do have another eem inside the truck on the passenger side by the kick panel it is plugged in. the truck starts and runs. Should i be concerned? Why is the ecm on driver side have no plug or wires going to it? Also my headlights work my radio and wipers work but I have no parking lights. Could this have to do with the ecm or is it a fuse? I have not had the time to check it out in depth.
1994 Ranger 4x4 4.0 auto/overdrive trans 4" lift
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problem.... Travis S. Electrical Tech 4 12-07-2010 07:45 AM
302 swap electrical question Banger91 8-Cylinder Tech 0 06-05-2010 07:38 PM
electrical bug FX4 Electrical Tech 1 10-13-2009 01:42 PM
need help 95 ranger electrical wigly1541 General Ford Ranger Discussion 1 07-19-2009 12:50 PM
Electrical Grimlins STL Electrical Tech 2 07-08-2009 06:07 PM