Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-16-2009, 12:53 PM
RANGER @ GT RANGER @ GT is offline
Ford Truck Driver
 
Join Date: Aug 2009
Posts: 82
Default H e l p , the batt keeps draining !!!

hope someone out there can tell me what the H to do...

2 nights ago I got home truck was running great, the next morning the battery was COMPLETLY drained nothing, had to jump start it... truck straterted normal at lunch time and then again at 5pm time to go home..... got home and this morning NOTHING again !!!! took it to a battery center they say the battery is ok, and so is the "alternator" (don't really know the name in english ) but is the little thingy that re-charges the batt...... so what else should I check????
__________________
_______________________________
'02 XLT Supercab
2.3L 4 Cyl.
Manual Trans
NEW: -CAI , Extra Air Intake Hose (K&N Pending)

Last edited by RANGER @ GT; 09-16-2009 at 01:12 PM.
Reply With Quote
  #2  
Old 09-16-2009, 01:41 PM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default

Look for a parasitic drain on the battery. It's pretty common for the alternator to be the culprit, but you'll need to measure the amount of amps between the negative battery terminal and the negative battery post. If it's more than around 35 milliamps, then that is a good indication that something is draining your battery. If this is the case, then pull fuses while checking amperage, also unhook alternator and test.

Pete
Reply With Quote
  #3  
Old 09-16-2009, 01:58 PM
RANGER @ GT RANGER @ GT is offline
Ford Truck Driver
 
Join Date: Aug 2009
Posts: 82
Default

Quote:
Originally Posted by Psychopete View Post
Look for a parasitic drain on the battery. It's pretty common for the alternator to be the culprit, but you'll need to measure the amount of amps between the negative battery terminal and the negative battery post. If it's more than around 35 milliamps, then that is a good indication that something is draining your battery. If this is the case, then pull fuses while checking amperage, also unhook alternator and test.

Pete
Ok I'll try with the fuses first, seems like the first step...after that will try the altenator...... Thanks Psycho
__________________
_______________________________
'02 XLT Supercab
2.3L 4 Cyl.
Manual Trans
NEW: -CAI , Extra Air Intake Hose (K&N Pending)
Reply With Quote
  #4  
Old 09-18-2009, 02:02 PM
RANGER @ GT RANGER @ GT is offline
Ford Truck Driver
 
Join Date: Aug 2009
Posts: 82
Default

OK, so I pulled out 3 Fuses (that I had suspected of) I took the A/C SELENOID 25 &56a (both from the fuse box inside the engine) , the INSTRUMENT CLUSTER 11 (inside fuse box) and the GEM, RADIO 20 & 28 (inside fuse box)......... left the batt plugged all night and the truck started on the first start....... therefore 1 of these IS the problem.... when I removed the AC one I got an ¨spark¨even though the engine was off and the key removed...... could this be an indication that, that was the one with trouble and the AC has a short cut ?????
__________________
_______________________________
'02 XLT Supercab
2.3L 4 Cyl.
Manual Trans
NEW: -CAI , Extra Air Intake Hose (K&N Pending)
Reply With Quote
  #5  
Old 09-21-2009, 07:36 AM
Psychopete Psychopete is offline
Psycho Pete
 
Join Date: Jun 2009
Posts: 1,489
Default

Quote:
Originally Posted by RANGER @ GT View Post
OK, so I pulled out 3 Fuses (that I had suspected of) I took the A/C SELENOID 25 &56a (both from the fuse box inside the engine) , the INSTRUMENT CLUSTER 11 (inside fuse box) and the GEM, RADIO 20 & 28 (inside fuse box)......... left the batt plugged all night and the truck started on the first start....... therefore 1 of these IS the problem.... when I removed the AC one I got an ¨spark¨even though the engine was off and the key removed...... could this be an indication that, that was the one with trouble and the AC has a short cut ?????
Could be that the A/C clutch solenoid could be stuck, have you tried replacing the other 2 fuses leaving the A/C solenoid fuses removed? Not too fimilar with that model year, but sound like you are on the right track.

Pete
Reply With Quote
  #6  
Old 09-21-2009, 08:01 AM
RANGER @ GT RANGER @ GT is offline
Ford Truck Driver
 
Join Date: Aug 2009
Posts: 82
Default

Actually did it friday night, I placed back the Radio and Lights fuse ...lef the A/C Selenoid ones off... and that was it.... I read something about the selenoid usually getting stuck.... what should I do now???? is it " easy" to get it un-stuck ?? or should I take it to the shop ??
__________________
_______________________________
'02 XLT Supercab
2.3L 4 Cyl.
Manual Trans
NEW: -CAI , Extra Air Intake Hose (K&N Pending)
Reply With Quote
  #7  
Old 09-21-2009, 08:30 AM
02'4.04x4 02'4.04x4 is offline
Ford Ranger Driver
 
Join Date: Aug 2009
Posts: 634
Default

Quote:
Originally Posted by RANGER @ GT View Post
Actually did it friday night, I placed back the Radio and Lights fuse ...lef the A/C Selenoid ones off... and that was it.... I read something about the selenoid usually getting stuck.... what should I do now???? is it " easy" to get it un-stuck ?? or should I take it to the shop ??
Well this is a general suggestion, learn what you can about the part specifically. This will help you learn where the individual part is and if you can get to it. You can google A/C silenoid, or just compressor and then we'll have someone that knows a little about the issue. Please remember to post your results.

Hmmm, come to think of it, just general electrical knowledge.

It should not matter if the silenoid is stuck or not. . . the relay kicks off, cutting the power. . . . . cutting the power. . . . . cutting the power. . . . . this to you I hope, clear is.(Yoda)
__________________
Current Mods
White gauges and Temp Cntrl, OHCw/Buggman LED mod,
Bosch +4, Accel Coil Pack, MSD6AL, Walbro, HiFlo Fuel filter,
Custom Ram Air, K&N, Ported / Matched intake, JBA 9mm wires,
Tweeked FPR, EBC 6k's, DynoMax-S CatBack, Jet-Chip, Reflex shocks,
New Anvil Mounts, Timbren's, Optima Yellow, DB 220A Alt. w/4g. jumper,
Western snow plow, More2Come

Last edited by 02'4.04x4; 09-21-2009 at 08:43 AM.
Reply With Quote
  #8  
Old 09-22-2009, 07:56 AM
RANGER @ GT RANGER @ GT is offline
Ford Truck Driver
 
Join Date: Aug 2009
Posts: 82
Default

thank you master.... I shall take it to the AC shop !! jaja
__________________
_______________________________
'02 XLT Supercab
2.3L 4 Cyl.
Manual Trans
NEW: -CAI , Extra Air Intake Hose (K&N Pending)
Reply With Quote
  #9  
Old 09-22-2009, 08:24 AM
02'4.04x4 02'4.04x4 is offline
Ford Ranger Driver
 
Join Date: Aug 2009
Posts: 634
Default

Quote:
Originally Posted by RANGER @ GT View Post
thank you master.... I shall take it to the AC shop !! jaja
in the relay the answer you, will find.
__________________
Current Mods
White gauges and Temp Cntrl, OHCw/Buggman LED mod,
Bosch +4, Accel Coil Pack, MSD6AL, Walbro, HiFlo Fuel filter,
Custom Ram Air, K&N, Ported / Matched intake, JBA 9mm wires,
Tweeked FPR, EBC 6k's, DynoMax-S CatBack, Jet-Chip, Reflex shocks,
New Anvil Mounts, Timbren's, Optima Yellow, DB 220A Alt. w/4g. jumper,
Western snow plow, More2Come
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search