Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 09-01-2009, 07:26 AM
dustedfock dustedfock is offline
ford gives me wood
Join Date: Sep 2009
Posts: 1
Default I have ghosts.

I have a '91 2.3 5sp with all sorts of problems. My mechanic just gave it back to me after two weeks and said "good luck."

Basically, I get a check engine light accompanied by the rpm gauge not working correctly, and some hesitation on acceleration. But, not always, and the symptoms can come in any combination. Like sometimes I get the light and the gauge, but no sputtering. Sometimes just the gauge, or just the light, or the gauge and the sputtering.

The sputtering/hesitation is also variable and intermittent, coming in and out depending on a few factors; gear, speed, resistance(hill), and how I'm on the pedal. If I let off of the accelerator a little, sometimes that will stop it for a moment. And this usually happens in 5th gear.

The rpm gauge is another matter. It drops to below 1000 and responds very little to anything, even though I can tell the truck is running at the right rpm's. It'll say 500 low in the gear, and 1000 or 1100 at 3000 to 3500.

The mechanic chased the check engine light for a while but it kept turning off on him before he could get the codes out (says he thinks there's a bunch). He told me to replace the computer with one out of the junk yard, and see if it helps. So, my real question is how long do I run the truck before I see some improvement?
Reply With Quote
Old 09-03-2009, 02:02 PM
02'4.04x4 02'4.04x4 is offline
Ford Ranger Driver
Join Date: Aug 2009
Posts: 634

Ghosts start at the ign switch everytime.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search