Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-30-2010, 05:11 AM
ranger2002 ranger2002 is offline
Learning to use the forums
 
Join Date: Apr 2010
Posts: 14
Default Idling problem

I have this problem on and off. I have a standard trans. Some times when turning on the ignition the truck barely idles and then dies. I will try restarting it a few times and then its fine and it will be that way for a day or two and then back to not idling again. The odd thing is when it does happen is that the check engine light does not come on. I have noticed when I unplugged the MAF that the truck will idle but I have to rev it up to get going. I have cleaned both the IAC and the MAF. Which is more likely to be the problem, the MAF, the IAC, or something else?

Thanks for any help
__________________
Ford Ranger 2002
2 door regular cab
2.3L 2X4
5 speed
Reply With Quote
  #2  
Old 12-02-2010, 04:19 PM
sasqutch1085 sasqutch1085 is offline
RUN, JUMP, FAIL.
 
Join Date: Jan 2010
Posts: 213
Default Re: Idling problem

Mine did that, you might have the same problem. It turned out to be the EGR valve
was clogged, or your MAF is bad.
__________________
01 EDGE 4.0 5 SPEED 4X4 FLOWMASTER LEVELING KIT SITTING ON 31s
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idling Giangrosso 4.0 SOHC / 4.0 OHV Tech 13 12-15-2010 09:21 PM
Ranger IDLING AT 45 MPH....HELP ? RangerIDLESat45mphWTF 4-Cylinder Tech 6 03-08-2010 11:34 PM
strange sound when idling. stephen 3.0 Vulcan Tech 8 11-21-2009 04:21 PM
Idling rough GSXR750 General Tech 3 08-24-2009 10:39 PM
Ranger idling.... SVORANGER351 Vehicle Snapshots 3 05-18-2009 06:28 PM