Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-24-2010, 06:42 PM
Puredreamz Puredreamz is offline
Like the Forums
 
Join Date: Sep 2010
Posts: 30
Default WEIRD... electrical experts, lost constant power to some fuses in panel.

What Happen:

I was hooking up a plow light just wanted to see if it worked, found constant power of #3 in fuse panel, wrapped wire around fuse touched power on light. It lite up for 2 secs then stopped, hooked up light to battery and it worked. Put test light on the fuse 3 no power and the fuses werent blown. I dont have a proper fuse panel layout.

Situation:
As of now fuses that have no power but no blown fuses are 3, 4, 7, 8, 27, 28.

Other Info:
checked power distribution block and fuses are fine maxi fuses are fine.


* 1995 ford ranger 4.0 V6 4x4 XLT, i ve attached a pic of the fuse panel.

Last edited by Puredreamz; 11-24-2010 at 06:43 PM. Reason: picture
Reply With Quote
  #2  
Old 11-24-2010, 06:58 PM
Puredreamz Puredreamz is offline
Like the Forums
 
Join Date: Sep 2010
Posts: 30
Default Re: WEIRD... electrical experts, lost constant power to some fuses in panel.

taken from a website 96 ford ranger service manual:

FUSE 3 = Parking Lamps

FUSE 4 = Left Headlamp ( which comes on when i turn key .. Weird)

FUSE 7 = Illumination Switches ( not working)

FUSE 8 = Right Headlamp & Fog light system ( not 100% sure but headlamp is working not sure about fog lights)

FUSE 27 = Hood lamp, map lights, glove box lamp, dome lamp, visor lamps, accessory delay, DR switch illumination and 4x4 system ( ALL NOT WORKING)

FUSE 28 = Memory Seat, GEM SYSTEM (?)
Reply With Quote
  #3  
Old 11-25-2010, 06:41 AM
Puredreamz Puredreamz is offline
Like the Forums
 
Join Date: Sep 2010
Posts: 30
Default Re: WEIRD... electrical experts, lost constant power to some fuses in panel.

anyone ? possible relays ?
Reply With Quote
  #4  
Old 11-25-2010, 10:57 AM
wvcat wvcat is offline
Ford Ranger Driver
 
Join Date: Jan 2010
Posts: 836
Default Re: WEIRD... electrical experts, lost constant power to some fuses in panel.

I would check the underhood fuse box and see if one of the big fuses are blown.
__________________
22 and counting...
Reply With Quote
  #5  
Old 11-25-2010, 11:23 AM
Puredreamz Puredreamz is offline
Like the Forums
 
Join Date: Sep 2010
Posts: 30
Default Re: WEIRD... electrical experts, lost constant power to some fuses in panel.

cHecked already all the mini and maxi fuses in the panel in the engine compartment are good they all have power and lite up when I put the test light to it

Last edited by Puredreamz; 11-25-2010 at 12:10 PM. Reason: correction
Reply With Quote
  #6  
Old 11-25-2010, 04:17 PM
wvcat wvcat is offline
Ford Ranger Driver
 
Join Date: Jan 2010
Posts: 836
Default Re: WEIRD... electrical experts, lost constant power to some fuses in panel.

I don't have a diagram for a 96 but I have a newer one I think. I'll take a look at it and see if I get any ideas...
__________________
22 and counting...
Reply With Quote
  #7  
Old 11-25-2010, 04:31 PM
Puredreamz Puredreamz is offline
Like the Forums
 
Join Date: Sep 2010
Posts: 30
Default Re: WEIRD... electrical experts, lost constant power to some fuses in panel.

No blown fuses anywhere no burnt/ melted or broken wires behind fuse panel. Not too familiar with gem module but I think that might be my problem because most the items it controls is not working on my truck and apparently sensitive to voltage spikes the plow light I was testing can draw up to 30 amps apparently
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Constant power?? 200-400ex Electrical Tech 6 11-07-2010 02:02 PM
Weird Electrical Issues, Water? ranchhand Electrical Tech 8 10-19-2010 11:55 AM
Missing Fuses for Power Locks and Mirrors happyvalley Electrical Tech 7 09-15-2010 02:37 PM
89 ranger,2.3,5spd,got stuck in mud..now have lost power!?? wth!?? foxbody 4-Cylinder Tech 4 03-30-2010 10:21 AM
lost power firelovesme Electrical Tech 0 01-08-2010 11:45 AM