Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-22-2009, 01:27 AM
milkman milkman is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 3
Default Tps??

Well I have been trying to get this fixed for over a year now. I am at my wits end and am literally about to torch the truck. I have tried 4 different sensors with no avail. I get the 5 volts on the VREF wire but nothing on the other two when I hook the leads from my multimeter to the two as described in this link. Ford Fuel Injection Throttle Position Sensor (TPS)

When I pull the code off its for the tps sensor and thats the only code. I have to emissions it but I cant get the CEL to stay off so its going to fail. Any ideas? You guys are my last hope.........
Reply With Quote
  #2  
Old 08-22-2009, 05:56 AM
DieHard4rd DieHard4rd is offline
The Old Guy
 
Join Date: Jul 2009
Posts: 4,824
Default

Have you tried disconnecting the battery so the computer can reset?
Reply With Quote
  #3  
Old 08-22-2009, 06:50 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Did u change the TPS sensor?
__________________
2005 Edge

Reply With Quote
  #4  
Old 08-22-2009, 07:28 PM
milkman milkman is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 3
Default

Yes to both...... I have tried 4 sensors..... I cant get CEL to stay off.... as in I shut it off then it comes right back on..............
Reply With Quote
  #5  
Old 08-22-2009, 08:06 PM
DieHard4rd DieHard4rd is offline
The Old Guy
 
Join Date: Jul 2009
Posts: 4,824
Default

Ok, after installing the new sensor did you calibrate it to the trucks computer??

You use a TPMS tool. Put the computer into training mode & reprogram each tire sensor in sequence. Starting LF RF RR LR.
Reply With Quote
  #6  
Old 08-22-2009, 08:46 PM
surfer03133 surfer03133 is offline
Dead Whales Everywhere!
 
Join Date: May 2009
Posts: 929
Send a message via Skype™ to surfer03133
Default

have you driven the truck at all since then? to get the pcm to acknowledge new information sensors the truck needs to be driven at 10 mph for a little while to get the pcm working
__________________
08 Ranger Sport 2wd
aFe CAI, 30x9.5.x15 Grabber AT2s, U/D pulleys, flowmaster super 44

"Those who make peaceful revolution impossible will make violent revolution inevitable."
- John F. Kennedy

"Somehow the "god of the athiests" delivers more miracles than all other religion combined than..."
Reply With Quote
  #7  
Old 08-23-2009, 06:52 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Quote:
Originally Posted by SNOWBALL09 View Post
Ok, after installing the new sensor did you calibrate it to the trucks computer??

You use a TPMS tool. Put the computer into training mode & reprogram each tire sensor in sequence. Starting LF RF RR LR.
Not a Tire Pressure Monitor System

TPS = Throttle Position Sensor
__________________
2005 Edge

Reply With Quote
  #8  
Old 08-23-2009, 08:14 AM
DieHard4rd DieHard4rd is offline
The Old Guy
 
Join Date: Jul 2009
Posts: 4,824
Default

Lmao.. Oops
Reply With Quote
  #9  
Old 08-23-2009, 11:28 AM
milkman milkman is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 3
Default

yes I have driven it at least 10 miles.....its been a process of over a year so probably around 12000 miles..
Reply With Quote
  #10  
Old 08-23-2009, 11:39 AM
surfer03133 surfer03133 is offline
Dead Whales Everywhere!
 
Join Date: May 2009
Posts: 929
Send a message via Skype™ to surfer03133
Default

ooo lol, then i dunno what to tell you. maybe the pcm is bad?
__________________
08 Ranger Sport 2wd
aFe CAI, 30x9.5.x15 Grabber AT2s, U/D pulleys, flowmaster super 44

"Those who make peaceful revolution impossible will make violent revolution inevitable."
- John F. Kennedy

"Somehow the "god of the athiests" delivers more miracles than all other religion combined than..."
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search