Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 08-20-2009, 12:19 PM
tubzilla tubzilla is offline
Learning to use the forums
Join Date: Aug 2009
Posts: 2
Default fan control issue

my heater/ac fan works in low on every switch setting except on the highest when it actually changes to the highest speed. could this just be a faulty switch or something worse?
Reply With Quote
Old 08-20-2009, 01:04 PM
DieHard4rd DieHard4rd is offline
The Old Guy
Join Date: Jul 2009
Posts: 4,824

Could be the switch (I would try spraying it with electrical contact cleaner) or the blower motor could be bad. For the different fan speeds the motor engages different phases for the speed.
Reply With Quote
Old 08-21-2009, 03:02 PM
greyghost greyghost is offline
Ford Ranger Driver
Join Date: Aug 2009
Posts: 1,528

i've had similar problems with my old '98 ranger let me explain what i found and maybe it will help you out.
my fan for my heat and ac was blowing on the high setting only. if you look under the hood on the firewall were the heater fan is located you will see a block that has 4 wires in it. i pulled that off and found it all corroded up. what i ended up doing is to make myself a little pic of were the wires went and cut the plug off and crimped new female spade connectors on the ends of the wires. while i was in there i decided that i'd take out the 2 screws that held the heater resistor out and found even more green corrosion.

i went to the stealership {because that's the only frekin place that stocked it in the middle of january} and got a new one at the sum of $27 something, then using my little pic i drew up put my wires back on and i was good to go.

hopefully this gives you a good place to start and i didn't confuse you in the process.
maybe this link will explain it a little better, compliments of trs...

Last edited by greyghost; 08-22-2009 at 09:46 AM. Reason: added link for blower relay
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise control problems FRTruckNut 4.0 SOHC / 4.0 OHV Tech 6 07-03-2012 01:24 PM
Lower Control Arm Duzan1 Suspension Tech 5 08-23-2009 05:48 PM
cruise control kb4422 Electrical Tech 30 07-27-2009 05:40 PM
cruise control bigblock119 General Tech 0 06-15-2009 07:35 AM
hid issue sprtyboy Electrical Tech 1 05-24-2009 07:27 PM