Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-01-2010, 04:29 PM
boodles1960 boodles1960 is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 2
Default Instrument Cluster Quit **HELP**

Bought 95 Ranger XLT used. Driving home, all gauges in instrument cluster quit. Someone said to change the GEM. I have changed both the GEM and instrument cluster with used ones, but with no luck. Called the local Ford dealership, they won't tell me anything other than leave it and they will fix it. I don't have the money for them to play with it. Took it to Autozone & they connected to a computer but said it didn't read any codes. I really need help. Any suggestions would be greatly appreciated. Thanks!
__________________
1995 Ford Ranger XLT 6 cyl 4.0L. Bought used, while driving down road, instrument panel quit (fuel, temp, amp, oil pressure, tach & speedometer). The battery light, airbag light and signal lights work. Replaced GEM with a used GEM, didn't fix. I'm at a loss . . . don't know where to begin looking.
Reply With Quote
  #2  
Old 11-01-2010, 05:21 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Instrument Cluster Quit **HELP**

Did you check the connection behind the cluster?
__________________
2005 Edge

Reply With Quote
  #3  
Old 11-01-2010, 08:01 PM
boodles1960 boodles1960 is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 2
Default Re: Instrument Cluster Quit **HELP**

I've called myself checking it and I've also replaced the cluster and then put back the old one. Autozone said something about maybe a "control module", but they didn't know where it was or what it looked like. They also said that if that was it, it would be a Ford dealer part. I'm still lost . . any other ideas? I've checked fuse boxes. Can you tell me where or what "control module" powers the gauges?
__________________
1995 Ford Ranger XLT 6 cyl 4.0L. Bought used, while driving down road, instrument panel quit (fuel, temp, amp, oil pressure, tach & speedometer). The battery light, airbag light and signal lights work. Replaced GEM with a used GEM, didn't fix. I'm at a loss . . . don't know where to begin looking.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Cluster Question Blackbeauty162 Interior Tech 10 02-27-2012 01:12 PM
Instrument Cluster yodercop Interior Tech 15 07-02-2011 08:09 AM
For Sale: Instrument Cluster earnbud Interior Parts 0 10-08-2010 10:15 PM
instrument cluster and others pmac03 Interior Tech 0 07-18-2010 07:11 PM
Replacing the Instrument Cluster bolivartech General Tech 2 07-02-2010 08:11 AM