Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-30-2010, 07:20 AM
bailthisout bailthisout is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 9
Default guages and warning lights but alt and battery test ok

intermintantly the spedo stops working the bat light comes on the brake lights come on the air bag light comes on then all go back to normal (working no lights) it just started having bursts of higher lighting power with the head lights when the issue takes place

it is a 2007 xlt (made in 06)
V6 4.0L 4x4
Reply With Quote
  #2  
Old 10-30-2010, 07:27 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: guages and warning lights but alt and battery test ok

That is way too many completely unrelated systems to be an actual problem with only one of them. I would start looking around under the dash for large loose electrical connectors that go through the firewall.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #3  
Old 10-30-2010, 07:38 AM
bailthisout bailthisout is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 9
Default Re: guages and warning lights but alt and battery test ok

I did not see anything lose broken or unconected under the hood
could this be a battery issue? also yesterday when it started again it happened first two weeks ago. the green eye was not green but by the time i got to the parts store the eye was green and everything tested ok

off topic- are clarks batt's any good vrs nappa.....???

thanks for the replys and the help im 2000 miles from home
Reply With Quote
  #4  
Old 10-30-2010, 07:42 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: guages and warning lights but alt and battery test ok

No this is not a battery problem. I think it is either centered around the alternator itself or a connection problem under the dash or under the hood in a main wire harness. The brake light, air bags, and charging light are all completely isolated and separate systems. A failure in one can not manifest itself in the others.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #5  
Old 10-30-2010, 07:50 AM
bailthisout bailthisout is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 9
Default Re: guages and warning lights but alt and battery test ok

ok thanks for your help
could the alt be intermitantly not working?
and should i just try to replace it even if its testing ok
can i beat with a hammer or spay something on it.......
Reply With Quote
  #6  
Old 10-30-2010, 08:07 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: guages and warning lights but alt and battery test ok

It's hard to troubleshoot when it is intermittent. The most obvious is an alternator problem. The charging light can only come on when the alternator is not generating power and the circuit has to be intact and complete. Also, the fact that you say the lights get brighter is indicative of an alternator problem.

The ABS, brake lights, and speedo having problems at the same time make no sense as they are all unrelated. Unless the alternator is creating an over-voltage condition that is pissing the systems off.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #7  
Old 10-30-2010, 08:45 AM
bailthisout bailthisout is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 9
Default Re: guages and warning lights but alt and battery test ok

ok so i just figured out that if i rev the engine the problem starts up
the bat light comes on and sometimes the gauges quit
the tach and the fuel gauge go to zero like they are unplugged???
does this help with an idea for a fix???
Reply With Quote
  #8  
Old 10-30-2010, 09:08 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: guages and warning lights but alt and battery test ok

Yes. It says to me your alternator is toast. It's charging at low RPM but as the RPM increases, it shits itself.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #9  
Old 10-30-2010, 09:15 AM
05RangerEdge 05RangerEdge is offline
I'm a sell out
 
Join Date: Jan 2010
Posts: 2,299
Default Re: guages and warning lights but alt and battery test ok

I had a similar problem. Maybe this will help

Battery Light?

I ended up being able to just fix my alternater rather than replacing.
__________________
SOLD: 2005 Ranger EDGE+ Supercab (2dr) 4x2
SOLD: 2007 Dodge Ram 1500 QC 5.7 HEMI
CURRENT: 2015 Tacoma DCLB TRD Sport
Reply With Quote
  #10  
Old 10-30-2010, 10:14 AM
bailthisout bailthisout is offline
Learning to use the forums
 
Join Date: Oct 2010
Posts: 9
Default Re: guages and warning lights but alt and battery test ok

thanks a ton for all of your help and input
on the third time testing it and figureing out that reving it up
showed the problem
i reved hard during the test and the alt
was putting out way too much juice.....19 volts i tnk it was
so i guess it is the regulator in the alt
on a three year old truck come on ford you can do better than that
cant you...... to realy help things out i get to drive almost two hours away
so i can get the new alt.....or pay the same price for a reman and still have to wait three days for it to show up.....
if ford is going to make crap parts they could at least stock them.......
having a great time in moab...............
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with guages on 2.3 Port91 4-Cylinder Tech 16 04-15-2011 06:54 PM
Low RPMS, lights dim, Battery starts to die TomN Electrical Tech 13 10-12-2010 10:12 AM
Swapping out guages in a 96 xlt AntDiN Interior Tech 15 10-09-2010 03:30 PM
alt. question Fluffy 3.0 Vulcan Tech 4 08-08-2010 04:30 AM
will alt. for 91 aerostar 3.0L work on 89 ranger 2.3L? foxbody Electrical Tech 4 11-09-2009 08:22 PM