Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-10-2009, 01:42 PM
atrocity atrocity is offline
meet me in outer space
 
Join Date: Jun 2009
Posts: 334
Send a message via AIM to atrocity
Default foglamp fuse?

Ever since i got my ranger the foglamps havn't worked, it doesn't look like the bulbs are out. I have a feeling the fuse blew, the manual doesn't say which fuse belongs to the fogs. Truck is an 04 ranger edge.
Reply With Quote
  #2  
Old 08-10-2009, 01:50 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Open your hood box on right side by the fire wall fuse #31 fuse size 15A
__________________
2005 Edge

Reply With Quote
  #3  
Old 08-10-2009, 02:27 PM
atrocity atrocity is offline
meet me in outer space
 
Join Date: Jun 2009
Posts: 334
Send a message via AIM to atrocity
Default

oh wow i was only lookin in the fuse box in the cab. Ill check that out to see if it works, thanks.
Reply With Quote
  #4  
Old 08-22-2009, 03:17 PM
atrocity atrocity is offline
meet me in outer space
 
Join Date: Jun 2009
Posts: 334
Send a message via AIM to atrocity
Default

i tried both boxes and the fuses were still good, any ideas? What should the bulbs look like if they're done?
Reply With Quote
  #5  
Old 08-22-2009, 03:37 PM
greyghost greyghost is offline
Ford Ranger Driver
 
Join Date: Aug 2009
Posts: 1,528
Default

i'd take the plugs off the back of the bulbs and test to see if your getting juice through the plug. you could use a normal test light and ground it to the frame or just anywere you can find near by. if your getting juice in both plugs then your bulbs need replaced.
Reply With Quote
  #6  
Old 08-22-2009, 06:13 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

take the bulb out and if the little wire is not connecting the two post it is gone
__________________
2005 Edge

Reply With Quote
  #7  
Old 08-29-2009, 01:50 PM
eks22 eks22 is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 1
Default

Hey I've got the same problem with my 04 Ranger. Does your turn signals come on full when you turn the headlights on but not the fog lights, cause that is what mine do. I tried all the fuses to no avail. It seems like a relay problem to me but I don't know
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
'95 Speedometer light/fuse? CWS23 General Tech 2 07-23-2011 05:40 PM
Fuse Box jkref282 Electrical Tech 1 08-10-2009 01:36 PM
Blowing Fuse 24 Mike1987 Electrical Tech 0 05-13-2009 04:06 AM