Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-11-2010, 06:49 AM
TomN TomN is offline
<-----Needs moar liftz
 
Join Date: Jun 2010
Posts: 1,125
Default Low RPMS, lights dim, Battery starts to die

Ive got a problem goin on now that I had before, fixed, returned, fixed and now have a new problem. Not to long, maybe 2 months ago, anytime my truck would go over 3000 RPMS, the battery light would come on, and the battery dial would slowly creep down. I did some research and found a new voltage regulator and alternator brushes would probably do the trick. I ordered them from advanced, and replaced them. When I removed the old ones, one of the brushes was worn so far down i doubt it was making contact. I put my new parts in and the truck was fine. Until 2 nights ago when it started doing the same thing again. Pulled out the alternator, removed the regulator and brushes to find the same problem again. Same brush was worn down again to the same extent. Common sense told me something in the alt is messing up the brushes. Funds are tight so I went up to the junkyard to grab me a new alternator. I got a manufactured one and threw it in my truck. Truck ran better but now the battery starts to die at low RPMS. WTF? I put the the new voltage regulator i bought 2 months ago and the brushes from the junkyard alt in and still same problem. I'm lost here. Any ideas?

Thanks in advance.
__________________
1997 Ranger XLT
4.0 4X4 Lotta Mods.

2001 Ford Crown Victoria Police Interceptor. 4.6 V8

Quote:
Originally Posted by richarddhoward View Post
my truck will rape your Honda.
Reply With Quote
  #2  
Old 10-11-2010, 07:19 AM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Low RPMS, lights dim, Battery starts to die

High demand on battery puts a high demand on the alternator.
What's the wattage of that Alpine system?
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #3  
Old 10-11-2010, 07:26 AM
TomN TomN is offline
<-----Needs moar liftz
 
Join Date: Jun 2010
Posts: 1,125
Default Re: Low RPMS, lights dim, Battery starts to die

There is no sub. I do have the KTP-445 whic is a mini amp. Thats is a 45 watt amp.

From Crutchfield:

Details:
•plug-and-play compact Class D amplifier for Alpine in-dash receivers
•4-channel amplifier
•45 watts RMS x 4 at 4 ohms (CEA-2006 compliant)
•selectable gain switch (high/low)
•fuse: 15A
•2-9/16"W x 1-1/2"H x 7-13/16"D
•warranty: 1 year
__________________
1997 Ranger XLT
4.0 4X4 Lotta Mods.

2001 Ford Crown Victoria Police Interceptor. 4.6 V8

Quote:
Originally Posted by richarddhoward View Post
my truck will rape your Honda.
Reply With Quote
  #4  
Old 10-11-2010, 02:26 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Low RPMS, lights dim, Battery starts to die

Well that's not enough draw to break a stock alternator.
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #5  
Old 10-11-2010, 03:59 PM
TomN TomN is offline
<-----Needs moar liftz
 
Join Date: Jun 2010
Posts: 1,125
Default Re: Low RPMS, lights dim, Battery starts to die

Quote:
Originally Posted by mickblock View Post
Well that's not enough draw to break a stock alternator.
Thats what I thought. Even just turning the headlights make the battery start going
__________________
1997 Ranger XLT
4.0 4X4 Lotta Mods.

2001 Ford Crown Victoria Police Interceptor. 4.6 V8

Quote:
Originally Posted by richarddhoward View Post
my truck will rape your Honda.
Reply With Quote
  #6  
Old 10-11-2010, 04:07 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Low RPMS, lights dim, Battery starts to die

You got a repair manual? Need to start learning/doing some charging system tests.
If the battery is old and done for, it could be putting too much draw on the alternator. You can do a load test or have one done at AZ to find out.
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #7  
Old 10-11-2010, 04:31 PM
TomN TomN is offline
<-----Needs moar liftz
 
Join Date: Jun 2010
Posts: 1,125
Default Re: Low RPMS, lights dim, Battery starts to die

The battery was replaced back in April. I hope its not done yet, but its under warrenty. I do have a repair manual. If your talking about voltage, I have done that before but not since switching the regulator.
__________________
1997 Ranger XLT
4.0 4X4 Lotta Mods.

2001 Ford Crown Victoria Police Interceptor. 4.6 V8

Quote:
Originally Posted by richarddhoward View Post
my truck will rape your Honda.
Reply With Quote
  #8  
Old 10-11-2010, 04:51 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Low RPMS, lights dim, Battery starts to die

Well if you know the right tests and know the right voltage specs to look for cool. But there's no reason you should be left scratching your head. Maybe you can read up on it and save yourself some frustration ya know?

Did you do all the preliminary stuff like clean the terminals? That stuff can make a big difference.
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #9  
Old 10-11-2010, 04:55 PM
TurdFX4 TurdFX4 is offline
Sept. 2011 TOTM
 
Join Date: Jan 2010
Posts: 1,771
Default Re: Low RPMS, lights dim, Battery starts to die

I had an issue after doing the body lift, where when it was idling, the needle would bounce around, a/c would blow out hot air, and the battery kept going dead. I soon realized it was a bad ground, the one that goes from the engine block to the firewall, it just wasnt tight enough. I know its not the same problem as yours but it may be able to help you out. Maybe just a bad ground somewhere?
Reply With Quote
  #10  
Old 10-11-2010, 05:10 PM
ranger024x4 ranger024x4 is offline
dumpster fire
 
Join Date: Sep 2010
Posts: 5,372
Default Re: Low RPMS, lights dim, Battery starts to die

Quote:
Originally Posted by TurdFX4 View Post
I had an issue after doing the body lift, where when it was idling, the needle would bounce around, a/c would blow out hot air, and the battery kept going dead. I soon realized it was a bad ground, the one that goes from the engine block to the firewall, it just wasnt tight enough. I know its not the same problem as yours but it may be able to help you out. Maybe just a bad ground somewhere?
I was thinking the same thing. Check/clean all grounds
Reply With Quote
  #11  
Old 10-11-2010, 06:57 PM
TomN TomN is offline
<-----Needs moar liftz
 
Join Date: Jun 2010
Posts: 1,125
Default Re: Low RPMS, lights dim, Battery starts to die

I will check the grounds in the AM. Could this have anything to do with my junkyard Alt?
__________________
1997 Ranger XLT
4.0 4X4 Lotta Mods.

2001 Ford Crown Victoria Police Interceptor. 4.6 V8

Quote:
Originally Posted by richarddhoward View Post
my truck will rape your Honda.
Reply With Quote
  #12  
Old 10-11-2010, 07:15 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Low RPMS, lights dim, Battery starts to die

Kind of hard to say that after you mentioned the same thing happening to the previous alternator.
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #13  
Old 10-11-2010, 07:51 PM
TurdFX4 TurdFX4 is offline
Sept. 2011 TOTM
 
Join Date: Jan 2010
Posts: 1,771
Default Re: Low RPMS, lights dim, Battery starts to die

Quote:
Originally Posted by TomN View Post
I will check the grounds in the AM. Could this have anything to do with my junkyard Alt?
Possibley. Its always hit or miss with junkyard parts. advance auto can test your alternator and battery for you
Reply With Quote
  #14  
Old 10-12-2010, 10:12 AM
TomN TomN is offline
<-----Needs moar liftz
 
Join Date: Jun 2010
Posts: 1,125
Default Re: Low RPMS, lights dim, Battery starts to die

Quote:
Originally Posted by mickblock View Post
Kind of hard to say that after you mentioned the same thing happening to the previous alternator.
This is the first time its done this at low RPMS. Last time was only at higher ones. 3K and up. I checked my grounds and all seem clear. I have 2 concerts today and tomorow, and one of the is in New York. So as a last ditch effort I put new brushes in my my old alt and threw that in. Its running like a champ for now. That is until the brushes wear down again, but it should hold me long enough until I can afford a new alt.
__________________
1997 Ranger XLT
4.0 4X4 Lotta Mods.

2001 Ford Crown Victoria Police Interceptor. 4.6 V8

Quote:
Originally Posted by richarddhoward View Post
my truck will rape your Honda.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3, starts fine, dies right way, starts runs rough for about 15 seconds JBusch 4-Cylinder Tech 4 10-07-2011 03:00 PM
Sputter/Die after battery disconnect?? (Not sure where to post) bordum128 Electrical Tech 7 06-21-2010 06:01 PM
Poor Idle/Die after battery disconnected! HELP!! bordum128 3.0 Vulcan Tech 2 06-21-2010 02:49 PM
check engine and battery low js250 General Tech 5 04-09-2010 12:25 PM
2.9 wont rev at all. starts and idles (low) but NO rev above playaforiife 2.9 Liter Tech 5 11-18-2009 12:02 PM