Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-01-2010, 07:56 PM
Dcrymes99ranger Dcrymes99ranger is offline
Explorer seats are in
 
Join Date: Oct 2009
Posts: 6,176
Default Need some help figuring out why I have no turn signals.

So my turn signals have been out for a few days. I bought a new turnsignal switch from work and replaced it. Still nothing. No clicking on the dash, no lights light up on the dash for the turn signals. No outside turn signal lights. So I replaced the fueses under the hood. Still nothing. Anyone got a clue on what else it could be? Could there be another fuse in the side of the dash?
__________________
1999 Ford Ranger 3.0xl


My Build Thread!!!
Reply With Quote
  #2  
Old 10-02-2010, 05:37 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Need some help figuring out why I have no turn signals.

The turn signal fuse is not under the hood. Its in the dashboard fuse panel.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #3  
Old 10-02-2010, 08:47 AM
Dcrymes99ranger Dcrymes99ranger is offline
Explorer seats are in
 
Join Date: Oct 2009
Posts: 6,176
Default Re: Need some help figuring out why I have no turn signals.

So I fixed the problem. I checked the fuse in the side of the dash on the driverside, and there wasn't even a fuse in the slot it goes. So I put a fuse in it and whallaaa....
__________________
1999 Ford Ranger 3.0xl


My Build Thread!!!
Reply With Quote
  #4  
Old 10-02-2010, 08:55 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Need some help figuring out why I have no turn signals.

Yes, that would certainly cause the signals to not work.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #5  
Old 10-02-2010, 07:06 PM
Dcrymes99ranger Dcrymes99ranger is offline
Explorer seats are in
 
Join Date: Oct 2009
Posts: 6,176
Default Re: Need some help figuring out why I have no turn signals.

Quote:
Originally Posted by FireRanger View Post
Yes, that would certainly cause the signals to not work.
Ok so today I swapped the fuse and when I did the signals worked. But as I drove it the over drive light was flashing and then the transmission was shifting really hard. So I buy a fuse for that and the wipers stay on constantly. Well after I put my old turn signal switch back in my radio constantly stayed on, and no wipers. Well I replaced the wiper relay in the fuse box under the hood and radio works fine wipers work fine and the signals work fine. After a 12.00 relay and about 10.00 of fuses I fix my problem.
__________________
1999 Ford Ranger 3.0xl


My Build Thread!!!
Reply With Quote
  #6  
Old 10-02-2010, 08:18 PM
FoMoCo FoMoCo is offline
RF.net ban camp founder
 
Join Date: Apr 2009
Posts: 1,816
Default Re: Need some help figuring out why I have no turn signals.

don't need any turn signals, no one ever uses them
__________________
2012 mustang premium v6 pony package
702 crew
XBGT:IKONIK MOPAR
Reply With Quote
  #7  
Old 10-02-2010, 08:49 PM
aaron_ariens aaron_ariens is offline
NO H8.
 
Join Date: Jan 2010
Posts: 2,435
Send a message via AIM to aaron_ariens Send a message via MSN to aaron_ariens
Default Re: Need some help figuring out why I have no turn signals.

Quote:
Originally Posted by FoMoCo View Post
don't need any turn signals, no one ever uses them
In Oregon thats true.
__________________
2001 Ford Ranger XLT 3.0 V6 Automatic.
1995 Acura Integra LS
PNW Crew!
http://www.facebook.com/aaron.ariens

Quote:
Originally Posted by richarddhoward View Post
Lol, Aaron: "I only text with trees, it makes it hard to text while driving though, I have to keep running the truck into trees to text!!" EPIC my friend. Lol
Reply With Quote
  #8  
Old 10-03-2010, 12:20 AM
FoMoCo FoMoCo is offline
RF.net ban camp founder
 
Join Date: Apr 2009
Posts: 1,816
Default Re: Need some help figuring out why I have no turn signals.

happens in washington as well
__________________
2012 mustang premium v6 pony package
702 crew
XBGT:IKONIK MOPAR
Reply With Quote
  #9  
Old 10-03-2010, 01:12 AM
Fx4wannabe01 Fx4wannabe01 is offline
Ford Ranger Driver
 
Join Date: Sep 2009
Posts: 4,058
Default Re: Need some help figuring out why I have no turn signals.

posts 1-5 are EL OH EL.
__________________
'01 XLT disguised as a '03 Fx4 Level II.
Reply With Quote
  #10  
Old 10-03-2010, 05:35 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Need some help figuring out why I have no turn signals.

Quote:
Originally Posted by Dcrymes99ranger View Post
Ok so today I swapped the fuse and when I did the signals worked. But as I drove it the over drive light was flashing and then the transmission was shifting really hard. So I buy a fuse for that and the wipers stay on constantly. Well after I put my old turn signal switch back in my radio constantly stayed on, and no wipers. Well I replaced the wiper relay in the fuse box under the hood and radio works fine wipers work fine and the signals work fine. After a 12.00 relay and about 10.00 of fuses I fix my problem.
Uh. Wow. If everything keeps working fine, then just pretend none of that ever happened.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #11  
Old 10-03-2010, 08:23 AM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: Need some help figuring out why I have no turn signals.

Quote:
Originally Posted by aaron_ariens View Post
In Oregon thats true.
Haha true

Quote:
Originally Posted by FoMoCo View Post
happens in washington as well
Only to avoid retarded Oregon drivers *cough*
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #12  
Old 10-03-2010, 08:46 AM
Dcrymes99ranger Dcrymes99ranger is offline
Explorer seats are in
 
Join Date: Oct 2009
Posts: 6,176
Default Re: Need some help figuring out why I have no turn signals.

Quote:
Originally Posted by richarddhoward View Post
Haha true



Only to avoid retarded Oregon drivers *cough*
lol
__________________
1999 Ford Ranger 3.0xl


My Build Thread!!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signals and Hazards stopped working all of the sudden. Suggestions? holyriverjordan Electrical Tech 7 12-24-2016 11:19 AM
wierd issue with turn signals....... lifted88 Exterior Tech 0 02-26-2010 11:48 AM
no hazards or turn signals or speedo 99 xlt 2wd 5spd DSMissed Electrical Tech 14 12-27-2009 02:09 PM
turn signals tompesar Electrical Tech 5 10-29-2009 06:18 PM
Turn signals not working Poody86 Electrical Tech 8 10-08-2009 08:52 PM