Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-28-2010, 08:44 AM
nikks nikks is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 3
Default Help please! I'm stumped (issue with the flasher)

So I noticed that my turning signal was sounding way too fast while driving, I recognized that usually means that there is a burnt out bulb I pulled over to check...and lets just say It gets soo messed up that I wish it was just a burnt out bulb

You see the driving light still works but doesn't flash in the front, and the rear turn signal works and flashes

but its faster than normal the hazard light works on every other light but the front passenger side

also the instrument cluster doesn't show a signal for turning right I can only hear the back one over working

I know the bulb thing is not the issue because it will stay steady, soo it has to be some kind of problem from the steering wheel to the bulb...some kind of signal not being sent...a wire issue....Help please !!

The make is a 2003 ford ranger
Reply With Quote
  #2  
Old 09-28-2010, 08:48 AM
ranger5572 ranger5572 is offline
2004 XLT with a few mods
 
Join Date: Jun 2010
Posts: 312
Default Re: Help please! I'm stumped (issue with the flasher)

check the relay
__________________
2004 XLT 4.0 4x4, 3" PA body lift, 32" BFG M/Ts, Dick Cepek DC-2 wheels, Euro tailights, self-painted headlight mod, NAV/DVD/XM/iPod stereo (Pioneer AVIC-D3), Line-X, Westin step bars, AVS bug shield and window vents
Reply With Quote
  #3  
Old 09-28-2010, 08:48 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Help please! I'm stumped (issue with the flasher)

I have to guess and say check the signal relay
Reply With Quote
  #4  
Old 09-28-2010, 09:02 AM
DieHard4rd DieHard4rd is offline
The Old Guy
 
Join Date: Jul 2009
Posts: 4,824
Default Re: Help please! I'm stumped (issue with the flasher)

I disagree with them both.


I say it's the relay
__________________
www.1fun4rd.blogspot.com
Reply With Quote
  #5  
Old 09-28-2010, 09:56 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Help please! I'm stumped (issue with the flasher)

Actually I disagree with all of you. You're making this way too complicated. You have a burned out turn signal bulb in the front and probably a burned out indicator bulb on the dash. The bulbs in the front and back have two filiments in them. One for the parking lights and one for the signals. The signal one is burned out. Just replace the bulb.

The flasher (not a relay ) sounds like it is working properly and doing exactly what it is supposed to do. The hazzards are a seperate flasher and work differently which is why it acts differently.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #6  
Old 09-28-2010, 10:40 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Help please! I'm stumped (issue with the flasher)

Quote:
Originally Posted by FireRanger View Post
Actually I disagree with all of you. You're making this way too complicated. You have a burned out turn signal bulb in the front and probably a burned out indicator bulb on the dash. The bulbs in the front and back have two filiments in them. One for the parking lights and one for the signals. The signal one is burned out. Just replace the bulb.

The flasher (not a relay ) sounds like it is working properly and doing exactly what it is supposed to do. The hazzards are a seperate flasher and work differently which is why it acts differently.
Yeah, I would go with what this guy says!
Reply With Quote
  #7  
Old 09-28-2010, 08:15 PM
nikks nikks is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 3
Default Re: Help please! I'm stumped (issue with the flasher)

About the bulbs I actually switch the ones from the left (working side) to the right side and it still didn't do anything. I even went as far as tearing apart my dash to get at the dash indicators to switch and change the bulbs and still nothing happened...
Today I swapped out the flasher "relay" and it still didn't work, the only difference was that the ticking sound wasn't abnormally fast anymore.....but still the right front turn signal did nothing
Reply With Quote
  #8  
Old 09-28-2010, 08:21 PM
nikks nikks is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 3
Default Re: Help please! I'm stumped (issue with the flasher)

Thanks for the advise though any possible solutions help! I'll eventually find the problem through trail and error....I guess... as much as a pain in the ass it's proving to be ha
Reply With Quote
  #9  
Old 09-29-2010, 03:36 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Help please! I'm stumped (issue with the flasher)

Its not making a fast flash because your new aftermarket flasher doesn't have that feature.

You have a wiring problem that will need a diagram to trace out. Pick up a Haynes or Chilton manual, they have all the wiring schematics.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #10  
Old 11-13-2010, 08:06 AM
Flash Flash is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 4
Default Re: Help please! I'm stumped (issue with the flasher)

I have been working on this problem for Nikks for quite some time now. It still perplexes us.

It was my hope that the symptoms described would trigger and answer from the forum, something common and simple experienced by others.

The right front signal does not work, neither does the dash indicator. When activated the right rear flashes double speed. The Hazards do not flash on the front right or the dash (right) either.
The obvious answer to a quickly flashing signal is a burnt out bulb somewhere in the curcit. I changed the front bulbs, no change. I changed the dash bulb, no change. I changed the right rear bulb even though it was working thinking there may have been some sort of short in it, no change.
I have checked the fuses, many times. Nikks changed the Flasher, no change.
Yesterday I did it all again thinking I may have missed something. Fuses, grounds, new Bulb in front, new bulb in rear, took apart the dash and tested the bulb there - no change.

When I tested for power at the front bulb I didn't find any, the white wire should have been pulsing. I also tested for power at the back of the cluster, again didn't find any at the bulb. I traced the curcit on the back of the cluster to one of the plugs there, found power in 2 wires but none pulsing and not in the 2 wires I identified as being related to the dash indicator.

I have experienced the 'fast flashing signal' before but never with the dash light out also. I'm thinking that this is the symptom that may lead to the answer from one of the members here.
The flasher is working as shown by the rear bulb flashing double speed, that part of the circut is functional. The problem appears to be between the flasher, the dash bulb, and the front bulb.
It would be great to understand the flow of the power to the signals-Battery>ignition>multi function switch>flasher>dash>F&R bulbs. but that doesn't appear to be the way it is as the power is working from the flasher to the rear just fine but does not make it to the dash or front bulb. Will the wiring diagram lead me in the right direction or will I end up having to open up the wiring harness? cuz I'd rather set the sucker on fire.
Reply With Quote
  #11  
Old 11-14-2010, 04:57 PM
Flash Flash is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 4
Default Re: Help please! I'm stumped (issue with the flasher)

Found it!

I went and bought the Haynes Manual as suggested. The only thing in it of any use (so far) was the wiring diagram on the last page. This confirmed the Circut I was looking for and the White with Blue Tracer wire I needed to track down.
This led me to the Multi Function Switch in the colum. There was White & Blue and sure enough it was loose. Pushed it in and everything functioned as it should.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
This really has me stumped about the CC recall EMB1230 General Tech 14 06-11-2014 06:46 AM
this has got me stumped... pyro29123 2.9 Liter Tech 4 09-26-2010 10:24 AM
Who hid my flasher? Where? PaulBennett Interior Tech 3 08-22-2010 10:46 PM
I'm Stumped and would appreciate some help midnightfireman 3.0 Vulcan Tech 24 04-02-2010 05:26 PM
Stumped kicknfiresout Electrical Tech 7 10-13-2009 04:46 AM