Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-21-2010, 04:00 PM
btm757 btm757 is offline
In Memory of Jason Finn
 
Join Date: Jul 2010
Posts: 748
Default HELP HELP: No Wipers! or Radio

to start I have a 2004 Supercab, 4.0L 4x4. After market radio

My radio the bast couple of months my radio would occasionally loose power with the key off and I would lose all my presets. well the past couple of weeks it would do it alot. This past week while driving all of a sudden the radio just went dead, I thought ahh crap this sucks, I got to where I was going took the radio out wiggled the wires and radio came back on. well its done it a few times now and then today I got in turned the key and no radio. so i messed with it for about 10 mins and the radio would not come back on. So I came home and on my way home I found out. My wipers or Washer wouldnt work at all.

I got home ran down all my fuses and they are all good.
The connection on the plug from the radio the battery wire looked like it had gotten kinda hot.
Opened the hood ran all the fuses down and they were all good.
Neither relay clicked when I pushed the switch or turned the knob.

I have had no other electrical problems
And this is the first time the wipers have done this.


Please any help would be greatly appreciated
Reply With Quote
  #2  
Old 09-21-2010, 04:09 PM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default Re: HELP HELP: No Wipers! or Radio

i would bet the two dont have anything to do with each other. the wiper thing is likely a multi function switch issue, i had a similar problem with my 96 ranger, sucky part is that the multi function switch is pretty pricey unless you find one at a junkyard but its simple to replace. now the radio, is it wired into the stock radio wiring harness or is it wired to a seperate ACC and constant circuit? either way i would pull the radio and follow the wires and look for a break somewhere, it sounds like a wire is broken or the plug isnt making good contact on the back of the radio.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #3  
Old 09-21-2010, 05:23 PM
btm757 btm757 is offline
In Memory of Jason Finn
 
Join Date: Jul 2010
Posts: 748
Default Re: HELP HELP: No Wipers! or Radio

How would I test to see if its the muti function switch?

I have the Radio harness wired into the harness adapter that is plugged into the factory harness
Reply With Quote
  #4  
Old 09-21-2010, 07:43 PM
darangerdanger darangerdanger is offline
GOT r' done :D
 
Join Date: Sep 2010
Posts: 430
Default Re: HELP HELP: No Wipers! or Radio

also you should check all the fuses just to be safe.

when i bought my truck someone had the wrong fuse for the radio/wipers/signals and they burnt out twice before i realized what was going on.
__________________
Sold-03 2wd edge. McQueen glass and 35's
New!- 1990 2.3 reg cab- 5/7 drop, cobra brakes, Hurst short shifter, sir Michael's rollpan
Daily-2003 5.4 supercrew 6" fabtech on 35's and too many mods
Reply With Quote
  #5  
Old 09-22-2010, 09:04 AM
stephen.g.fiddes stephen.g.fiddes is offline
Next-best to Chuck Norris
 
Join Date: Feb 2010
Posts: 795
Default Re: HELP HELP: No Wipers! or Radio

Quote:
Originally Posted by darangerdanger View Post
also you should check all the fuses just to be safe.

when i bought my truck someone had the wrong fuse for the radio/wipers/signals and they burnt out twice before i realized what was going on.
He already said that he checked them. If it was fuses it would not do anything when he wiggled the wires.

Quote:
Originally Posted by btm757 View Post
How would I test to see if its the muti function switch?

I have the Radio harness wired into the harness adapter that is plugged into the factory harness
If it looks like your wires got hot, there is something shorting somewhere, or too much current being drawn for the wires to handle. Both should be stopped by a fuse, but you said all your fuses were good. First, check that there isnt a 25A fuse in a 15A fuse slot etc.

That, i'm willing to bet will not be a permanent fix. You should also check your wiring harness for shorting in the connection to the radio. Once you have that fixed, it should not be a problem anymore.



and x2 on what Pat said about the multi-function switch
__________________
Schwinn Super-Sport, Nikon D90 ROLLED: 2001 Ford Ranger XLT Super Cab 4X4MODS
Quote:
Originally Posted by Fourliter Dan View Post
and as for boobs, as long as the cant hold up a book with sag, pointed in the right direction and not peperoni or canadian bacon nips were good to go!
Quote:
Originally Posted by Fx4wannabe01 View Post
ok...i'll just come out and say it... you got's an auto. That alone revokes your right to brag about being part of the elite Level II's! Take that!
Quote:
Originally Posted by Clinton View Post
Oh come on....every girl likes pink....even Demon
Buy my pictures at Imagekind!
Reply With Quote
  #6  
Old 09-22-2010, 09:18 AM
mossyoak03 mossyoak03 is offline
hillbilly
 
Join Date: Sep 2009
Posts: 657
Send a message via AIM to mossyoak03
Default Re: HELP HELP: No Wipers! or Radio

Quote:
Originally Posted by stephen.g.fiddes View Post
He already said that he checked them. If it was fuses it would not do anything when he wiggled the wires.
he was telling him to check the amps of the fuse if you had any common sense.
__________________
Mud holes are like a pretty woman with an std, you want to hit but are scared of the consequences!

4wd is like a condom. i'd rather have it and not need it rather tan needing it and not having it!
Reply With Quote
  #7  
Old 09-22-2010, 09:19 AM
stephen.g.fiddes stephen.g.fiddes is offline
Next-best to Chuck Norris
 
Join Date: Feb 2010
Posts: 795
Default Re: HELP HELP: No Wipers! or Radio

Quote:
Originally Posted by mossyoak03 View Post
he was telling him to check the amps of the fuse if you had any common sense.
Woah... simmer down. I thought you meant check that the fuses were good.
__________________
Schwinn Super-Sport, Nikon D90 ROLLED: 2001 Ford Ranger XLT Super Cab 4X4MODS
Quote:
Originally Posted by Fourliter Dan View Post
and as for boobs, as long as the cant hold up a book with sag, pointed in the right direction and not peperoni or canadian bacon nips were good to go!
Quote:
Originally Posted by Fx4wannabe01 View Post
ok...i'll just come out and say it... you got's an auto. That alone revokes your right to brag about being part of the elite Level II's! Take that!
Quote:
Originally Posted by Clinton View Post
Oh come on....every girl likes pink....even Demon
Buy my pictures at Imagekind!
Reply With Quote
  #8  
Old 09-22-2010, 03:17 PM
btm757 btm757 is offline
In Memory of Jason Finn
 
Join Date: Jul 2010
Posts: 748
Default Re: HELP HELP: No Wipers! or Radio

This is my radio Harness. This is the part that plugs into the factory harness Yellow wire is battery feed


The brown pin on the plug is the battery feed


Factory Harness. Far right bottom hole is battery feed
Reply With Quote
  #9  
Old 09-22-2010, 03:32 PM
stephen.g.fiddes stephen.g.fiddes is offline
Next-best to Chuck Norris
 
Join Date: Feb 2010
Posts: 795
Default Re: HELP HELP: No Wipers! or Radio

The best I can make out of it is too much current being pulled through it and getting hot.
__________________
Schwinn Super-Sport, Nikon D90 ROLLED: 2001 Ford Ranger XLT Super Cab 4X4MODS
Quote:
Originally Posted by Fourliter Dan View Post
and as for boobs, as long as the cant hold up a book with sag, pointed in the right direction and not peperoni or canadian bacon nips were good to go!
Quote:
Originally Posted by Fx4wannabe01 View Post
ok...i'll just come out and say it... you got's an auto. That alone revokes your right to brag about being part of the elite Level II's! Take that!
Quote:
Originally Posted by Clinton View Post
Oh come on....every girl likes pink....even Demon
Buy my pictures at Imagekind!
Reply With Quote
  #10  
Old 09-26-2010, 09:49 AM
btm757 btm757 is offline
In Memory of Jason Finn
 
Join Date: Jul 2010
Posts: 748
Default Re: HELP HELP: No Wipers! or Radio

Any more Ideas
Reply With Quote
  #11  
Old 09-26-2010, 06:08 PM
Melbob1156 Melbob1156 is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 11
Default Re: HELP HELP: No Wipers! or Radio

Look behind the radio and you may have to remove the vent tube, look at the firewall for a ground. I'm only guessing here but because the radio and wiper motor are located close to the center of the vehicle, I know from my 97 that their is a body ground in that location. Overheated wires with the lack of a blown fuse indicates a loose ground. Because their is no + to - connection (direct short) the fuse won't blow. Because the wires can be loose enough to arc and still remain connected to maintain a completed circuit, the repetitious spike in power will cause the wire to heat and melt. And of course, from time to time the connection may be lost for long periods and then for no reason (just the right vibration) the power can be restored.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wipers Don't Work! ARENG01 Electrical Tech 8 06-07-2016 01:44 PM
wipers js250 Electrical Tech 2 10-06-2014 08:59 AM
Windshield wipers not stopping. Longhaireddwb Electrical Tech 6 04-22-2014 08:15 PM
windshield wipers brannonmetal Exterior Tech 1 10-29-2009 04:43 PM
wipers randomely go on crarg6 Electrical Tech 2 10-10-2009 10:17 PM