Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-31-2010, 05:32 AM
k5tpa k5tpa is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 11
Default Was no Odometer now Not charging

96 Ranger Supercab 4.0 Auto, unfortunately stock...

My odometer was not working so I removed the instrument cluster. I wanted to verify the worm gear was bad, it is. I left the instrument cluster out so I don't have to remove it again to put the new gear in. I drove the truck to work yesterday and it was fine. Today the headlights were dim then there was a beeping like a UPS when the power goes out. The truck was losing power, I turned the lights and AC off to make it the last mile to work. The battery is drained, the alternator is not charging.

If you remove the instrument cluster (including volt gauge) will this make the alternator not charge?
Reply With Quote
  #2  
Old 08-31-2010, 05:34 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Was no Odometer now Not charging

I never heard that before
Reply With Quote
  #3  
Old 08-31-2010, 05:44 AM
k5tpa k5tpa is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 11
Default Re: Was no Odometer now Not charging

I can't imagine why it would matter but it is just too coincidental... I have to wait until I get home to plug the instrumential cluster back in and see if it begins to charge. Only I had plans to do something else tonight...
Reply With Quote
  #4  
Old 08-31-2010, 05:22 PM
drppdyllwrngr drppdyllwrngr is offline
Ford Ranger Driver
 
Join Date: Feb 2010
Posts: 3,122
Default Re: Was no Odometer now Not charging

if the cluster is out, the alternator will NOT charge. the battery light in the cluster is part of the charging system.
__________________
Krylon Fusion is for Amateurs.
Reply With Quote
  #5  
Old 09-01-2010, 02:16 AM
k5tpa k5tpa is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 11
Default Re: Was no Odometer now Not charging

Put a new worm gear in from the junkyard. Odometer is working and the battery is charging. It all worked out but what a pain that was...
Reply With Quote
  #6  
Old 09-01-2010, 03:14 AM
Coleosis Coleosis is offline
The Sickest
 
Join Date: Jun 2009
Posts: 451
Default Re: Was no Odometer now Not charging

Is there a way to bypass it? Like if you're doing a swap and want to replace the cluster with all custom gauges?
Reply With Quote
  #7  
Old 09-01-2010, 03:39 AM
drppdyllwrngr drppdyllwrngr is offline
Ford Ranger Driver
 
Join Date: Feb 2010
Posts: 3,122
Default Re: Was no Odometer now Not charging

wire in a light bulb that is tucked away in the dash somewhere.
__________________
Krylon Fusion is for Amateurs.
Reply With Quote
  #8  
Old 08-20-2012, 02:56 AM
tyler.rich tyler.rich is offline
Learning to use the forums
 
Join Date: Jul 2012
Posts: 6
Default Re: Was no Odometer now Not charging

so you fixed your odometer with a new worm gear. question was your speedo working when your odometer and trip werent working because that is the problem i am having. my odometer and trip work ONCE IN A WHILE
Reply With Quote
  #9  
Old 08-21-2012, 03:15 AM
k5tpa k5tpa is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 11
Default Re: Was no Odometer now Not charging

That is the classic broken worm gear symptom. Speedometer still works.
Reply With Quote
  #10  
Old 08-21-2012, 10:07 PM
tyler.rich tyler.rich is offline
Learning to use the forums
 
Join Date: Jul 2012
Posts: 6
Default Re: Was no Odometer now Not charging

OK now I know what to fix thank you
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging AC CapeCodBob General Tech 15 07-12-2012 05:57 PM
lil tank not charging lil tank Electrical Tech 0 05-27-2010 07:48 PM
Charging Problem vaguru Electrical Tech 0 01-28-2010 08:12 AM
Charging system problem joedell Electrical Tech 3 06-19-2009 07:20 AM
99 ford ranger not charging? HECTOR S Electrical Tech 1 01-22-2009 05:48 AM