Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-13-2010, 08:22 AM
Cstalls Cstalls is offline
Ford Pickup
 
Join Date: Jul 2010
Posts: 100
Default None of the lights work in my car

Hi. I have a 99 ford ranger. I've noticed recently that my dashboard quit lighting up, and...well just about everything inside doesn't light up. The beeping sound the truck makes when you leave your lights on and open the door doesn't come on anymore. My head lights work fine, but there's no illumination of anything in my truck.

I also have a subwoofer system in there, with a Clarion CZ200 headunit and a 10'' subwoofer, if that means anything at all.

Thanks so much you guys.
Reply With Quote
  #2  
Old 08-13-2010, 10:10 AM
sgtsandman sgtsandman is offline
Tank Diver
 
Join Date: Mar 2010
Posts: 3,078
Default Re: None of the lights work in my car

Did you check the fuse?
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #3  
Old 08-13-2010, 01:14 PM
Cstalls Cstalls is offline
Ford Pickup
 
Join Date: Jul 2010
Posts: 100
Default Re: None of the lights work in my car

To check them, do I have to pull them out? Cuz I just kinda looked over them and none looked fried but maybe I'm just doing it the wrong way.
Reply With Quote
  #4  
Old 08-13-2010, 06:36 PM
sgtsandman sgtsandman is offline
Tank Diver
 
Join Date: Mar 2010
Posts: 3,078
Default Re: None of the lights work in my car

yep, to see if the wire inside has blown.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #5  
Old 08-13-2010, 10:08 PM
Cstalls Cstalls is offline
Ford Pickup
 
Join Date: Jul 2010
Posts: 100
Default Re: None of the lights work in my car

Do you know what area of the fuse box I should look? Or just in general check them all?
Reply With Quote
  #6  
Old 08-14-2010, 08:54 AM
Toofarnorth Toofarnorth is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 8
Default Re: None of the lights work in my car

Quote:
Originally Posted by Cstalls View Post
Do you know what area of the fuse box I should look? Or just in general check them all?
I found this owners manuals Looked at the '99 manual and found that fuse number 11 which is a 7.5 amp fuse protects the Instrument Cluster, Daytime Running Lights
(DRL), and RABS Resistor.

I would start there.
__________________
1993 4x4 extracab short bed 3L

1993 4x4 shortbed 4L (donor) Parting out
Reply With Quote
  #7  
Old 08-14-2010, 08:58 AM
ranger5572 ranger5572 is offline
2004 XLT with a few mods
 
Join Date: Jun 2010
Posts: 312
Default Re: None of the lights work in my car

I don't know about the rest of the lights in the truck but as far as the dash lights and open door dinging: When I pulled my dash out a few weeks ago, I noticed that when I unhooked the harness from the back of the dash cluster the dinging stopped and the lights went out on the cluster. I don't recall the rest of the dash lights going out. There are two harnesses on the back of my cluster. It's a 2004.
__________________
2004 XLT 4.0 4x4, 3" PA body lift, 32" BFG M/Ts, Dick Cepek DC-2 wheels, Euro tailights, self-painted headlight mod, NAV/DVD/XM/iPod stereo (Pioneer AVIC-D3), Line-X, Westin step bars, AVS bug shield and window vents
Reply With Quote
  #8  
Old 08-14-2010, 09:57 AM
Cstalls Cstalls is offline
Ford Pickup
 
Join Date: Jul 2010
Posts: 100
Default Re: None of the lights work in my car

Quote:
Originally Posted by ranger5572 View Post
I don't know about the rest of the lights in the truck but as far as the dash lights and open door dinging: When I pulled my dash out a few weeks ago, I noticed that when I unhooked the harness from the back of the dash cluster the dinging stopped and the lights went out on the cluster. I don't recall the rest of the dash lights going out. There are two harnesses on the back of my cluster. It's a 2004.
So are you saying I could have an unhooked harness behind my dashboard?

And just another detail. My Clarion headunit is having troubles turning on. I dont know if this is the head unit it'self, but it could be because of that.
Reply With Quote
  #9  
Old 08-14-2010, 10:06 AM
ranger5572 ranger5572 is offline
2004 XLT with a few mods
 
Join Date: Jun 2010
Posts: 312
Default Re: None of the lights work in my car

Could be. I just know mine quit dining when I unhooked the one harness. It's pretty easy to take it all apart to check. As far as the head unit goes, I don't think there'd be much of a relation there. But, there could be a wiring issue somewhere else that's causing it. Are there rats or mice running around where you park? I stored my boat at a buddies house one winter. There was a mouse with babies living in a nest made out of insulation from my ignition wires and grass inside the outboard cover. I stomped them.
__________________
2004 XLT 4.0 4x4, 3" PA body lift, 32" BFG M/Ts, Dick Cepek DC-2 wheels, Euro tailights, self-painted headlight mod, NAV/DVD/XM/iPod stereo (Pioneer AVIC-D3), Line-X, Westin step bars, AVS bug shield and window vents
Reply With Quote
  #10  
Old 08-14-2010, 10:50 AM
Cstalls Cstalls is offline
Ford Pickup
 
Join Date: Jul 2010
Posts: 100
Default Re: None of the lights work in my car

Quote:
Originally Posted by ranger5572 View Post
Could be. I just know mine quit dining when I unhooked the one harness. It's pretty easy to take it all apart to check. As far as the head unit goes, I don't think there'd be much of a relation there. But, there could be a wiring issue somewhere else that's causing it. Are there rats or mice running around where you park? I stored my boat at a buddies house one winter. There was a mouse with babies living in a nest made out of insulation from my ignition wires and grass inside the outboard cover. I stomped them.
hahaha that could totally be it! our neighbors cat is always finding mice and shrews and leaving them around the yard. i'll def. check that out. thanks for the tips.
Reply With Quote
  #11  
Old 08-14-2010, 11:16 AM
Cstalls Cstalls is offline
Ford Pickup
 
Join Date: Jul 2010
Posts: 100
Default Re: None of the lights work in my car

Sorry to double post, but I'm out here checking my fuses and I don't see a fuse 11. How would I know if the fuse is blown or not? Because these all seem fine.
Reply With Quote
Reply

Tags
ford, illumination, inside, lights, ranger

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
running lights dont work...help please. lv2huntandfishwithranger Electrical Tech 8 03-30-2011 05:54 PM
Converting a newer truck to work with amber rear signals/red brake lights Jp7 Electrical Tech 6 08-07-2010 08:05 PM
Tail lights won't work on 1989 Ford Ranger BLH Electrical Tech 1 05-16-2010 07:38 PM
1999 lights work but won't turn over elnoseface 4-Cylinder Tech 0 02-23-2010 04:58 PM
Rear parking/tail lights don't work. dynamo04 General Ford Ranger Discussion 8 11-19-2009 11:13 AM