Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-05-2010, 02:29 PM
FlyingFatass FlyingFatass is offline
Like the Forums
 
Join Date: Jul 2010
Posts: 32
Default Absolutely no power at all...but not the battery?

Story: got in my truck and tried to start it. Starter only clicked, but didnt make any attempt at turning over. Did the same a few times, then after turning it off and trying again, I had no power at all. Dashboard wont light up, clock is off, nothing. Did a quick check of the batt and all connections looked fine. Didn't have time to check the fuses as I had to go somewhere. Funny thing was, when i opened the hood, the little light on it turned on o_O, yet I had no power to anything else.

Battery was showing normal voltage the few times it wouldnt turn over, and this was just after driving it for about 30 minutes with the alternator working, so it should have a decent charge. So it's definately an electrical problem.

It could be a fuse, but I wouldnt think that a single fuze would cut power to all of the dash electronics, starter, etc. My other guess would have to be the ignition itself. It could be possible that its not making connection, which would explain why nothing turned on when the key is turned.

I'm not too good with electronics, but thats the best I could explain it. Any other idea's as to what is wrong?
Reply With Quote
  #2  
Old 08-05-2010, 02:44 PM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default Re: Absolutely no power at all...but not the battery?

i would start with the simplest thing first by removing the battery cables and cleaning the terminals really good than tightening it all back down and go from there.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #3  
Old 08-05-2010, 02:58 PM
reconjb reconjb is offline
Found a Diesel
 
Join Date: Aug 2010
Posts: 10,686
Default Re: Absolutely no power at all...but not the battery?

DO what you didn't have time to do and check the fuses that's one of the only things i can think of
Reply With Quote
  #4  
Old 08-05-2010, 03:20 PM
FlyingFatass FlyingFatass is offline
Like the Forums
 
Join Date: Jul 2010
Posts: 32
Default Re: Absolutely no power at all...but not the battery?

Now it does seem to be a problem with the battery. I now get power to the dash and everything, but the second i try to turn it over, everything dies.

I'm not sure if this is weird or not, but my radio suddenly had all different pre-programmed stations o_O?

My friends going to come over and try to jump it.
Reply With Quote
  #5  
Old 08-05-2010, 03:23 PM
reconjb reconjb is offline
Found a Diesel
 
Join Date: Aug 2010
Posts: 10,686
Default Re: Absolutely no power at all...but not the battery?

It almost sounds like you have a short in your ignition somewhere and you are blowing a main fuse
Reply With Quote
  #6  
Old 08-05-2010, 03:26 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Absolutely no power at all...but not the battery?

Or you can do what was suggested and probably fix it immediately?

Quote:
Originally Posted by 01_ranger_4x4 View Post
i would start with the simplest thing first by removing the battery cables and cleaning the terminals really good than tightening it all back down and go from there.
You aren't going to find a fuse. There is no main fuse labeled "Truck". ANd fuses don't magically un-blow after giving them a rest You either have a dead battery or a bad nasty connection on the battery cables. There is nothing else that would cause this. Not sure how you've ruled out a dead battery if you haven't tested it or tried to jump start it.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #7  
Old 08-05-2010, 03:27 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Absolutely no power at all...but not the battery?

Do you have any large blocks of time that seem to be "missing?" Or unexplainable marks or scars on your body?
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #8  
Old 08-05-2010, 04:55 PM
FlyingFatass FlyingFatass is offline
Like the Forums
 
Join Date: Jul 2010
Posts: 32
Default Re: Absolutely no power at all...but not the battery?

Tried jumping it, but same problem

Everything would light up on the dash, turn the key "Click" and no power to anything. I know the connections on the battery are good, i replaced the terminals a few weeks ago, the wires have great contact and I even cleaned down and sanded the terminals for maximum connection. I also checked the main fuses and all of them are still good.

Also, if you let the truck sit for a minute, closed all the doors so the cab light would turn off and wait for a little, suddenly everything would have power again when the key was turned (but not far enough to turn the motor over).

It could be a bad connection somewhere in the ingition switch, but then why would the cab light and engine light turn off after trying to start it? The alternator and battery problems were thrown out when trying to jump as well.

My father still claims it's the battery, but I dont see how the battery went from full power to completely drained in 30 minutes. And even then, when it did have power (before turning the ingnition) the battery level on the dash was well within the normal range.
Reply With Quote
  #9  
Old 08-05-2010, 05:00 PM
FlyingFatass FlyingFatass is offline
Like the Forums
 
Join Date: Jul 2010
Posts: 32
Default Re: Absolutely no power at all...but not the battery?

Quote:
Originally Posted by reconjb View Post
It almost sounds like you have a short in your ignition somewhere and you are blowing a main fuse
It could be, but when why would, after some time, it still get power again? And why would trying to start it (this time while being jumped) suddenly cut power to all the electronics.



Hmmmm. Could it be an issue with the computer? I thought it was weird that the pre-set's on the radio would suddenly change. I dont see why a blown fuse or a short somewhere could be causing that (which is what made me think of the computer)
Reply With Quote
  #10  
Old 08-05-2010, 05:46 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Absolutely no power at all...but not the battery?

My 93 XL did the same thing. Turns out the battery terminal was affected by just a little bit of junk on it. so i douched it with water and baking soda mix, it cleaned up and i havent had a problem since
Reply With Quote
  #11  
Old 08-05-2010, 08:40 PM
FlyingFatass FlyingFatass is offline
Like the Forums
 
Join Date: Jul 2010
Posts: 32
Default Re: Absolutely no power at all...but not the battery?

After having it sit for a while I had a friend come over to test the batt with a meter. But I tried starting it again before he did and it started right up.

Tested the alternator too by taking the lead off the batt and it ran fine with it off, so thats all good too.

I'm still not too sure what it was though. Tomorrow when theirs light were gunna check the main ground and some other stuff to be sure. Will also invest in a new batt just to be sure.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Light? 05RangerEdge 3.0 Vulcan Tech 28 05-14-2013 04:21 PM
Optima Battery jaywmu08 Product/Company/Member Reviews 8 10-22-2010 01:24 PM
Replace passenger side power rear view mirror on 2005 Ranger with power windows Theodore Viera Interior Tech 2 06-21-2010 09:39 PM
battery js250 Electrical Tech 6 01-09-2010 02:52 PM
'04 3.0 install new battery g-ann General Ford Ranger Discussion 4 11-03-2009 07:44 PM