Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-02-2010, 01:53 PM
Fordaholic Fordaholic is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 1
Question Speedo and Odo at 50%, 4x4 lights stuck on

Hi yall! New to this site, just curious on my current electrical problem. I own a 2001 ranger 4.0l 4x4. Out of nowhere both my 4x4 lights come on, and the Speedometer and Odometer starting operating at 50%. Ex: I go two miles, it records 1 mile, I go 50 mph, it says 25 mph. Also the 4x4 lights came on although the 4 wheel drive did not engage. I am assuming it is the speedo sensor on the rear axle? But could it be anything else? Just confused because I thought if that sensor were to just go, then all mph and odomoter reading would be gone with it, not 50%. Any insight would be greatly appreciated! Thanks a lot!
Reply With Quote
  #2  
Old 08-02-2010, 03:50 PM
rwenzing rwenzing is offline
Some assembly required...
 
Join Date: Jun 2009
Posts: 890
Default Re: Speedo and Odo at 50%, 4x4 lights stuck on

In 2001, the sensor on the top of the rear diff is for the ABS only. The 2001 raw speedometer signal comes from the OSS sensor in the transmission case (automatic) or in the extension housing (manual). The OSS could possibly be bad but doesn't often fail.

Actually, I think that your problem is not in the speedometer system at all. The speedometer is corrected by a multiplier in the PCM whenever the 4x4 Low indicator light is on. It makes the speedometer read lower to correct for the 2.48:1 gear reduction in the transfer case. I believe that whatever is causing that 4Low light to be on incorrectly is also causing the speedometer error. Get the electronic 4WD fixed and the speedometer problem should go away too.
__________________
2003 FX4 Level II, Supercharged 5.0L V8, Headers, Duals
BW4406 manual transfer case, Aussie Locker, Torsen L/S, 4.10's
Bilstein 7100 rezzies, Cadillac/Mustang rear discs, Duff traction bars
Keypad Entry, Lock LEDs, ABS switch, sway bar discos
Heated seats, Explorer EATC, Trip Computer and consoles

2003 XLT 2.3L M5OD-R1 reg cab, 2011 Taurus SEL, 2016 C-MAX Energi Plug-in Hybrid
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you recalibrate the speedo/odo for bigger tires? NOLArat Wheels and Tires 22 12-03-2013 09:12 AM
Why is my 03' Ford Ranger stuck in 4x4 Low? BluesMan General Tech 8 11-07-2010 07:01 AM
Speedo, Odo, Dome Light, Wipers and 3rd brake light raydizzle34 Electrical Tech 1 06-14-2010 11:22 AM
GOT STUCK...pics of stuck and others from today 99offroadrngr Vehicle Snapshots 15 03-01-2010 09:28 PM
4lo stuck with no lights on. 94b4000zmzm Drivetrain Tech 0 12-21-2009 02:42 PM