Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-18-2020, 08:35 PM
cobrajocky cobrajocky is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default New Alternator still not charging battery, only 12.3v output.

I have a 97 Mazda B-4000 SE 4.0L Xtr Cab (same as a Ranger XLT), with 98.4k miles. The original Motorcraft Alternator finally gave up the ghost, fortunately the battery still got me home. I bought a new, no doubt Wuhan CN made, Alternator (aren't they all these days) AFD0012 through Amazon distributed by DB Electical rated at 95A like the original Motorcraft, same in physical size. Their site and the chart on the Amazon lists it as compatible to my B-4000 and the equiv Ford 4.0L V6 XLT Ranger too. Installed smoothly in <45 minutes (not my first rodeo), but I immediately noticed that the voltage at the battery terminals was barely over 12.4 V. I then measured it with a DVM at the + voltage terminal on the Alternator to an engine ground at 2k RPM =2.3V and 2.5k RPM = 12.2V! When I turn on the headlights, there is a very noticeable drag on the running, but doesn't kill the motor.

Oh, I did test the Amperage output of the Alternator with my ancient Craftsman Engine Analyzer system and it showed a 10AMP output at 2k RPM.

So my question is, is it obvious the Chop Suey Alternator is bad (probably 1 or more diodes open in the rectifier), or could something else be limiting the voltage output? All the connectors are fine as far as I can tell, no corrosion, fit well to the Alt. What else ??

The original Alternator was occasionally "spiking " in voltage output, first 5 to 15 minutes of running (on initial cold start up) shooting up to a "pulsing" 14.8 to 15.2V for a couple of months before it died.
The Dash Battery warning light was intermittently flashing and then would turn off when voltage dropped below 13.8- 14.0 V. (I have a cigarette lighter port Digital Volt Meter.)

Appreciate any and all thoughts, except the crazy ones.

Last edited by cobrajocky; 06-19-2020 at 11:12 AM.
Reply With Quote
  #2  
Old 06-19-2020, 07:28 AM
Markous Markous is offline
Journeyman
 
Join Date: Mar 2013
Posts: 1,189
Default Re: New Alternator still not charging battery, only 12.3v output.

how old is your battery?
__________________
2007 Sport|Dark Shadow Grey|3.slow|2WD|Black Billet Grill|Anzo LED's
Pictures
Reply With Quote
  #3  
Old 06-19-2020, 11:23 AM
cobrajocky cobrajocky is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default Re: New Alternator still not charging battery, only 12.3v output.

Quote:
Originally Posted by Markous View Post
how old is your battery?
Battery is a Heavy Duty, 48 months rating and is 28 months old. When I charge it with an external charger 13.5V at 2Amps for 4 to 6 hours it holds a 12.8v charge for 48 hours.

I don't see how a battery condition would inhibit (to below 12.4v) the voltage output of a new Alternator measured at the alternators B+ terminal to chassis ground.

I've also tested the 3-wire cable to the Alternator, with the ignition OFF - Yellow wire shows 12.5V, the associated 15A fuse is good, green wire is showing 0 volts(as it should) until you turn on the ignition (not start) then 12.5V, and the associated 7.5 A fuse is also good.

The "Fused Link" from the Neg Battery post to chassis gnd is also good.
Reply With Quote
  #4  
Old 06-20-2020, 03:26 PM
dvrich dvrich is offline
Ford Ranger Driver
 
Join Date: Sep 2010
Posts: 2,969
Default Re: New Alternator still not charging battery, only 12.3v output.

If you are getting 12.5 V at the alternator with the engine running and 12.5 V at the battery, the Chinese alternator is bad.
__________________
Stock car driver Bubba Wallace is making even more demands of Nascar, he wants them to change from 15" wheels to 32"
Reply With Quote
  #5  
Old 06-21-2020, 03:16 PM
cobrajocky cobrajocky is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 8
Default Re: New Alternator still not charging battery, only 12.3v output.

Turns out that the Ground lead in the 3-wire Connector was bad, fixed it and the Alternator is putting out a consistant 14.0 volts.

Problem with the "Red" Alternator is solved.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alternator not charging Marcus33 4-Cylinder Tech 12 01-21-2015 09:17 PM
High Output Alternator Recommendations TB-9862 Electrical Tech 2 01-07-2015 10:23 AM
High Output Alternator ELCouz Electrical Tech 1 01-06-2014 04:10 AM
'03 4.0 alternator not charging??? grizlywinkleman Electrical Tech 2 12-02-2013 01:00 PM
Battery not charging, no output from Alternator High Flow Electrical Tech 7 12-13-2011 10:46 AM