Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-18-2020, 12:26 AM
NDL NDL is offline
Like the Forums
 
Join Date: Feb 2010
Posts: 30
Default I Need A Discontinued GEM Module / Parasitic Drain Issue Killing My Battery

I have a 2001 Ranger XL 2.5L truck, straight drive.

I had a parasitic drain issue which continually drained/killed my battery overnight, which I traced down to a faulty GEM module. When I disconnected the GEM module, the parasitic drain stopped, and, believe it or not, *everything* but my wipers worked.

The module for my truck is discontinued, and I am not going to buy a used unit which may or may not work, for how long, etc. After calling around, I found a GEM module for a 2001 Ranger 4 x 4. I plugged the new module in; the parasitic drain issue stopped; everything worked, but my speedometer went crazy, and my motor wouldn't rev past 2,300 rpm - it was as if the motor was running too lean; the motor would sputter and almost die.

I pulled the truck over, put in the original GEM module, and the truck is back to normal - sans the parasitic drain issue. For now, I pulled the negative terminal off my battery.

The module number is EL5Z-14B205-DRM, and several websites say they have the part, but when you call them, they say they don't have the part.

Suggestions? I cannot afford a new truck, and a used module is too much of a gamble. The only replacement manufacturer that I have seen, is cardone, and I won't buy cardone.

Thank you
Reply With Quote
  #2  
Old 01-19-2020, 11:59 AM
Scrambler82 Scrambler82 is offline
The EDGE
 
Join Date: Nov 2009
Posts: 165
Default Re: I Need A Discontinued GEM Module / Parasitic Drain Issue Killing My Battery

I am not a mechanic nor do I understand the GEM Module but I was wondering IF, can you determine what in the GEM Module is causing the problem.
The GEM must be sending info to something that is causing the drain, if you can determine where the power is going... MAYBE you can correct the problem.

I'm thinking the GEM is going to be a problem for all of us with older Rangers... I hope you can find the problem.

Ltr
__________________
Grev B
Do it right the first time !
03 EDGE, E4 RED, SL Lifted w/Coil Over in frt, BFG AT, 33 x 12.50 x 15 a lot of little things.
Custom front and rear bumpers - C4x4, in OK.
Reply With Quote
  #3  
Old 01-19-2020, 10:27 PM
NDL NDL is offline
Like the Forums
 
Join Date: Feb 2010
Posts: 30
Default Re: I Need A Discontinued GEM Module / Parasitic Drain Issue Killing My Battery

Quote:
Originally Posted by Scrambler82 View Post
I am not a mechanic nor do I understand the GEM Module but I was wondering IF, can you determine what in the GEM Module is causing the problem.
The GEM must be sending info to something that is causing the drain, if you can determine where the power is going... MAYBE you can correct the problem.

I'm thinking the GEM is going to be a problem for all of us with older Rangers... I hope you can find the problem.

Ltr
I thank you for your suggestions, and agree with what you wrote.

I think I might put a switch on fuse 26, which powers the GEM...
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parasitic Drain and battery light on EaOutlaw1969 Electrical Tech 7 03-16-2016 11:02 AM
Odd Parasitic Battery Draw Augustinaris Electrical Tech 4 02-10-2014 06:59 PM
Parasitic power drain traced to radio druid Electrical Tech 2 10-09-2013 07:34 PM
Battery Drain Issue?? iTzMetal 4.0 SOHC / 4.0 OHV Tech 1 03-09-2013 08:02 PM
Crazy parasitic drain- help if you can clt800 Electrical Tech 12 10-29-2012 06:19 AM