Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-03-2019, 12:34 PM
Ben Milner Ben Milner is offline
Learning to use the forums
 
Join Date: Apr 2019
Posts: 2
Thumbs down Electric System Dead While Driving

On my way to school my ranger slowly lost all its electric, I checked my voltage and was on critically low, so I whipped into the nearest parking lot as the engine died.

I spent an hour with my voltmeter checking the voltage of my battery, which is at a perfect 13.6. If I turn the key on in my truck I barely have power, the clock blinks on and off as it tries to receive power, and the truck cannot start.

Ive checked my grounds and they are all set, battery is brand new and as I said working fine. I checked my voltage to my starter, which is also fine. What could be wrong???
__________________
2000 Ford Ranger XLT 4x4 v6 4.0
Reply With Quote
  #2  
Old 04-03-2019, 02:08 PM
e.fisher26 e.fisher26 is offline
Ford Pickup
 
Join Date: Aug 2018
Posts: 120
Default Re: Electric System Dead While Driving

Does it start with a jump and stop running after the jump is disconnected? Could be bad alternator


覧覧覧覧覧
2004 ranger 4.0L edge
Reply With Quote
  #3  
Old 04-03-2019, 05:19 PM
Ben Milner Ben Milner is offline
Learning to use the forums
 
Join Date: Apr 2019
Posts: 2
Default Re: Electric System Dead While Driving

I thought this too, I put a charger on my battery (set it to start), and the starter just clicked, as if not getting enough power, just like the electronics in the cab. I haven't dabbled much in electronics in vehicles so I'm not too sure about this. Wish I could run the truck to test the alternator better...

Does the power by any chance run through the alternator from the battery? I thought the power was direct but if it runs through the alternator thats something I didnt consider.
__________________
2000 Ford Ranger XLT 4x4 v6 4.0
Reply With Quote
  #4  
Old 11-20-2019, 07:54 PM
JerkyMiester JerkyMiester is offline
Learning to use the forums
 
Join Date: Nov 2019
Posts: 2
Default Re: Electric System Dead While Driving

Quote:
Originally Posted by Ben Milner View Post
I thought this too, I put a charger on my battery (set it to start), and the starter just clicked, as if not getting enough power, just like the electronics in the cab. I haven't dabbled much in electronics in vehicles so I'm not too sure about this. Wish I could run the truck to test the alternator better...

Does the power by any chance run through the alternator from the battery? I thought the power was direct but if it runs through the alternator thats something I didnt consider.
Hi OP,

I just posted this problem in the forum. Did you ever find the solution to your problem? My 2009 Ranger suffered the same symptoms you described. However after pulling over and turning ignition off, I tried it and it cranked up and ran like normal. Only happened one time so far.

Last edited by JerkyMiester; 11-20-2019 at 07:57 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
electric fan black06xlt 4.0 SOHC / 4.0 OHV Tech 1 04-05-2017 09:01 AM
1999 Fuel System Question Single Line System junkdealer2 4-Cylinder Tech 2 05-11-2015 11:42 AM
Separate Voltage System For System. spudkilla224 Audio / Video 9 06-11-2013 12:48 PM
No electric Nothing but Fords Off Topic 3 01-03-2012 08:34 AM
Electric help AGAIN RoadDawg Electrical Tech 8 02-14-2011 01:17 PM