Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-07-2018, 10:03 AM
jim22 jim22 is offline
Ford Truck Driver
 
Join Date: Aug 2009
Posts: 81
Default 1999 Phantom Wipers

I've got a fairly common problem I guess, my windshield wipers run once in a while while off, frequently in conjunction with switching the actual turn signal on or off, i.e. when the arm moves/is moved. Yesterday my wife laughed at my truck because of it So today I decided to dig in and figure it out.

I had this problem and made my first attempt to fix it a few years ago by removing the knob and cleaning contacts, which didn't really help. I believe at the time I had the original Ford part installed. I then replaced the switch with ebay's finest cheap aftermarket chineseium part labeled Sensa, which actuallly seemed to solve it for a while.

Hint number one: When changing the part, be careful of the little plastic part which holds in the contact for the Key-In switch in the ignition switch. Mine broke and is now held in with tape and zip ties.

Hint number two: There are three screws that hold the column covers together. Take these out and gently fish the coves off and out from under the dash. Mine have one broken screw sleeve on the bottom, not sure I actually broke it. I am attempting to glue it, but we'll see.

Now, I'm having the same trouble with the Sensa switch. There are numerous TSB's, etc regarding this problem, and I believe there is a revised Ford part to fix it. It doesn't seem to require a GEM replacement or reprogram, but it's all a little unclear. There are part numbers listed, but it's hard to tell for sure if even a Ford part you purchase is the revised part.

There are also various wiring diagrams posted, and I found one which shows the internal schematic and pinout. I went through and verified the resistance values for all operating conditions. The interval functions are on one pin, and the off/int/lo/hi are on another pin. The two pins share a common pin. The washer function shorts out the interval resistance and SHOULD NOT AFFECT the off/int/lo/hi side.

I found my resistances spot-on, but I found that fiddling with the washer button messed up the off/int/lo/hi side resistance, making it quite high. That, I believe, caused the GEM/ECM to think the wipers were "not off". A eureka moment!

I disassembled the knob, and used some contact/tuner cleaner to wipe the circuit board. The board didn't look bad, but I could see where the contacts were dragging across them. It could have been a bit of corrosion. There was NOT a lot of grease in there. The cleaner I used will leave behind a little mineral oil.

I was about ready to go out to Napa and pick up an Echlin part, for which the picture showed the OEM part numbers, but it wasn't really in stock. I reassembled the switch to recheck the resistances and write them down, and discovered that the problem was disappeared. Since I struck out on the part, I put the original back in. I left the column covers off to scare it and will drive it for a week or two and see if it's really fixed.

So, hint number three: Yes, it can really be that the contacts are dirty and need to be cleaned. This is easier than removing the switch, and worth a try.

Does anybody have any more detail on what was changed in the revised part? I was expecting resistance changes, but now I'm thinking maybe something about the layout of the circuit card and/or contacts in the knob.

Thought I would share...

Jim
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wipers Coyotekiller General Tech 1 04-09-2015 07:21 AM
1999 Ranger Sport Speedometer Cab light and wipers Bal2 Introduce Yourself 3 09-10-2014 06:50 AM
The phantom dying,stubble while driving lowboi 4-Cylinder Tech 4 07-08-2013 10:17 AM
For Sale: BOSS 10" Shallow Phantom Series Sub HoustonM Interior Parts 5 05-18-2011 10:13 PM
where can i get a phantom grille for my 88 ranger superdancingpanda Exterior Tech 2 08-31-2010 04:40 PM