Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-02-2018, 07:33 PM
The Browning Ranger The Browning Ranger is offline
Roc pile up i dis Ma!
 
Join Date: Nov 2011
Posts: 468
Default Erratic Gauges LED caused?

I installed led stips behind my gauge faces instead of bulbs, i soldered them to where the bulb sockets go, reinstalled all the needles everything was working fine, but after driving for more than 30 min the speedometer and tachometer start to read erratic and progressivly get worse and worse. If you shut the truck off for 10-15 min they go back to reading correctly. Im guessing this is a voltage problem, voltage regulator, resistor,to much power from the led strips? any advice would be helpful.
__________________
THE BROWNING RANGER
31x10.5 r15, 4inch spindles, 2inch blocks n shackles
My Build Thread
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough idle caused by CPS? MCRuss 3.0 Vulcan Tech 4 05-26-2017 11:40 AM
No start woes caused by CPS..? 84minieldo 4-Cylinder Tech 7 05-16-2015 01:12 PM
damn old drivers?!! caused an accident NFCTWC General Ford Ranger Discussion 5 09-22-2013 09:12 PM
Is this caused by my speedo cable? 94mtx Drivetrain Tech 3 09-01-2011 04:38 PM
This Caused My Flat!? Mayguy General Ford Ranger Discussion 8 04-08-2010 05:32 PM