Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-10-2017, 04:43 AM
fehujber fehujber is offline
Learning to use the forums
 
Join Date: Aug 2012
Posts: 1
Default 1996 4.0 crank no start no com with PCM

Been a member but never posted. I have a problem with a 1996 Ranger splash auto 4.0. For past few months when I would cross a HARD bump she would "hiccup" downshift, race, cut out and return. Then run normal. 2 weeks ago she toasted the voltage regulator which I rebuilt and she ran fine. Last friday I crossed a bump and she cut out and stayed there. Flatbed time.
So far I have checked the FP Relay. ( not pumping but I can Bypass and it runs and pumps fine) The main fuse for the PCM was blown which I have replaced. NO other fuses are out, Still the issue persists she will crank but not start, with or without fuel pumping. I have tried 3 scanners the last being my laptop with an em327 and Forscan. NOTHING will communicate with the PCM. I pilled the unit opened it up and see no visible issues.
Even tried a local auto electric guru, he came up dry.
Has anybody had anything similar.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
crank, no start jat23tec 4.0 SOHC / 4.0 OHV Tech 3 07-01-2017 01:52 AM
1992 2.3L will crank but not start but will push start Texas92 4-Cylinder Tech 8 10-17-2016 04:13 AM
Crank/No Start 93 XLT Amishman73 General Tech 3 09-13-2016 07:00 AM
crank no start.... please help dalton.edwards91 Electrical Tech 12 10-08-2015 11:44 AM
will crank over but not start brokedownranger94 General Tech 17 12-14-2012 07:29 PM