Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-12-2017, 06:42 AM
COUNTRYCOWBOYRANGER COUNTRYCOWBOYRANGER is offline
Ford Tough
 
Join Date: Aug 2016
Posts: 356
Default odometer is not working

I have a 2000 ford ranger and swapped out my stock black cluster with a silver one from an explorer, i also took apart the silver cluster and set my mileage back to what it should be...All my lights work fine, but my mileage and odometer wont roll anymore...any ideas what could cause that? Bad motor or worm gear?
__________________
2000 Ford Ranger 4x4 | Lv2 31 spline 8.8 | Eaton E-locker | Bw 1354 manual t-case | Torsen/Front | 12,500lb tuff stuff winch w/synthetic rope | Cosmo Racing CAI | Pro-Comp Es9000's | Logan's Metal 4x4 Front Bumper | 32x10.50r16 Hankook Dynapro ATM | :
Reply With Quote
  #2  
Old 09-12-2017, 10:48 AM
Kealel Kealel is offline
Bringing hell to the city
 
Join Date: Feb 2015
Posts: 2,563
Default Re: odometer is not working

How did you roll the miles?

Did you make sure you plugged the odometer motor back in?

You should have noticed a broken worm gear if you rolled the miles right.
__________________
Baby Girl: 2006 White Ranger XL with many memories. R.I.P. 1/26/15
Quote:
Originally Posted by Logan03CO View Post
I knew you were an alright guy!
Quote:
Originally Posted by ford4thot View Post
The only reason it's worn out junk is because you've gone 70k miles without changing the oil.
Reply With Quote
  #3  
Old 09-12-2017, 11:39 AM
COUNTRYCOWBOYRANGER COUNTRYCOWBOYRANGER is offline
Ford Tough
 
Join Date: Aug 2016
Posts: 356
Default Re: odometer is not working

Quote:
Originally Posted by Kealel View Post
How did you roll the miles?

Did you make sure you plugged the odometer motor back in?

You should have noticed a broken worm gear if you rolled the miles right.
I plugged the odometer motor back in and the worm gear wasn't broken..I'm thinking I may have tightened something too much or maybe the motor is bad..
__________________
2000 Ford Ranger 4x4 | Lv2 31 spline 8.8 | Eaton E-locker | Bw 1354 manual t-case | Torsen/Front | 12,500lb tuff stuff winch w/synthetic rope | Cosmo Racing CAI | Pro-Comp Es9000's | Logan's Metal 4x4 Front Bumper | 32x10.50r16 Hankook Dynapro ATM | :
Reply With Quote
  #4  
Old 09-12-2017, 02:47 PM
Kealel Kealel is offline
Bringing hell to the city
 
Join Date: Feb 2015
Posts: 2,563
Default Re: odometer is not working

Quote:
Originally Posted by COUNTRYCOWBOYRANGER View Post
I plugged the odometer motor back in and the worm gear wasn't broken..I'm thinking I may have tightened something too much or maybe the motor is bad..
Did you roll the miles exactly how the How To thread states?

If so it may be possible you pushed the numbers too close together. What I like to do is set it 10 miles below what I want, roll it 5 to 8 times with my fingers (spinning the rod that the gear is on) to make sure it all moves as it should, and then run out all but 1 mile when realigning the needle.
__________________
Baby Girl: 2006 White Ranger XL with many memories. R.I.P. 1/26/15
Quote:
Originally Posted by Logan03CO View Post
I knew you were an alright guy!
Quote:
Originally Posted by ford4thot View Post
The only reason it's worn out junk is because you've gone 70k miles without changing the oil.
Reply With Quote
  #5  
Old 09-13-2017, 04:32 AM
COUNTRYCOWBOYRANGER COUNTRYCOWBOYRANGER is offline
Ford Tough
 
Join Date: Aug 2016
Posts: 356
Default Re: odometer is not working

Yea, I Did exactly how the threads stated when it came to rolling it, I'm gonna tear it apart tomorrow and find out exactly what's wrong with it.

Sent from my Prime10ES using Tapatalk
__________________
2000 Ford Ranger 4x4 | Lv2 31 spline 8.8 | Eaton E-locker | Bw 1354 manual t-case | Torsen/Front | 12,500lb tuff stuff winch w/synthetic rope | Cosmo Racing CAI | Pro-Comp Es9000's | Logan's Metal 4x4 Front Bumper | 32x10.50r16 Hankook Dynapro ATM | :
Reply With Quote
  #6  
Old 09-13-2017, 04:58 AM
Kealel Kealel is offline
Bringing hell to the city
 
Join Date: Feb 2015
Posts: 2,563
Default Re: odometer is not working

Take pictures to show everything in case it doesn't work again
__________________
Baby Girl: 2006 White Ranger XL with many memories. R.I.P. 1/26/15
Quote:
Originally Posted by Logan03CO View Post
I knew you were an alright guy!
Quote:
Originally Posted by ford4thot View Post
The only reason it's worn out junk is because you've gone 70k miles without changing the oil.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer & Odometer Not Working Vexy Electrical Tech 16 05-04-2013 11:00 AM
Odometer not working RangerRoad Electrical Tech 0 01-29-2013 06:14 AM
Odometer working?? Artemis General Ford Ranger Discussion 5 02-01-2012 05:33 PM
Odometer Stopped working! swat784 Interior Tech 15 10-05-2009 01:55 PM