Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-05-2010, 03:09 PM
TitanJeff TitanJeff is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 10
Default Speakers quit on '93. Radio seems fine.

My daughter's '93 Ranger had all four speakers go out the same time. In tinkering around, the radio seems to be fine. I've jiggled a few wires but haven't had any luck finding anything.

I searched the manual for fuse info but don't see one for just the speakers. I'm baffled.

Her style of radio for that truck is the basic cassette player if that helps.

Any suggestions before I pull out the radio and create a big mess? Thanks.
Reply With Quote
  #2  
Old 07-05-2010, 04:22 PM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Speakers quit on '93. Radio seems fine.

You won't make a mess at all taking it out. I have a 93 as well and the speakers are just about shot too so it just may be time or a bad connection in the rear of the radio. If you're looking for aftermarket replacement go to crutchfield.com, or call them. If you buy a stereo and speakers they throw in the mounting brackets, wiring harness' and everything you need specifically for your vehicle
Reply With Quote
  #3  
Old 07-05-2010, 04:33 PM
TitanJeff TitanJeff is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 10
Default Re: Speakers quit on '93. Radio seems fine.

With all four going out at once, think it could be a connection on the back of the radio? I thought I'd make that my first plan of attack.

Thanks for your reply.
Reply With Quote
  #4  
Old 09-18-2010, 10:26 AM
TitanJeff TitanJeff is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 10
Default Re: Speakers quit on '93. Radio seems fine.

Sorry to bump an old thread but here's the latest.

I get out the radio and check the wiring and all is good but still no music. Radio continues to work normally. So I put it back in.

Daughter goes weeks without it working until this week when she hops into the truck and the speakers come on. She enjoys the music until she arrives to school and, in the afternoon, no speakers again when she starts back up the truck.

Anyone ever experience something like this? I've checked fuses and jiggled wires everywhere. My next move is to take it somewhere but, if there is something I'm overlooking, would like to give it one last shot.
Reply With Quote
  #5  
Old 04-02-2014, 07:37 PM
jeremyrwells87 jeremyrwells87 is offline
Learning to use the forums
 
Join Date: Apr 2014
Posts: 2
Default

The same thing is happening to my 96 ranger my music Is off and if I close a door or go over a bump it turns back on I'm pretty stumled
Reply With Quote
  #6  
Old 04-02-2014, 07:57 PM
DimePaul DimePaul is offline
Ford Ranger Owner
 
Join Date: Dec 2013
Posts: 56
Default Re: Speakers quit on '93. Radio seems fine.

Sounds like time for a new OEM radio. It probably has a loose wire somewhere inside the radio unit. Can you see if any of the wires of the radio plug are missing or not?
__________________
Ford Ranger 99 3.0 XLT Ext. Cab 2wd
Reply With Quote
  #7  
Old 04-02-2014, 08:23 PM
jeremyrwells87 jeremyrwells87 is offline
Learning to use the forums
 
Join Date: Apr 2014
Posts: 2
Default

No wires are loose I checked twice but I'll look again tomorrow
Reply With Quote
  #8  
Old 04-03-2014, 04:01 PM
cvar cvar is offline
Ford Ranger Driver
 
Join Date: Jun 2012
Posts: 1,310
Default Re: Speakers quit on '93. Radio seems fine.

http://www.therangerstation.com/tech..._diagrams.html

Get a multimeter, and test the voltages on your Gray radio connector's pins. Do you have good power and grounds on all those correct pins? It's gotta be one of those, or else something is loose inside the radio itself (ie, time for replacement radio).

On some systems, the Gray pin #1 (circuit 689) is not used, and on other (eg, premium) sound systems, power to this pin will mute (silence) the radio while starting the engine, cuz it's supposed to go to Hot-In-Start.
__________________
1997 4x4 Mazda B4000 SE, Ext.Cab
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Ranger Speedometer quit working? wrongfulleaf Electrical Tech 28 09-11-2013 06:49 PM
92 ranger 4 by quit workin mikertldg Drivetrain Tech 0 01-26-2010 07:49 PM
Tach quit working speterson Electrical Tech 0 01-24-2010 11:10 AM
speedometer quit working blackandgreen98 Electrical Tech 5 01-22-2010 10:56 AM
The Old Soviet Doomsday Machine and other fine blunders in Nuclear past/present. Superlifted06FX4 Off Topic 1 09-26-2009 06:59 AM