Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-17-2017, 07:37 PM
450thumper 450thumper is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 28
Arrow Windshield wipers only thing not working.

I cant figure out what the problem is here. My wipers will not work at all. Ive checked fuse 16. Checked relays under the hood. They are good. I pulled the plug from wiper motor and have no power there. Whats weird is my turn signals work hi beams and even my washer fluid still sprays. So that would mean the mfs (multi function switch) is good correct? What else should i be checking. Clean ole ranger. Truck description in signature below.
__________________
1996 Ranger XLT 2wd 2.3l ext.cab 5-speed
Reply With Quote
  #2  
Old 03-17-2017, 07:43 PM
jheitt jheitt is offline
Ford Tough
 
Join Date: Nov 2014
Posts: 423
Default Re: Windshield wipers only thing not working.

Ground the body of the wiper motor and see if they start to work

Sent from my SM-G930W8 using Tapatalk
__________________
2008 Sport 4x4, Pro Comp D windows, 265/75R16's, leather, JVC double DIN, Kenwood 5-1/4 components, Clarion XR2420, 4 - 8" Dayton Audio SD215A-88 in 3.6ft^3 @ 38hz
Reply With Quote
  #3  
Old 03-18-2017, 08:59 AM
Grumpa Grumpa is offline
Busted Knuckles
 
Join Date: Mar 2016
Posts: 229
Default Re: Windshield wipers only thing not working.

...or it may be the one thing that is bad on the multifunction switch. Electrical problems can be a real pain tracking down.


RangerWiper.jpg
__________________
1995 Ranger XLT 3.0L OBDII
Trans: A4LD (E) 2WD
Rear: 7.5 / 3.45 NL LHD
Tires:GY P235 75/R15 (orig 225 70/R14)
Long Bed, 20 Gal Tank
Up to 229,900 miles

Last edited by Grumpa; 03-18-2017 at 09:08 AM.
Reply With Quote
  #4  
Old 03-21-2017, 09:03 PM
450thumper 450thumper is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 28
Default Re: Windshield wipers only thing not working.

Ground didnt help, and im getting no power with the test light at the plug on wiper motor. So basically i need to just replace the mfs in process of elimination? Any way to check switch?

Thanks for the replies
__________________
1996 Ranger XLT 2wd 2.3l ext.cab 5-speed
Reply With Quote
  #5  
Old 03-22-2017, 03:20 AM
Jswifto Jswifto is offline
Ford Ranger Driver
 
Join Date: Dec 2013
Posts: 1,532
Default

Sure is if you have power coming to the switch but no power coming out then it is the switch. Look on line for the wiring diagram that is for your model
__________________
1999 Ranger 4.0 and extreme Snap-on tool fetish
Reply With Quote
  #6  
Old 03-22-2017, 06:27 AM
RoberticusMaximus RoberticusMaximus is offline
<<< Husky the High Dog!
 
Join Date: Jan 2012
Posts: 7,111
Default Re: Windshield wipers only thing not working.

before you pull the MF switch, pop the end off & look at the contacts. its free lol

here's some pics: http://www.fordrangerforum.com/membe...-cleaning.html

Last edited by RoberticusMaximus; 03-22-2017 at 06:30 AM.
Reply With Quote
  #7  
Old 03-22-2017, 08:26 AM
hyghwayman hyghwayman is offline
Ford Pickup
 
Join Date: Jan 2017
Posts: 120
Default Re: Windshield wipers only thing not working.

Quote:
Originally Posted by RoberticusMaximus View Post
before you pull the MF switch, pop the end off & look at the contacts. its free lol


+1
__________________
2001 3.0L XL 5sp 2WD
Standard Cab - Short Bed (112" WB)
7.5 w/ 3.73
Acquired Dec. 23rd, 2016
History Unknown
Reply With Quote
  #8  
Old 03-22-2017, 09:19 AM
450thumper 450thumper is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 28
Default Re: Windshield wipers only thing not working.

Wow thanks you guys! After work ill do just that, and look up a diagram for the mfs and test those leads. Great advice ! Ill be sure to post what i find. Thanks!
__________________
1996 Ranger XLT 2wd 2.3l ext.cab 5-speed
Reply With Quote
  #9  
Old 03-22-2017, 09:57 AM
barneycat11 barneycat11 is offline
2006 FX4
 
Join Date: Nov 2014
Posts: 320
Default Re: Windshield wipers only thing not working.

Read the system codes and check smart junction box fuse 5 (30amp) in the lower right passenger fuse panel.Also check all the electrical connectors connected to this fuse panel.
__________________
barneycat11 2006 FX4
Reply With Quote
  #10  
Old 03-22-2017, 10:00 AM
RoberticusMaximus RoberticusMaximus is offline
<<< Husky the High Dog!
 
Join Date: Jan 2012
Posts: 7,111
Default Re: Windshield wipers only thing not working.

happy to help!
one more thing, if/when you get into the steering column, check to see if one of the pins has simply pulled out of the MFSwitch connector. i don't have a pic of it, but my right (or left - cant remember) turn signal wire pulled right out, presumably because i liked to keep the column adjusted down. after 15 years of up/down every time i got out/in, it eventually pulled it right out!

----------

Quote:
Originally Posted by barneycat11 View Post
Read the system codes and check smart junction box fuse 5 (30amp) in the lower right passenger fuse panel.Also check all the electrical connectors connected to this fuse panel.
that's a free on too!
Reply With Quote
  #11  
Old 03-22-2017, 06:30 PM
450thumper 450thumper is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 28
Default Re: Windshield wipers only thing not working.

Ik will do. I got the end cap off todag and the little elec contactors looked messed up. I tried to straighten it out cleaned it all and put back in and got nothin.

Didnt know there were fuses passenger side. Ill check it out
__________________
1996 Ranger XLT 2wd 2.3l ext.cab 5-speed
Reply With Quote
  #12  
Old 03-28-2017, 07:25 AM
450thumper 450thumper is offline
Liking the Ford Ranger Forum
 
Join Date: Jun 2011
Posts: 28
Default Re: Windshield wipers only thing not working.

Well found the problem! So the 30 amp fuse had a bad connection i noticed with a test light i was getting intermittent power at the fuse. Relized it was the prongs that the fuse wedges into. So i gently took off that red gaurd around fuse box then gently pushed the tabs back in to get a better bite on the fuse. Now wipers work great! And ive already ordered the mfs ��

Not to change subject but i noticed not all my fuses have power with key on. Is this normal ? Ive included a pic with each fuse that has no power the fuse has a white dot on it. Problem?

----------

https://s12.postimg.org/z1aikmw8t/IMG_3967.jpg

__________________
1996 Ranger XLT 2wd 2.3l ext.cab 5-speed
Reply With Quote
Reply

Tags
2.3 5-speed, not working, wipers

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn, windshield wipers and speedo all not working lawnmowernick Electrical Tech 11 10-22-2015 06:09 PM
Windshield wipers not working properly mwillika Electrical Tech 26 11-07-2014 07:09 AM
windshield wipers not working pmccar27 Electrical Tech 1 02-07-2014 06:39 PM
Windshield wipers stopped working when i pulled the radio StitchsDad Electrical Tech 0 02-03-2013 12:54 PM
2000 2.5, windshield wipers not working Slum Zombe 4-Cylinder Tech 1 05-05-2012 07:27 PM