Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-19-2016, 05:21 PM
Brackins Brackins is offline
Learning to use the forums
 
Join Date: Dec 2016
Posts: 2
Default Speedometer/tach work after driving a distance

I have a 96 ranger. The speedometer and tach plus the voltage gauge start working only after driving a distance, usually a few miles. They stay at zero and all start working at the same time. Where do I start to find the problem?

Sent from my LG-UK495 using Tapatalk
Reply With Quote
  #2  
Old 12-20-2016, 05:42 PM
Grumpa Grumpa is offline
Busted Knuckles
 
Join Date: Mar 2016
Posts: 86
Default Re: Speedometer/tach work after driving a distance

Hmmm, they only come on after driving a few miles? Have you tapped on the cluster or top of the dash to see if they will come on? Is there anything else not working the way it's supposed to, like door chimes or dash lights? When you turn the key to the run (not start) position, do all the dash lamps like the MIL , ABS, Seatbelt and such light up briefly?
__________________
1995 Ranger XLT 3.0L OBDII
Trans: 4R44E 2WD
Rear: 3.45
Tires: P235 75/R15
Up to 220,200 miles
Reply With Quote
  #3  
Old 12-20-2016, 06:33 PM
Jswifto Jswifto is offline
Ford Ranger Driver
 
Join Date: Dec 2013
Posts: 1,421
Default

Check your engine harness plug and the plug at the firewall for corrosion. Also do a wiggle test on the wires
__________________
1999 Ranger 4.0 and extreme Snap-on tool fetish
Reply With Quote
  #4  
Old 12-20-2016, 07:05 PM
Brackins Brackins is offline
Learning to use the forums
 
Join Date: Dec 2016
Posts: 2
Default Re: Speedometer/tach work after driving a distance

Everything else works as it should. I'm at a lose.

Sent from my LG-UK495 using Tapatalk
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 B3000 (Mazda) - Speedo/Tach die and engine light comes on while driving alpinejonny Electrical Tech 5 07-11-2015 03:46 PM
Squeaking after driving for a distance Gainaxx 3.0 Vulcan Tech 22 10-19-2014 12:15 PM
Speedometer Tach Question Ural Bob Interior Tech 1 11-03-2013 05:50 AM
tach, speedometer,cel all eratic,intermittant newman 4.0 SOHC / 4.0 OHV Tech 0 11-24-2012 05:15 PM
2008 speedometer and tach not working tbar Electrical Tech 0 12-13-2011 02:52 PM