Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-19-2016, 10:35 AM
gnarshosapian gnarshosapian is offline
Liking the Ford Ranger Forum
 
Join Date: Aug 2013
Posts: 16
Default Heat/AC blower mystery

Recently my blower stopped working which is way more of an issue than I thought it would be at first because defogging the windshield is very slow.

The blower died suddenly, as in it worked one day and didn't the next. There was no slow death, or partiality to a high speed or a low speed. It simply wouldn't turn on one day.

I've checked the fuse and the relay, and replaced the blower motor resistor and the blower motor itself and still there is no sign of life on any speed setting.

I'm stumped.

Has anyone dealt with a similar issue? Am I missing a second fuse someplace? Is the issue at the switch?
__________________
2001 6cyl 3.0 2wd Manual Trans.
Reply With Quote
  #2  
Old 12-19-2016, 11:30 AM
sheltonfilms sheltonfilms is offline
Junkyard Dog
 
Join Date: Sep 2010
Posts: 1,833
Default Re: Heat/AC blower mystery

Quote:
Originally Posted by gnarshosapian View Post
Recently my blower stopped working which is way more of an issue than I thought it would be at first because defogging the windshield is very slow.

The blower died suddenly, as in it worked one day and didn't the next. There was no slow death, or partiality to a high speed or a low speed. It simply wouldn't turn on one day.

I've checked the fuse and the relay, and replaced the blower motor resistor and the blower motor itself and still there is no sign of life on any speed setting.

I'm stumped.

Has anyone dealt with a similar issue? Am I missing a second fuse someplace? Is the issue at the switch?
The blower motor resistor pigtail has been known to have issues with corrosion.

You still have the old blower motor and relay? I would apply 12v to the original motor and see if it runs.
__________________
Automotive Electronics Engineer
2000 XLT 2.5L A/T
Mods:
Explorer OHC
Explorer Autodim Mirrors w/ Autolamps
Explorer Sport White Face Gauges
Reply With Quote
  #3  
Old 12-26-2016, 09:44 AM
GreatDane GreatDane is offline
A lonely dane
 
Join Date: Nov 2013
Posts: 814
Default Re: Heat/AC blower mystery

Quote:
Originally Posted by sheltonfilms View Post
The blower motor resistor pigtail has been known to have issues with corrosion.

You still have the old blower motor and relay? I would apply 12v to the original motor and see if it runs.
X2 on that! Its always best to test units on a separate 12v network
__________________
1997 - 4.0 - Auto - 4x4 - Extended cab

1997 - 4 banger - 5-speed - 2WD - Extended cab
SOLD
Reply With Quote
Reply

Tags
air, air cond, blower motor, heat

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heat blower setting issue Henne Electrical Tech 21 04-17-2014 04:04 PM
question about the ac/ heat blower motor huffa12 General Ford Ranger Discussion 4 07-27-2011 10:27 AM
SCREEEEAMMING Heat Blower Motor / Fan Gumcrew2 General Tech 0 05-12-2011 04:37 PM
blower motor for heat not working Ranger96k 4-Cylinder Tech 2 09-05-2009 09:39 PM