Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-11-2016, 06:39 PM
Utah Utah is offline
Learning to use the forums
 
Join Date: Dec 2016
Posts: 2
Default Wiper washer won't squirt.

I replaced the W/W motor pump on the reservoir. Still nothing. I fear the problem is on the blinker/wiper assembly. Its supposed the squirt fluid and wipers should make two swipes. But nothing happens when I push the end of the handle inward.

Help!
Reply With Quote
  #2  
Old 12-12-2016, 04:59 AM
sonicboom sonicboom is offline
Learning to use the forums
 
Join Date: Dec 2016
Posts: 3
Default Re: Wiper washer won't squirt.

My truck did the same thing, and the I ran a wire from the battery to a switch. I attached a positive lead to the black and white wire on the water pump thinking that was the positive lead. Now nothing works in the truck. Only thing that power up is the brake lights. So I fried something. I figured since I had probably no power from that button on the column it would not hurt anything to splice that wire with one of those clamp things to what I thought was the power wire to that pump. I'm thinking I put power maybe to the ground wire and burn something up in the truck. I since removed the electrical ignition module and noticed the yellow wires have power into that but for some reason nothing beyond that work when I turn the key on. So maybe it fried that sucker. That button you push on that blinker unit I did-assembled and that is what started the problem with the pump not working. I'm going to check the grounds today since I can't find a bad fuse or relay. I'm really getting frustrated here.
Reply With Quote
  #3  
Old 12-12-2016, 07:06 AM
Ordinary Biker Ordinary Biker is online now
Just call me'Two Rangers'
 
Join Date: Apr 2013
Posts: 3,845
Default Re: Wiper washer won't squirt.

Quote:
Originally Posted by Utah View Post
I replaced the W/W motor pump on the reservoir. Still nothing. I fear the problem is on the blinker/wiper assembly. Its supposed the squirt fluid and wipers should make two swipes. But nothing happens when I push the end of the handle inward.

Help!
The fact that the wipers didn't go either, even if it didn't squirt, was your clue. Wipers, no squirt, yes I would have looked at the pump. No wipers OR squirt, sounds like the signal is either not being generated, or it isn't getting there.
__________________
'98, 2wd, 2.5l, 5spd, regular cab step side
'07, 4X4, 4.0l, 5spd, super cab fleet side
'66 Ford Mustang 289, Auto
'81 Yamaha XS850 custom bobber
'91 Suzuki Marauder

They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety. - Ben Franklin
The best government is a benevolent tyranny tempered by an occasional assassination. - Voltaire
Reply With Quote
  #4  
Old 12-12-2016, 07:37 AM
sonicboom sonicboom is offline
Learning to use the forums
 
Join Date: Dec 2016
Posts: 3
Default Re: Wiper washer won't squirt.

Push in the squirt switch and see with a voltage meter if you have power to the leads for the water pump. Two wires, one is black and the other black with a white line, I'm not sure which one the positive, sometimes ford will use a black wire for power supply. I've not been able to find a schematic showing which wire is what for that water pump. You find out let me know.
Reply With Quote
  #5  
Old 12-12-2016, 04:04 PM
Grumpa Grumpa is offline
Busted Knuckles
 
Join Date: Mar 2016
Posts: 97
Default Re: Wiper washer won't squirt.

Have you checked any fuses and such?
__________________
1995 Ranger XLT 3.0L OBDII
Trans: A4LD (E) 2WD
Rear: 3.45 NL LHD
Tires: P235 75/R15
Long Bed
Up to 221,400 miles
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Drive axle thrust washer won't fit ghack Drivetrain Tech 4 02-19-2015 04:46 PM
wiper / washer issues Vin Electrical Tech 2 10-07-2014 02:38 PM
Windshield wiper/washer problem Dal33tdude12 Electrical Tech 0 05-03-2014 08:59 PM
wiper blades and windshield washer fluid??? the3oh1 General Ford Ranger Discussion 13 07-27-2012 10:23 PM
No power at windshield wiper washer motor JSobo Electrical Tech 5 05-11-2011 07:41 AM