Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-22-2016, 06:09 PM
dangerranger01NJ dangerranger01NJ is offline
Just the tip
 
Join Date: Aug 2012
Posts: 1,377
Default having LED issues...

Okay so I recently converted all my exterior bulbs to LEDs got the ep27 relay and swapped it in and had no problems for a few weeks. I get in my truck, key off engine off and the relay is just clicking, lights and 4ways and stuff work fine but the relay just clicks all the time and this just started about an hour ago. Any suggestions would be a big help
__________________
2006 Ford Ranger FX4 Off Road
maxed out torsion keys, Add a Leaf, 3" higher then stock, LT265/75R16 BF Goodrich all terrain KO2s on 16x8 Black Rock 997 Type 8 Wheels, 15% front windows, 5% back windows. Cobra 40 Channel CB and a 3' Firestik II, 3157 Pilot LED backup light bulbs and 2 KC Dayligher 100 Watt lights
Reply With Quote
  #2  
Old 04-23-2016, 02:47 AM
cortezmario94 cortezmario94 is offline
Ford Truck Driver
 
Join Date: Sep 2015
Posts: 84
Default

...unplug them... And plug them back in
Reply With Quote
  #3  
Old 04-23-2016, 03:46 AM
dangerranger01NJ dangerranger01NJ is offline
Just the tip
 
Join Date: Aug 2012
Posts: 1,377
Default

The bulbs or the relay?
__________________
2006 Ford Ranger FX4 Off Road
maxed out torsion keys, Add a Leaf, 3" higher then stock, LT265/75R16 BF Goodrich all terrain KO2s on 16x8 Black Rock 997 Type 8 Wheels, 15% front windows, 5% back windows. Cobra 40 Channel CB and a 3' Firestik II, 3157 Pilot LED backup light bulbs and 2 KC Dayligher 100 Watt lights
Reply With Quote
  #4  
Old 04-23-2016, 06:30 AM
msparks msparks is offline
Ford Ranger Driver
 
Join Date: Mar 2015
Posts: 907
Default

Send buggman a message. He can probably help you out.

----------

Oh when you find out let us know. Plans in the future for my truck is LEDs
__________________
2005 FX4 4.0 SOHC L/S 4.10 Automatic Transmission k&n drop-in air filter, filter box mod, LED tag and back up lights
Reply With Quote
  #5  
Old 04-23-2016, 06:43 AM
dangerranger01NJ dangerranger01NJ is offline
Just the tip
 
Join Date: Aug 2012
Posts: 1,377
Default

I think it might just be me having these problems. There's a guy on here with a 2011 and he hasn't had any issues in 2 months. I messaged him on Facebook but for now I swapped everything back.
__________________
2006 Ford Ranger FX4 Off Road
maxed out torsion keys, Add a Leaf, 3" higher then stock, LT265/75R16 BF Goodrich all terrain KO2s on 16x8 Black Rock 997 Type 8 Wheels, 15% front windows, 5% back windows. Cobra 40 Channel CB and a 3' Firestik II, 3157 Pilot LED backup light bulbs and 2 KC Dayligher 100 Watt lights
Reply With Quote
  #6  
Old 04-23-2016, 07:36 AM
Ordinary Biker Ordinary Biker is offline
Just call me'Two Rangers'
 
Join Date: Apr 2013
Posts: 4,038
Default Re: having LED issues...

The relay's are cheap enough, did you think about replacing it? I have been running LED's for almost 2 years, no problem.
__________________
'98, 2wd, 2.5l, 5spd, regular cab step side
'07, 4X4, 4.0l, 5spd, super cab fleet side
'66 Ford Mustang 289, Auto
'81 Yamaha XS850 custom bobber
'91 Suzuki Marauder

They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety. - Ben Franklin
The best government is a benevolent tyranny tempered by an occasional assassination. - Voltaire
Reply With Quote
  #7  
Old 04-23-2016, 07:41 AM
dangerranger01NJ dangerranger01NJ is offline
Just the tip
 
Join Date: Aug 2012
Posts: 1,377
Default

I went through 3 and they all did the same thing lol
__________________
2006 Ford Ranger FX4 Off Road
maxed out torsion keys, Add a Leaf, 3" higher then stock, LT265/75R16 BF Goodrich all terrain KO2s on 16x8 Black Rock 997 Type 8 Wheels, 15% front windows, 5% back windows. Cobra 40 Channel CB and a 3' Firestik II, 3157 Pilot LED backup light bulbs and 2 KC Dayligher 100 Watt lights
Reply With Quote
  #8  
Old 04-23-2016, 07:46 AM
Ordinary Biker Ordinary Biker is offline
Just call me'Two Rangers'
 
Join Date: Apr 2013
Posts: 4,038
Default Re: having LED issues...

Very strange. I agree, maybe Buggman can help with his wisdom.
__________________
'98, 2wd, 2.5l, 5spd, regular cab step side
'07, 4X4, 4.0l, 5spd, super cab fleet side
'66 Ford Mustang 289, Auto
'81 Yamaha XS850 custom bobber
'91 Suzuki Marauder

They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety. - Ben Franklin
The best government is a benevolent tyranny tempered by an occasional assassination. - Voltaire
Reply With Quote
  #9  
Old 04-23-2016, 05:53 PM
buggman buggman is offline
Do not touch the trim!
 
Join Date: Aug 2010
Posts: 3,019
Default Re: having LED issues...

it could be a bad ep-27 flasher causing the issues, but it could be the type of led's you're using as well.
some of the newer tech led's have been causing odd issues that the flasher nor load resistors seem to remedy.
i haven't had a chance to fully investigate a remedy for the new style led's yet.
__________________
'96 XLT, 4.0L, 4x4 Auto, Super Cab, K&N Filter, Dual Exhaust, 200a Alt, Clear Corners, BUGGMAN LED's, Expo Power Seats & Console, LED modded '01 Tails

Need LED's? Send me a PM
LINKS... Click 'em - - -> BUGGMAN PICS - - -BUGGMAN'S YouTube Channel - - -BUGGMAN'S FaceBook
Reply With Quote
  #10  
Old 04-28-2016, 04:55 AM
netcana netcana is offline
Learning to use the forums
 
Join Date: Apr 2016
Posts: 9
Default Re: having LED issues...

Contact the seller from where you bought this product they will fix your problem.
Reply With Quote
  #11  
Old 04-28-2016, 05:17 AM
dangerranger01NJ dangerranger01NJ is offline
Just the tip
 
Join Date: Aug 2012
Posts: 1,377
Default

I bought the bulbs from Walmart and I got it figured out the bulbs I bought don't have diodes in them so they allow back flow of current
__________________
2006 Ford Ranger FX4 Off Road
maxed out torsion keys, Add a Leaf, 3" higher then stock, LT265/75R16 BF Goodrich all terrain KO2s on 16x8 Black Rock 997 Type 8 Wheels, 15% front windows, 5% back windows. Cobra 40 Channel CB and a 3' Firestik II, 3157 Pilot LED backup light bulbs and 2 KC Dayligher 100 Watt lights
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal issues with LED lights 2008RangerSport Electrical Tech 34 04-11-2016 09:51 PM
LED Conversion Issues emtjcjr Electrical Tech 2 06-12-2014 08:41 PM
Cree LED headlight issues? LI Ranger 00 Electrical Tech 10 04-04-2014 07:20 AM
Bed Cap LED Third Brake Issues Jkad Exterior Tech 0 03-27-2014 09:04 AM
Led blinker issues 1994! MotoRider36 Electrical Tech 5 01-21-2014 10:11 PM