Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 06-21-2010, 05:12 PM
d4sqd86 d4sqd86 is offline
Loud N Proud
Join Date: Jun 2009
Posts: 63
Send a message via AIM to d4sqd86 Send a message via Yahoo to d4sqd86
Default Headlights not coming on

So I've had this HID kit since about January or so and blew a fuse once. Friday night I was heading out of town, and started blowing fuses left and right. Didn't drive it all weekend and on my way back into town today, I noticed I had a light out. I'm sitting at work, went out and checked it out, and noticed I now have NO headlights at all. Checked all the fuses and none are blown, bulbs look fine, I have no clue what else to check. Is there a relay under the hood anywhere or anything like that?! Any help would be great, don't want to drive at 1030pm with no heads =/
04 Ranger Tremor
Kenwood Excelon x-693
RE Audio SE 12 w/ US Amps Xterminator 1600
10000k HID Headlight Conversion
More to come....
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine light coming on? ranger324 4.0 SOHC / 4.0 OHV Tech 0 03-10-2010 05:54 AM
CEL keeps coming on 1freaky1 4.0 SOHC / 4.0 OHV Tech 26 03-08-2010 09:29 AM
Look what's coming my way! dixie_boysles Off Topic 17 01-31-2010 01:52 PM
Changes are coming... Lazler Vehicle Snapshots 20 01-30-2010 11:12 AM
Another coming from RF enraged_hunter Introduce Yourself 16 09-26-2009 11:47 AM