Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 06-06-2010, 09:50 AM
murphybrain murphybrain is offline
Learning to use the forums
Join Date: Jun 2010
Posts: 1
Default Wont stay running, seems to be electrical

1997 2.3L ranger
Battery, alternator, and battery cable connectors have less than 5K miles on them, alternator replaced professionally.

Get in the truck, everything seems normal. Try to start and get nothing. Not even a click. Cleaned battery terminals and checked connections at starter relay.

Gave it a jump and seemed sluggish but still started. Ran fine (or as well as it normally does) Let it run for 15 minutes or so, but once i tried to go anywhere the engine stalled. Tried it again and this time when i removed the jumper cables the engine died.

Voltage on battery is normal.

Only other thing that seems weird is whenever i open the car door the dome light doesn't come on, and i hear a clicking that sounds like its coming from the glovebox.

Any suggestions what to try next? I think my wife is going to kill me if I keep leaving her at home with the baby and no car while I'm at work.
1997 2WD Ranger
2.3 SOHC 4 Cyl
156k Miles
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why wont my 4.0L Ford Ranger stay running when cold? NeonBoy95 Drivetrain Tech 4 08-29-2010 02:47 AM
please help 3.0 wont stay running bogs and wont rev up mdub4life29 3.0 Vulcan Tech 2 06-03-2010 12:58 PM
Truck wouldn't stay running TrndAssassin 4-Cylinder Tech 5 05-31-2010 09:00 AM
cranks but wont stay running sscrash 4-Cylinder Tech 8 07-17-2009 10:11 PM
wont stay running Lila General Ford Ranger Discussion 4 05-06-2009 04:04 PM