Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-07-2015, 01:38 PM
SlyFoxJr7 SlyFoxJr7 is offline
Like the Forums
 
Join Date: Feb 2015
Posts: 30
Default Driver's Side Low Beam Not working

all my other lights work, highs, passenger low, fogs, etc. I've read there's supposed to be a fuse in #8 and #10 but I have neither and my headlights worked fine, my truck didn't come with fogs but came with the wiring and button, I use the fog light button to power two kc lights I have hooked so i know they work. this happened after I hooked up a set of Hids with a bad ballast, and I'm not getting any voltage from my low beam connector to the actual headlight, I lost my service manual so have no clue what relays/fuses to check.

I read on an explorer forum that theres some kind of VOL(?) thing under the center console that a saulder will come off but as I don't have a center console Idk where that thing would be or if my ranger even has one.
any help would be appreciated, thanks!
__________________
01 Ford Ranger 3.0 XLT 4x4
32/11.50 Wild Country MXTs/15x8 Pacer Bullet Holes
12" JBL sub
HIDS, 24" Light Bar, other LEDs
Brush Guard
K&N Cold Air Intake
Reply With Quote
  #2  
Old 08-07-2015, 01:43 PM
Logan03CO Logan03CO is offline
No wire hangers, ever!

 
Join Date: Jun 2010
Posts: 10,313
Default Re: Driver's Side Low Beam Not working

Quote:
Originally Posted by SlyFoxJr7 View Post
I lost my service manual so have no clue what relays/fuses to check.
Click for owners manual: 2001 Ford Ranger Owners Manual
__________________
Curent 2003 Ford Mustang Mach 1 owner - Build Thread for her: Logan's 2003 Mach 1

Former 2003 Ford Ranger owner - Build Thread for her: Project Budget Buster
Reply With Quote
  #3  
Old 08-07-2015, 01:44 PM
SlyFoxJr7 SlyFoxJr7 is offline
Like the Forums
 
Join Date: Feb 2015
Posts: 30
Default Re: Driver's Side Low Beam Not working

Quote:
Originally Posted by Logan03CO View Post
Click for owners manual: 2001 Ford Ranger Owners Manual
I love this place....

Thank you so much
__________________
01 Ford Ranger 3.0 XLT 4x4
32/11.50 Wild Country MXTs/15x8 Pacer Bullet Holes
12" JBL sub
HIDS, 24" Light Bar, other LEDs
Brush Guard
K&N Cold Air Intake
Reply With Quote
  #4  
Old 08-07-2015, 01:45 PM
Ordinary Biker Ordinary Biker is offline
Just call me'Two Rangers'
 
Join Date: Apr 2013
Posts: 3,975
Default Re: Driver's Side Low Beam Not working

Did you check the resistance of the bulb, voltage being delivered, swap it with the other side? You you know it might just be burned out. Probably your trucks way of letting you that cheeseball plug-n-play HID's are just dumb.
__________________
'98, 2wd, 2.5l, 5spd, regular cab step side
'07, 4X4, 4.0l, 5spd, super cab fleet side
'66 Ford Mustang 289, Auto
'81 Yamaha XS850 custom bobber
'91 Suzuki Marauder

They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety. - Ben Franklin
The best government is a benevolent tyranny tempered by an occasional assassination. - Voltaire
Reply With Quote
  #5  
Old 08-07-2015, 01:47 PM
Logan03CO Logan03CO is offline
No wire hangers, ever!

 
Join Date: Jun 2010
Posts: 10,313
Default Re: Driver's Side Low Beam Not working

Quote:
Originally Posted by SlyFoxJr7 View Post
I love this place....

Thank you so much
No problem.


Fuse #38 in the power distribution box (AKA - Under hood) is listed as the "Left Headlamp Low Beam" (Page #169-170 of the manual/PDF).
__________________
Curent 2003 Ford Mustang Mach 1 owner - Build Thread for her: Logan's 2003 Mach 1

Former 2003 Ford Ranger owner - Build Thread for her: Project Budget Buster

Last edited by Logan03CO; 08-07-2015 at 01:49 PM.
Reply With Quote
  #6  
Old 08-07-2015, 02:09 PM
SlyFoxJr7 SlyFoxJr7 is offline
Like the Forums
 
Join Date: Feb 2015
Posts: 30
Default Re: Driver's Side Low Beam Not working

Quote:
Originally Posted by Ordinary Biker View Post
Did you check the resistance of the bulb, voltage being delivered, swap it with the other side? You you know it might just be burned out. Probably your trucks way of letting you that cheeseball plug-n-play HID's are just dumb.
Well, saying it was a bad ballast, I put my normal halogens back in. They worked fine 5 minutes before I unplugged them and tried the HIDs out. I highly doubt they'd be burnt out

----------

Quote:
Originally Posted by Logan03CO View Post
No problem.


Fuse #38 in the power distribution box (AKA - Under hood) is listed as the "Left Headlamp Low Beam" (Page #169-170 of the manual/PDF).
that was my problem. And here I was thinking it was a dimmer switch or something because the same thing happened to my buddys 2011... I'm filled with a mixture of relief and foolishness...

Thanks again!
__________________
01 Ford Ranger 3.0 XLT 4x4
32/11.50 Wild Country MXTs/15x8 Pacer Bullet Holes
12" JBL sub
HIDS, 24" Light Bar, other LEDs
Brush Guard
K&N Cold Air Intake
Reply With Quote
  #7  
Old 09-10-2017, 03:37 AM
biscuitboy9123 biscuitboy9123 is offline
Learning to use the forums
 
Join Date: Sep 2017
Posts: 3
Default Re: Driver's Side Low Beam Not working

Hey guys....

My 04 Ranger edge low beam driver side went out. But the high beams work. And the low be am on the passenger side work. Even swapped bulbs and nothing. Been running HIDs for a year now. Could've done some damage? Checked fuses under the hood and im.gettng no power to them.but I swapped them in another spot and they work just fine. Any ideas? Honestly don't think it's a switch. Connector for the bulb looks fine and what wiring I can see looks fine also
If I have to dig deeper I will.... just needing to know where to start now since fuses aren't working but are still good.
__________________
2004 Ford Ranger edge. 3.0 V6 5 speed
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Driver's Side Power Window not working msparks Electrical Tech 5 06-27-2015 06:18 PM
98 right low beam is not working grens404 3.0 Vulcan Tech 27 04-09-2015 06:20 AM
Low beam/High beams stopped working. duddadu Electrical Tech 5 10-04-2014 06:29 PM
low beam out druwevr Electrical Tech 18 10-07-2010 08:25 PM
Left side driver speaker not working? scrillasherv Audio / Video 6 11-04-2009 12:21 PM