Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-26-2015, 08:27 PM
mudgripranger mudgripranger is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2014
Posts: 15
Exclamation ABS false activating every stop

So i bought a 05 2wd 2.3L ranger and the tire sizes were different. the back ones were bigger than the front ones. I asked a few people some people said tires, some said sensors, etc. So I went with brand new speed sensors and that didnt fix it so i said screw it and bought four new kenda klevers. My abs used to false activate every stop no matter how smooth i made it. now it still false activates but at random times my abs light will come on along with a brake light and abs will completely shut off after i brake a few times. I have know clue whatsoever about how to approach this
Reply With Quote
  #2  
Old 02-26-2015, 08:37 PM
barneycat11 barneycat11 is offline
2006 FX4
 
Join Date: Nov 2014
Posts: 320
Default Re: ABS false activating every stop

You need to read the ABS code to find out which sensor is not working.The ABS will shut off if a fault is read and resets when you turn off the key. Bad sensor ring,low voltage on a sensor read the code to narrow it down.

Last edited by barneycat11; 02-26-2015 at 09:12 PM.
Reply With Quote
  #3  
Old 02-26-2015, 08:49 PM
sheltonfilms sheltonfilms is offline
Junkyard Dog
 
Join Date: Sep 2010
Posts: 1,893
Default Re: ABS false activating every stop

Quote:
Originally Posted by mudgripranger View Post
So i bought a 05 2wd 2.3L ranger and the tire sizes were different. the back ones were bigger than the front ones. I asked a few people some people said tires, some said sensors, etc. So I went with brand new speed sensors and that didnt fix it so i said screw it and bought four new kenda klevers. My abs used to false activate every stop no matter how smooth i made it. now it still false activates but at random times my abs light will come on along with a brake light and abs will completely shut off after i brake a few times. I have know clue whatsoever about how to approach this
I think you just said what your problem is with "my abs light will come on along with a brake light".

Brake light either comes on when parking brake is on OR if you have low fluid level. (information is from your manual page 11)

Check your fluid level and bleed your brakes. Check for leaks, especially at the calipers, wheel cylinders, and master cylinder.
__________________
Automotive Electronics Engineer
2000 XLT 2.5L A/T
Mods:
Explorer OHC
Explorer Autodim Mirrors w/ Autolamps
Explorer Sport White Face Gauges

Last edited by sheltonfilms; 02-26-2015 at 08:52 PM.
Reply With Quote
  #4  
Old 02-26-2015, 09:03 PM
mudgripranger mudgripranger is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2014
Posts: 15
Default Re: ABS false activating every stop

I just got brand new sensors

----------

Quote:
Originally Posted by sheltonfilms View Post
I think you just said what your problem is with "my abs light will come on along with a brake light".

Brake light either comes on when parking brake is on OR if you have low fluid level. (information is from your manual page 11)

Check your fluid level and bleed your brakes. Check for leaks, especially at the calipers, wheel cylinders, and master cylinder.
I got brand new calipers, my fluid level is good i bleed them 2 months ago when i put the new calipers on
Reply With Quote
  #5  
Old 02-26-2015, 09:09 PM
sheltonfilms sheltonfilms is offline
Junkyard Dog
 
Join Date: Sep 2010
Posts: 1,893
Default Re: ABS false activating every stop

So bleed before this happened? or started happening before being bleed?

Also which sensors did you replace how many and where?
__________________
Automotive Electronics Engineer
2000 XLT 2.5L A/T
Mods:
Explorer OHC
Explorer Autodim Mirrors w/ Autolamps
Explorer Sport White Face Gauges
Reply With Quote
  #6  
Old 02-26-2015, 09:19 PM
mudgripranger mudgripranger is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2014
Posts: 15
Default Re: ABS false activating every stop

Quote:
Originally Posted by sheltonfilms View Post
So bleed before this happened? or started happening before being bleed?

Also which sensors did you replace how many and where?
It has been doing this since i got it but when i put new tires on it the abs and brake light come on at a random time and abs shuts off. there are only two sensors and i replaced them
Reply With Quote
  #7  
Old 02-26-2015, 09:24 PM
sheltonfilms sheltonfilms is offline
Junkyard Dog
 
Join Date: Sep 2010
Posts: 1,893
Default Re: ABS false activating every stop

Actually there are three sensors, that is why I asked. There is a third on the rear differential on the top.

----------

May want to remove it and see if there is crud on it, and also check the hole where it goes.
__________________
Automotive Electronics Engineer
2000 XLT 2.5L A/T
Mods:
Explorer OHC
Explorer Autodim Mirrors w/ Autolamps
Explorer Sport White Face Gauges
Reply With Quote
  #8  
Old 02-27-2015, 07:51 AM
mudgripranger mudgripranger is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2014
Posts: 15
Default Re: ABS false activating every stop

Quote:
Originally Posted by sheltonfilms View Post
Actually there are three sensors, that is why I asked. There is a third on the rear differential on the top.

----------

May want to remove it and see if there is crud on it, and also check the hole where it goes.
I always thought there was one but people have told me that there isnt so I never bothered to look! Thanks man I'll go check it out as soon as im home and let you know if that fixes the problem!
Reply With Quote
Reply

Tags
abs, abs problem, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
False Engine Codes? olsin6 3.0 Vulcan Tech 1 10-01-2014 07:48 PM
ABS and brake lights on after hard stop in my 97 ncarolinaranger General Tech 7 03-05-2013 10:58 AM
Discuss How To: Deactivating/activating the BeltMinder feature (seatbelt chime) STL How-To Submissions 79 01-21-2013 07:49 PM
True or false Fordguy52 8-Cylinder Tech 4 08-05-2011 06:00 PM
How To: Deactivating/activating the BeltMinder feature (seatbelt chime) STL Interior Guides 1 09-15-2009 08:07 PM