Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-22-2015, 06:45 PM
yzfoxracer yzfoxracer is offline
Learning to use the forums
 
Join Date: Feb 2015
Posts: 5
Default

So my speedo stopped working yesterday so I replaced the sensor on the axel but it's still not working any ideas
__________________
1997 2.3 5speed regular cab long bed

Last edited by yzfoxracer; 02-23-2015 at 09:43 PM.
Reply With Quote
  #2  
Old 02-22-2015, 06:57 PM
jabbo88 jabbo88 is offline
chirpin' & lurkin'
 
Join Date: Mar 2014
Posts: 1,076
Default Re: Speedo

We need some info on your truck; year, etc.
Consider making a signature so everyone can see it and better assist you.
Could be a number of things wrong, including the cluster itself. Is your odometer working? Any lights on on the cluster? More info please.
__________________
1995 Ford Ranger XL 3.0 Long bed
Gold color
matching Leer shell ♠ clear corners ♠ black tail lights ♠ Mustang dome ♠ Bugflector II ♠ throttle mod ♠ sound system:
Pioneer AVH-x5600BHS ✣ Diamond D672S ✣ Infinity Kappa 682.9cf ✣ Precision Power P900.4 ✣ Precision Power P1000.1 ✣ Massive CORE-1 ✣ Sundown SD-2 8" ✣

BUILD THREAD
Reply With Quote
  #3  
Old 02-22-2015, 07:04 PM
yzfoxracer yzfoxracer is offline
Learning to use the forums
 
Join Date: Feb 2015
Posts: 5
Default

Quote:
Originally Posted by jabbo88 View Post
We need some info on your truck; year, etc. Consider making a signature so everyone can see it and better assist you. Could be a number of things wrong, including the cluster itself. Is your odometer working? Any lights on on the cluster? More info please.
sorry I'm new here so still trying to figure it out. But anyways I have 97 2.3 5speed. The speedo moves around sometimes and the abs light is on I'm not sure if the odometer is working I'll know soon though.
__________________
1997 2.3 5speed regular cab long bed
Reply With Quote
  #4  
Old 02-23-2015, 09:14 PM
02RangerFX4 02RangerFX4 is offline
Lil' Red
 
Join Date: Jan 2011
Posts: 6,369
Default

Quote:
Originally Posted by yzfoxracer View Post
sorry I'm new here so still trying to figure it out. But anyways I have 97 2.3 5speed. The speedo moves around sometimes and the abs light is on I'm not sure if the odometer is working I'll know soon though.
Your replaced the ABS sensor. You need to most likely replace the VSS sensor in the transmission.
__________________
2002 ford ranger FX4 Off Road | 4.0l v6 | Flowmaster 40 S/I D/O | JBA Headers | Rebello Racing cams | port and polished heads | K&n Drop-in filter | TwinStick | 31 Spline 4.10 Torsen rear diff | Alcoa rims | Sitting on 31's|
Reply With Quote
  #5  
Old 02-23-2015, 09:33 PM
yzfoxracer yzfoxracer is offline
Learning to use the forums
 
Join Date: Feb 2015
Posts: 5
Default

Quote:
Originally Posted by jabbo88 View Post
We need some info on your truck; year, etc. Consider making a signature so everyone can see it and better assist you. Could be a number of things wrong, including the cluster itself. Is your odometer working? Any lights on on the cluster? More info please.
odometer is not working

----------

Quote:
Originally Posted by 02RangerFX4 View Post
Your replaced the ABS sensor. You need to most likely replace the VSS sensor in the transmission.
where is that on the trans
__________________
1997 2.3 5speed regular cab long bed
Reply With Quote
  #6  
Old 02-23-2015, 09:41 PM
02RangerFX4 02RangerFX4 is offline
Lil' Red
 
Join Date: Jan 2011
Posts: 6,369
Default

Quote:
Originally Posted by yzfoxracer View Post
odometer is not working ---------- where is that on the trans
It should be towards the output shaft side. If you remove the sensor it has a little gear on the end of it.
__________________
2002 ford ranger FX4 Off Road | 4.0l v6 | Flowmaster 40 S/I D/O | JBA Headers | Rebello Racing cams | port and polished heads | K&n Drop-in filter | TwinStick | 31 Spline 4.10 Torsen rear diff | Alcoa rims | Sitting on 31's|
Reply With Quote
  #7  
Old 02-23-2015, 09:43 PM
yzfoxracer yzfoxracer is offline
Learning to use the forums
 
Join Date: Feb 2015
Posts: 5
Default

Quote:
Originally Posted by 02RangerFX4 View Post
It should be towards the output shaft side. If you remove the sensor it has a little gear on the end of it.
so there is two vss's one on the trans and one on the axel
__________________
1997 2.3 5speed regular cab long bed
Reply With Quote
  #8  
Old 02-23-2015, 10:30 PM
02RangerFX4 02RangerFX4 is offline
Lil' Red
 
Join Date: Jan 2011
Posts: 6,369
Default

Quote:
Originally Posted by yzfoxracer View Post
so there is two vss's one on the trans and one on the axel
I'd consider the one on the axle to be a wheel speed sensor. Either way they both serve different purposes.
__________________
2002 ford ranger FX4 Off Road | 4.0l v6 | Flowmaster 40 S/I D/O | JBA Headers | Rebello Racing cams | port and polished heads | K&n Drop-in filter | TwinStick | 31 Spline 4.10 Torsen rear diff | Alcoa rims | Sitting on 31's|
Reply With Quote
  #9  
Old 02-24-2015, 12:12 PM
sheltonfilms sheltonfilms is offline
Junkyard Dog
 
Join Date: Sep 2010
Posts: 1,835
Default Re: Speedo

1997 and before use transmission sensor for odometer/speedomter/cruise. The diff sensor is only used by the abs.

1998-2000 just uses the diff sensor for everything.

2001+ went back to a transmission sensor for speed but change the sensor type from a gear driven one to a contactless type.
__________________
Automotive Electronics Engineer
2000 XLT 2.5L A/T
Mods:
Explorer OHC
Explorer Autodim Mirrors w/ Autolamps
Explorer Sport White Face Gauges
Reply With Quote
Reply

Tags
ideas, sensor, shaft, speedo, stopped

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo off with 4:88 and 35's?!?! stranger96 Drivetrain Tech 3 10-29-2013 12:31 PM
02 Speedo 02 SonicRanger 4.0 SOHC / 4.0 OHV Tech 2 06-11-2013 11:15 AM
No speedo STATIC RANGER General Tech 0 06-06-2013 04:53 PM
Speedo help markymark81 4-Cylinder Tech 0 10-14-2012 08:35 PM
HELP!!! with speedo 02dangerrangerjosh Interior Tech 7 07-27-2011 05:51 AM