Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-25-2015, 12:52 PM
Bereswill Bereswill is offline
Ford Motor Company
 
Join Date: May 2014
Posts: 138
Default LED lights not working.

I installed LED lights in my front turn signals.
I also installed EP27 flasher relay.
Now my turn signal lights flash like my hazard lights, and my dash lights and radio lights flash with them. Until I turn on my headlights, or parking lights on then they work fine.
Anyone else have this problem? Anyone know how to fix them?
__________________
2000 XLT 4x4 ext. cab 3.0L 149000 mi on eng., body, and trans. Mods, Nerf Bars/ 35% tinted windows/Mustang dome light with LED light/dual sun visor's with lighted mirrors/Ranger third brake/cargo light with LED lights and brake flasher/under hood light with Led.

Last edited by Bereswill; 01-27-2015 at 02:18 PM.
Reply With Quote
  #2  
Old 02-03-2015, 08:44 PM
Bereswill Bereswill is offline
Ford Motor Company
 
Join Date: May 2014
Posts: 138
Default Re: LED lights not working.

I changed the flasher thinking that I might have gotten a bad one.
Pluged new one in and it worked until I got on highway.
Now if I step on brake. the brake lights, front turn lights , and dash lights come on.
If I use turn signal then front and back flash on both sides. along with the dash lights.
__________________
2000 XLT 4x4 ext. cab 3.0L 149000 mi on eng., body, and trans. Mods, Nerf Bars/ 35% tinted windows/Mustang dome light with LED light/dual sun visor's with lighted mirrors/Ranger third brake/cargo light with LED lights and brake flasher/under hood light with Led.
Reply With Quote
  #3  
Old 02-03-2015, 09:51 PM
black 06 ranger black 06 ranger is offline
can it get any better!
 
Join Date: Dec 2012
Posts: 965
Default Re: LED lights not working.

Did you check your fuses? Might not help but flip your led and plug it back in. Disconnect the battery for couple of min then check it.
__________________
2006 Ranger. 2.3l 5 speed
Air box mod and throttle cable mod.
Tri-fold tonneau cover. VHT taillights. Tinted corner lights.
fog lights.black headlights.
LED driving lights, dome, 3rd breaklight, LED tailgate light bar and LED foot wells. LED tails.
4.10 stock gears[/COLOR]

My Build:

http://www.fordrangerforum.com/proje...ger-build.html
Reply With Quote
  #4  
Old 02-06-2015, 06:50 AM
Bereswill Bereswill is offline
Ford Motor Company
 
Join Date: May 2014
Posts: 138
Default Re: LED lights not working.

Quote:
Originally Posted by black 06 ranger View Post
Did you check your fuses? Might not help but flip your led and plug it back in. Disconnect the battery for couple of min then check it.
Every thing work like it should as long as I have my parking, or headlights on.
So I just have to drive with my lights on at daytime.
__________________
2000 XLT 4x4 ext. cab 3.0L 149000 mi on eng., body, and trans. Mods, Nerf Bars/ 35% tinted windows/Mustang dome light with LED light/dual sun visor's with lighted mirrors/Ranger third brake/cargo light with LED lights and brake flasher/under hood light with Led.
Reply With Quote
  #5  
Old 02-22-2015, 04:56 PM
CharlieM CharlieM is offline
Ford Truck Driver
 
Join Date: Jul 2014
Posts: 77
Default

I think every led bulb has to grounded each bulb, not in a series
__________________
Charles
Dont fix it unless it's broken or you really bored
Reply With Quote
  #6  
Old 02-22-2015, 09:05 PM
Bereswill Bereswill is offline
Ford Motor Company
 
Join Date: May 2014
Posts: 138
Default Re: LED lights not working.

Quote:
Originally Posted by CharlieM View Post
I think every led bulb has to grounded each bulb, not in a series
Thanks, I'll check that out and let you know.
__________________
2000 XLT 4x4 ext. cab 3.0L 149000 mi on eng., body, and trans. Mods, Nerf Bars/ 35% tinted windows/Mustang dome light with LED light/dual sun visor's with lighted mirrors/Ranger third brake/cargo light with LED lights and brake flasher/under hood light with Led.
Reply With Quote
  #7  
Old 02-24-2015, 07:01 AM
Conner9802 Conner9802 is offline
Like the Forums
 
Join Date: Mar 2014
Posts: 45
Default

I have the same problem. I'm gonna wait to buy anything else til I find a solution. I have load resistors that worked fine on the rear turn signals but I can't figure out how to wire them in the front to see if they work.
__________________
1998 XLT
2wd
Single cab
Hard flat bed cover
New pioneer head unit and speakers
Reply With Quote
  #8  
Old 02-24-2015, 12:15 PM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,900
Default Re: LED lights not working.

Quote:
Originally Posted by Bereswill View Post
I installed LED lights in my front turn signals.
I also installed EP27 flasher relay.
Now my turn signal lights flash like my hazard lights, and my dash lights and radio lights flash with them. Until I turn on my headlights, or parking lights on then they work fine.
Anyone else have this problem? Anyone know how to fix them?
As a matter of the fact, I'm having a similar issue (park lites won't work with LED's but turn/brake/tail/park will) and yes, I have found one way to fix it (different bulbs but need to find brighter ones) and an effort to correct the problem that came up on my first attempt (used LED bulbs with 12 SMD LED's and a CREE projector). That will involve testing the bulbs with some diodes so as to eliminate what is probably (and hopefully) a backfeeding issue, which would be my first suspicion as to why you're having a light issue. IMO, if you regard each effort to replace an incandescent bulb with an LED, then you won't be far from the truth. They all prototypes and experiments, subject to revisions.

Upshot here is, I would suggest you get some test leads (HF has them) and some small diodes and see if backfeeding is the problem. If it is and if you like the performance of your LED's, then permanently incorporate the diodes in the wiring. Another option that many people use for LED's when they don't want to tinker/experiment is to contact member buggman for LED's.
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #9  
Old 02-24-2015, 10:22 PM
Bereswill Bereswill is offline
Ford Motor Company
 
Join Date: May 2014
Posts: 138
Default Re: LED lights not working.

Quote:
Originally Posted by cowboybilly9mile View Post
As a matter of the fact, I'm having a similar issue (park lites won't work with LED's but turn/brake/tail/park will) and yes, I have found one way to fix it (different bulbs but need to find brighter ones) and an effort to correct the problem that came up on my first attempt (used LED bulbs with 12 SMD LED's and a CREE projector). That will involve testing the bulbs with some diodes so as to eliminate what is probably (and hopefully) a backfeeding issue, which would be my first suspicion as to why you're having a light issue. IMO, if you regard each effort to replace an incandescent bulb with an LED, then you won't be far from the truth. They all prototypes and experiments, subject to revisions.

Upshot here is, I would suggest you get some test leads (HF has them) and some small diodes and see if backfeeding is the problem. If it is and if you like the performance of your LED's, then permanently incorporate the diodes in the wiring. Another option that many people use for LED's when they don't want to tinker/experiment is to contact member buggman for LED's.
I have never worked with test leads and diodes. I don't know what to do with them.
__________________
2000 XLT 4x4 ext. cab 3.0L 149000 mi on eng., body, and trans. Mods, Nerf Bars/ 35% tinted windows/Mustang dome light with LED light/dual sun visor's with lighted mirrors/Ranger third brake/cargo light with LED lights and brake flasher/under hood light with Led.
Reply With Quote
  #10  
Old 02-25-2015, 05:36 PM
Conner9802 Conner9802 is offline
Like the Forums
 
Join Date: Mar 2014
Posts: 45
Default

I'm at a loss with what to do. I have a 98 where it takes 2 bulbs for each side in the front for the turn signals. I have led load resistors but idk where to wire them. Should I buy the EP27 and try it or does someone have a solution?

----------

When I put even one led bulb in everything flashes even the dash lights tail lights all blinkers. Even tag lights
__________________
1998 XLT
2wd
Single cab
Hard flat bed cover
New pioneer head unit and speakers
Reply With Quote
  #11  
Old 02-25-2015, 05:40 PM
Ordinary Biker Ordinary Biker is offline
Just call me'Two Rangers'
 
Join Date: Apr 2013
Posts: 3,977
Default Re: LED lights not working.

Always buy the EP27, and not mess with load resistors
__________________
'98, 2wd, 2.5l, 5spd, regular cab step side
'07, 4X4, 4.0l, 5spd, super cab fleet side
'66 Ford Mustang 289, Auto
'81 Yamaha XS850 custom bobber
'91 Suzuki Marauder

They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety. - Ben Franklin
The best government is a benevolent tyranny tempered by an occasional assassination. - Voltaire
Reply With Quote
  #12  
Old 02-25-2015, 05:41 PM
Conner9802 Conner9802 is offline
Like the Forums
 
Join Date: Mar 2014
Posts: 45
Default

Quote:
Originally Posted by Ordinary Biker View Post
Always buy the EP27, and not mess with load resistors
I put one in each side for the rear turn signals.....
__________________
1998 XLT
2wd
Single cab
Hard flat bed cover
New pioneer head unit and speakers
Reply With Quote
  #13  
Old 02-25-2015, 09:22 PM
Bereswill Bereswill is offline
Ford Motor Company
 
Join Date: May 2014
Posts: 138
Default Re: LED lights not working.

Quote:
Originally Posted by Ordinary Biker View Post
Always buy the EP27, and not mess with load resistors
I have tried two EP27's and they didn't fix the problem.
__________________
2000 XLT 4x4 ext. cab 3.0L 149000 mi on eng., body, and trans. Mods, Nerf Bars/ 35% tinted windows/Mustang dome light with LED light/dual sun visor's with lighted mirrors/Ranger third brake/cargo light with LED lights and brake flasher/under hood light with Led.
Reply With Quote
  #14  
Old 02-26-2015, 08:55 PM
cowboybilly9mile cowboybilly9mile is offline
Ford Ranger Driver
 
Join Date: Mar 2010
Posts: 4,900
Default Re: LED lights not working.

Quote:
Originally Posted by Bereswill View Post
I have never worked with test leads and diodes. I don't know what to do with them.
The diode will function like a check valve and stop backfeeding. As an example, backfeeding from the brake/turn lights into the park/tail/dash light circuit could cause them to illuminate. The diode stops this unwanted current flow. I am discovering that some LED's with *certain* internals may be prone to this.

The test leads allow you to quickly hook up the LED bulb (or whatever else you're working on) and a couple diodes to one of your front or rear illumination/turn lamp sockets or if desired, the connector. I did this myself yesterday (and, solved the problem); in my albums there is one titled, The 06+ rear lamp assembly upgrade. In there you can see how the test was done at the LR light. Although not shown, it was also done on a front illumination/turn light. The diodes were bought off of ebay and the test leads from HarborFreight; together it was under $10.

Unless you are driving an 04 or an 05 (you don't have a siggy telling us what you have), I haven't looked at your wiring. If you are, then you're not going to get there trying more and more EP27 flashers and if in fact the LED is backfeeding, then you may not get there with resistors. A resistor does serve the same function as a diode does, ie, diode acts like a check valve and allows current to pass one way through it, but not the opposite.
__________________
2004 Ranger FX4 Level II, 5R55E, Sonic Blue Pearl

Proudly JAP/RICE free since March 2000
Reply With Quote
  #15  
Old 02-26-2015, 09:22 PM
Bereswill Bereswill is offline
Ford Motor Company
 
Join Date: May 2014
Posts: 138
Default Re: LED lights not working.

Quote:
Originally Posted by cowboybilly9mile View Post
The diode will function like a check valve and stop backfeeding. As an example, backfeeding from the brake/turn lights into the park/tail/dash light circuit could cause them to illuminate. The diode stops this unwanted current flow. I am discovering that some LED's with *certain* internals may be prone to this.

The test leads allow you to quickly hook up the LED bulb (or whatever else you're working on) and a couple diodes to one of your front or rear illumination/turn lamp sockets or if desired, the connector. I did this myself yesterday (and, solved the problem); in my albums there is one titled, The 06+ rear lamp assembly upgrade. In there you can see how the test was done at the LR light. Although not shown, it was also done on a front illumination/turn light. The diodes were bought off of ebay and the test leads from HarborFreight; together it was under $10.

Unless you are driving an 04 or an 05 (you don't have a siggy telling us what you have), I haven't looked at your wiring. If you are, then you're not going to get there trying more and more EP27 flashers and if in fact the LED is backfeeding, then you may not get there with resistors. A resistor does serve the same function as a diode does, ie, diode acts like a check valve and allows current to pass one way through it, but not the opposite.

What size diode did you use?
__________________
2000 XLT 4x4 ext. cab 3.0L 149000 mi on eng., body, and trans. Mods, Nerf Bars/ 35% tinted windows/Mustang dome light with LED light/dual sun visor's with lighted mirrors/Ranger third brake/cargo light with LED lights and brake flasher/under hood light with Led.
Reply With Quote
Reply

Tags
flash, installed, led, lights, parking

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I installed off road lights, The lights work but the switch LED doesnt light up when writtenaudio Electrical Tech 26 05-09-2014 02:44 PM
[SOLD] High Power LED 3rd Brake Light / LED Lisense Plate Lights (IL) Jp7 Exterior Parts 11 06-22-2012 11:09 AM
brake lights, tail lights and instrument panel lights not working polkster Electrical Tech 1 06-12-2012 04:25 PM
pic request...light output of cargo lights on bed (led/non led) HazardousRanger Vehicle Snapshots 53 04-25-2012 06:29 PM
For Sale: 93-99 Ranger LED tail lights & 01-05 halo projector fog lights j$wift Exterior Parts 5 08-04-2010 08:05 PM