Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #46  
Old 04-10-2015, 03:23 PM
93 4x4 93 4x4 is offline
Ford Motor Co
 
Join Date: Feb 2010
Posts: 155
Default Re: LED lights not working.

Yeah I had trouble regular LEDs to
__________________
93 Ranger Supercab, 4.0, 5spd, 1354 Manual Tcase, Narrowed D44HP, 12"Lift, One Piece Aluminum Drive Shaft, 8.8 Explorer 31 Spline Disc Rear, Headman Headers, Edge Running Boards, Edge Textured Flairs, Explorer Overhead Console, Fog Light Mod, Throttle Cable Mod, 35/12.50/15's on 10x15 Mickey Thompson Rims.

Last edited by 93 4x4; 04-11-2015 at 09:24 AM.
Reply With Quote
  #47  
Old 04-10-2015, 04:55 PM
Ordinary Biker Ordinary Biker is online now
Just call me'Two Rangers'
 
Join Date: Apr 2013
Posts: 3,977
Default Re: LED lights not working.

Quote:
Originally Posted by 93 4x4 View Post
Anybody see these plasma LEDs yet check out the video in the link these are plug-and-play these are made for the regular socket but there's also some out there for the new style prong. I bought a set their outstanding!

http://www2.cougarpartscatalog.com/plasma2.html
I would like to know what makes a 'plasma' LED, specially because they are simply using Cree LED chips...
__________________
'98, 2wd, 2.5l, 5spd, regular cab step side
'07, 4X4, 4.0l, 5spd, super cab fleet side
'66 Ford Mustang 289, Auto
'81 Yamaha XS850 custom bobber
'91 Suzuki Marauder

They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety. - Ben Franklin
The best government is a benevolent tyranny tempered by an occasional assassination. - Voltaire
Reply With Quote
  #48  
Old 04-28-2015, 02:45 PM
Bereswill Bereswill is offline
Ford Motor Company
 
Join Date: May 2014
Posts: 138
Default Re: LED lights not working.

Here is what I found and I'm still lost:

My turn signal and brake lights were making my dash and radio lights blink. When my dome light fuse blew, this stopped happening.

The fuse has nothing to do with the brakes or turn signal.

Here is what is on the fuse circuit: Battery Saver Relay, Electronic Shift Relay, Interior Lamp Relay Power Window Relay, Electronic Shift Control Module, Dome Map Lamp, GEM, and Instrument Cluster.

If I was having bleed back from the tail lights or directional lights, why wouldn't I be having problems with the other things on the fuse circuit?
__________________
2000 XLT 4x4 ext. cab 3.0L 149000 mi on eng., body, and trans. Mods, Nerf Bars/ 35% tinted windows/Mustang dome light with LED light/dual sun visor's with lighted mirrors/Ranger third brake/cargo light with LED lights and brake flasher/under hood light with Led.
Reply With Quote
Reply

Tags
flash, installed, led, lights, parking

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I installed off road lights, The lights work but the switch LED doesnt light up when writtenaudio Electrical Tech 26 05-09-2014 02:44 PM
[SOLD] High Power LED 3rd Brake Light / LED Lisense Plate Lights (IL) Jp7 Exterior Parts 11 06-22-2012 11:09 AM
brake lights, tail lights and instrument panel lights not working polkster Electrical Tech 1 06-12-2012 04:25 PM
pic request...light output of cargo lights on bed (led/non led) HazardousRanger Vehicle Snapshots 53 04-25-2012 06:29 PM
For Sale: 93-99 Ranger LED tail lights & 01-05 halo projector fog lights j$wift Exterior Parts 5 08-04-2010 08:05 PM