Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-29-2008, 02:08 PM
Helmut
Guest
 
Posts: n/a
Default Sensor Atop 2003 Ford Ranger 8.8 Axle Housing?

In case anyone needed the part number for this sensor it is Motorcraft BRAB-130
Ford Part # F85Z2L373AC

Faults I have found with this sensor when it goes bad is a jumpy speedometer needle, illuminated ABS light, and eratic/abnormal/unwanted shifting of the automatic transmission.
Reply With Quote
  #2  
Old 11-29-2008, 02:08 PM
144289
Guest
 
Posts: n/a
Default

sensor is for ABS, and speedometer
Reply With Quote
  #3  
Old 11-29-2008, 02:08 PM
Allan C
Guest
 
Posts: n/a
Default

I'm not sure but I think it's a either a speed sensor or it has something to do with the limited slip rear end. I just changed one ( customer brought his own ) and I know it measures the rotations of the pinion gear.
Reply With Quote
  #4  
Old 11-29-2008, 02:09 PM
Old Man Dirt
Guest
 
Posts: n/a
Default

It is a hall effect senor I think. It detects rotation of the ring gear in the differential. This is part of the ABS system. Sometimes getting all the gunk off of them will correct the problem.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing o2 sensor bullcity 3.0 Vulcan Tech 2 05-26-2009 03:46 PM
hole in front axle housing... beaujt Drivetrain Tech 0 05-26-2009 03:13 PM
where is the iat sensor location on 97 ford ranger? Ben M General Ford Ranger Discussion 1 01-24-2009 07:15 PM
On a 2003 Ford Ranger? Steve L General Ford Ranger Discussion 1 01-16-2009 11:49 AM