Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-02-2010, 10:13 PM
4.0Joe 4.0Joe is offline
Like the Forums
 
Join Date: Jan 2010
Posts: 39
Default HIDs

Hey guys. I just installed my HIDs today. Took it out for a night ride to see what they look like and turn on my stereo and the lights go out. What happened? I tried unplugging stuff and putting it back in to see if that would work and I even messed around with the fuses and still no luck. When I turn on my cd player it runs weak. It's all static sounding. Anyone know what's wrong? Any help would be appreciated since I do a lot of night driving and this is my daily driver.
Reply With Quote
  #2  
Old 05-02-2010, 10:25 PM
Vrod21 Vrod21 is offline
Ford Tough
 
Join Date: Dec 2009
Posts: 325
Default Re: HIDs

Need more info. Aftermarket CD player or stock. What kind of projo's, with relay or without. My stereo turns on when the truck turns on, do you mean something else?
__________________
(SOLD) 2003 Ranger 4.0L V6 FX4
2001 F150 Supercrew Triton V8 (DD)
2008 Fusion 3.0L SEL V6 (my baby)
1992 Taurus SHO MTX (my toy-almost Supercharged)
2004 Nissan Murano SL AWD (Wife's car)
Reply With Quote
  #3  
Old 05-02-2010, 10:35 PM
4.0Joe 4.0Joe is offline
Like the Forums
 
Join Date: Jan 2010
Posts: 39
Default Re: HIDs

Aftermarket. The faceplate was lit up. It was when I actually ran the CD player when the lights shut off. The HIDs I got were from DDM tuning with the hi/low function. It came with it's own relay harness.
Reply With Quote
  #4  
Old 05-02-2010, 10:48 PM
Vrod21 Vrod21 is offline
Ford Tough
 
Join Date: Dec 2009
Posts: 325
Default Re: HIDs

Do you have an amp and subs, did you install the deck.......What I'm getting at is....this sounds like an electrical issue. I believe your deck may be wire up poorly, or something is grounded bad such as an amp. Or you HID's are wired wrong. Do you high beams work? Some pics of you install would be helpful.
__________________
(SOLD) 2003 Ranger 4.0L V6 FX4
2001 F150 Supercrew Triton V8 (DD)
2008 Fusion 3.0L SEL V6 (my baby)
1992 Taurus SHO MTX (my toy-almost Supercharged)
2004 Nissan Murano SL AWD (Wife's car)
Reply With Quote
  #5  
Old 05-02-2010, 10:55 PM
Vrod21 Vrod21 is offline
Ford Tough
 
Join Date: Dec 2009
Posts: 325
Default Re: HIDs

Check out this troubleshooting guide

http://reviews.ebay.com/HID-XENON-CO...00000001215090
__________________
(SOLD) 2003 Ranger 4.0L V6 FX4
2001 F150 Supercrew Triton V8 (DD)
2008 Fusion 3.0L SEL V6 (my baby)
1992 Taurus SHO MTX (my toy-almost Supercharged)
2004 Nissan Murano SL AWD (Wife's car)
Reply With Quote
  #6  
Old 05-02-2010, 11:06 PM
4.0Joe 4.0Joe is offline
Like the Forums
 
Join Date: Jan 2010
Posts: 39
Default Re: HIDs

No a local shop did everything. My high beams worked. Before I put them on I tested it out first to see if it works. I did notice though when I ran it at night that they seemed to have "blown out". It's like when I turned them on they started to turn on and shut off for a millisecond and came back on. I don't know if that helps. I will tell you how I wired it though. Basically everything is plug and play(the ballasts, bulbs...etc) however the harness they give you has three individual prongs that you had put in this blue connector they give you to plug into the stock harness. I just basically matched them by color. Red to red, black to black, and the other one that's left is white on the HID harness and the only one left on the stock harness was green so I matched those together. Other than that, there was a postive and negative cable within the harness that I just plugged into the battery. Could that be what's wrong? I'll get pics of the HIDs tomorrow.
Reply With Quote
  #7  
Old 05-02-2010, 11:22 PM
Vrod21 Vrod21 is offline
Ford Tough
 
Join Date: Dec 2009
Posts: 325
Default Re: HIDs

Check out these links to check your wiring.

https://www.ddmtuning.com/support/in...id=100&nav=0,1


https://www.ddmtuning.com/support/in...emid=1&nav=0,1
__________________
(SOLD) 2003 Ranger 4.0L V6 FX4
2001 F150 Supercrew Triton V8 (DD)
2008 Fusion 3.0L SEL V6 (my baby)
1992 Taurus SHO MTX (my toy-almost Supercharged)
2004 Nissan Murano SL AWD (Wife's car)
Reply With Quote
  #8  
Old 05-02-2010, 11:37 PM
beef08 beef08 is offline
Oh Yup!
 
Join Date: Mar 2010
Posts: 2,695
Default Re: HIDs

ive seen alot of em flicker before turning on its like the gases are warming up inside...but i could be wrong just seen it on alot of cars with hid kits
__________________
"I thought this was America!"-Randy Marsh

2003 fx4 4.10, maxed tbars, 5000k HIDS 3157 silverstar bulbs, expo ohc, alons mag light holder, 06+ tails, throttle cable mod, air box mod
360tag:BEEFS7A7US
Reply With Quote
  #9  
Old 05-03-2010, 09:34 AM
4.0Joe 4.0Joe is offline
Like the Forums
 
Join Date: Jan 2010
Posts: 39
Default Re: HIDs

Hey guys! Here's a couple pictures. The first is just how I connected the wires. I took off the connector they gave so you can see the wires better. I just color matched them. Is the connection right so far? The second pic is what I believe is the hi/low controller and just where that sits. It's just hanging there. The ballasts are near each of the headlights. The passenger one is just 3M taped near the fenderwell air duct. and the driver side one is hidden in a little spot directly in fron the the battery. The third pic is how I hooked it up to the battery. Could that be the problem? It says in the instructions to hook the neg to the battery but I hear people hooking it up to any bolt on the body as well.
Attached Images
File Type: jpg 1.jpg (57.9 KB, 13 views)
File Type: jpg 2.jpg (57.9 KB, 11 views)
File Type: jpg 3.jpg (82.2 KB, 11 views)
Reply With Quote
  #10  
Old 05-03-2010, 04:58 PM
geezmo2001 geezmo2001 is offline
My rangexplodeneer.
 
Join Date: Aug 2009
Posts: 247
Default Re: HIDs

Sounds like a bad ground or a ground 'loop'. Just my .02. Good luck. Fwiw, I have my hid's pos. and neg. connected directly to the battery.
__________________
2001 Extended cab Edge, 4x4, 4.0, 4.10 gears, 3" PA body lift, Heartthrob dual exhaust, Roush Thunderbolt signal mirrors, 8000k hid head/foglights, Mountaineer leather buckets, Xplorer shorty console, Alpine 9856 receiver, 10" type r sub in ported box, air box mod, throttle cable mod, Rancho R5000 shox, Scangauge II, plus many other things...
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: Brand New HIDs any bulb any color great price!! DrIftKi7Vg Exterior Parts 781 08-31-2016 03:50 PM
what HIDS? 02BlueRanger Exterior Tech 27 06-13-2011 04:04 PM
Installing projector headlamps/hids in 2010 Ranger bs709 Exterior Tech 11 04-29-2010 12:21 PM
Contour SVT content: New head lights/hids Sonic04edge Vehicle Snapshots 16 03-23-2010 03:53 PM
Installing HIDs GSXR750 Electrical Tech 19 10-11-2009 08:05 PM