Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-17-2014, 11:52 AM
Bigdhendry Bigdhendry is offline
94 Ranger 4wd Auto
 
Join Date: May 2014
Posts: 7
Default EEC IV 94 Ranger 4.0 EEC-no codes

Symptoms:
1. CEL/MIL on continuously when ign. on or running: Can retrieve no codes or even engine ID from CEL/MIL using proper jumper, brake, park, level parameters.
2. Fuel pump runs continuously with ign. on or running- pressure adequate apparently without gauge <don't have a high pressure gauge, but it sprays well>. I note the guage does not read but stays at 1/4 tank.
3. Stalls on idle but runs nicely at 1500RPM and up, if foot taken off of accellerator will die.
My thoughts: It is running in FMEM mode (failure of a critical sensor) or HLOS ( hardware limited mode- too great a failure for FMEM): Problem is identifying failed component if it is a sensor or the PCM if that is the case. The battery has been replaced and codes lost, but I've driven it 14 miles and brought it to operating temp to allow re-adudstment; still - can't retrieve KOEO codes.
Your thoughts? Thanks!
__________________
1994 Ranger Ext.Cab 4.0 Auto(A4LD?) Project truck doesn't run, RF axle broken, windows don't work - etc.
Pretty rough shape but I'm optomistic!
Reply With Quote
  #2  
Old 06-18-2014, 05:50 AM
Bigdhendry Bigdhendry is offline
94 Ranger 4wd Auto
 
Join Date: May 2014
Posts: 7
Default Re: EEC IV 94 Ranger 4.0 EEC-no codes

Visited man who had worked on the truck & was informed that he had installed an PCM from another truck of a different year which was supplied by seller(who neglected to tell me). Ordering correct one. Still seeking information source for specific trouble shooting values & procedures; will look for factory service manuals on ebay & Amazon.
__________________
1994 Ranger Ext.Cab 4.0 Auto(A4LD?) Project truck doesn't run, RF axle broken, windows don't work - etc.
Pretty rough shape but I'm optomistic!
Reply With Quote
  #3  
Old 06-19-2014, 03:25 PM
Bigdhendry Bigdhendry is offline
94 Ranger 4wd Auto
 
Join Date: May 2014
Posts: 7
Default Re: EEC IV 94 Ranger 4.0 EEC-no codes

Ordered elect/vacuum trouble shooting Ford repair manual. While looking at removal of PCM found another BAD ground, of all the grounds I've cleaned the two adjacent to the vac tank near the PCM&brake booster.. Really nasty & made tremendous difference in running.
__________________
1994 Ranger Ext.Cab 4.0 Auto(A4LD?) Project truck doesn't run, RF axle broken, windows don't work - etc.
Pretty rough shape but I'm optomistic!
Reply With Quote
  #4  
Old 06-19-2014, 06:46 PM
Mike In Bama Mike In Bama is offline
Electronics Tech
 
Join Date: Mar 2013
Posts: 1,194
Default

I don't know if this will help you with your current problem, but it sure provides a ton of information for everything electrical.

A complete set of wiring diagrams! Free.

Go to www.bbbind.com .

Select TSB Database, then Wiring Diagrams. Enter your truck info. From there you can choose what Category you need. It's all there, including wire colors to help you trace problems.

Good luck!
__________________
2005 2.3L XL 5SOD 3.73 K&N
KYB Shocks Husky Toolbox
Alpine / Rockford Fosgate Sound

"Ask me about my AC Vent fix!"
Reply With Quote
  #5  
Old 06-19-2014, 06:52 PM
Bigdhendry Bigdhendry is offline
94 Ranger 4wd Auto
 
Join Date: May 2014
Posts: 7
Default Re: EEC IV 94 Ranger 4.0 EEC-no codes

That's really cool. Thank you!
__________________
1994 Ranger Ext.Cab 4.0 Auto(A4LD?) Project truck doesn't run, RF axle broken, windows don't work - etc.
Pretty rough shape but I'm optomistic!
Reply With Quote
  #6  
Old 06-27-2014, 02:13 PM
Bigdhendry Bigdhendry is offline
94 Ranger 4wd Auto
 
Join Date: May 2014
Posts: 7
Talking Re: EEC IV 94 Ranger 4.0 EEC-no codes

Quote:
Originally Posted by Bigdhendry View Post
Symptoms:
1. CEL/MIL on continuously when ign. on or running: Can retrieve no codes or even engine ID from CEL/MIL using proper jumper, brake, park, level parameters.
2. Fuel pump runs continuously with ign. on or running- pressure adequate apparently without gauge <don't have a high pressure gauge, but it sprays well>. I note the guage does not read but stays at 1/4 tank.
3. Stalls on idle but runs nicely at 1500RPM and up, if foot taken off of accellerator will die.
My thoughts: It is running in FMEM mode (failure of a critical sensor) or HLOS ( hardware limited mode- too great a failure for FMEM): Problem is identifying failed component if it is a sensor or the PCM if that is the case. The battery has been replaced and codes lost, but I've driven it 14 miles and brought it to operating temp to allow re-adudstment; still - can't retrieve KOEO codes.
Your thoughts? Thanks!
----------------------
FOLLOW UP- Indeed it was the wrong ECM and the new one cleared all issues in the elect. dept. except a code 172 KOEO lean. I do have a new TPS shipped since it is known to have been tampered with. Next on the agenda is the front Dana 35 that sounds like a haybinder and has broken parts. Think the best route is replace the whole unit with a used one.
__________________
1994 Ranger Ext.Cab 4.0 Auto(A4LD?) Project truck doesn't run, RF axle broken, windows don't work - etc.
Pretty rough shape but I'm optomistic!
Reply With Quote
  #7  
Old 06-30-2014, 11:50 PM
Bigdhendry Bigdhendry is offline
94 Ranger 4wd Auto
 
Join Date: May 2014
Posts: 7
Default

Had to get off the wallet and buy a fuel pressure gauge, it revealed that the pressure was not holding and running below normal (20psi). Replaced the fuel pressure regulator with a junk yard special- engine now normal. Researching the Dana 35 drive shafts and possible mod to passenger side; have a broken yoke on the slip shaft and would like to remove the c-clip but it appears that I could remove the u joint in place with the right tool- may be too easy and cheap to pass up, leave the mod for another day. Will pull hubs tomorrow and check bearings, intend to install manual Warn hubs; thought about the heavy duty ones for the jeep 35 rear which are touted by the rock climbers but will probably do the standard kit. Onward and upwards.
__________________
1994 Ranger Ext.Cab 4.0 Auto(A4LD?) Project truck doesn't run, RF axle broken, windows don't work - etc.
Pretty rough shape but I'm optomistic!
Reply With Quote
Reply

Tags
cel, codes, eec, fmem, hlos

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
'86 Ranger, 2.3, Gas, EFI, where is my EEC-IV Located??? bozo4ford 4-Cylinder Tech 3 10-06-2012 04:29 PM
Eec issue Play4Keeps Electrical Tech 0 05-28-2012 04:03 PM
1991 eec-IV JJcrago05 4.0 SOHC / 4.0 OHV Tech 8 05-13-2012 05:09 PM
88 ranger eec issue gran touring 2.9 Liter Tech 8 08-13-2011 08:48 AM
94 Ranger XLT 4.0L EEC test results help shaynec1981 4.0 SOHC / 4.0 OHV Tech 6 09-03-2009 04:00 PM