Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-30-2010, 11:27 AM
sgampp01 sgampp01 is offline
Learning to use the forums
Join Date: Mar 2010
Posts: 2
Default Electrical Problems

My 2001 Ranger with 4.0 L speedometer and tach stopped working, the battery then went dead while driving. I had the battery and alt checked and the alt output was weak, so I put on a new one. This didn't help. The speedometer and tach still do not work nor does the voltage meter. A couple of things that started happening a day before this: the airbag light started flashing occasionally and the theft system went off while parked.

Could this be a pcm problem? Would the pcm keep the alt from charging the battery?
Reply With Quote
Old 03-30-2010, 01:10 PM
Daedalus Daedalus is offline
Ford Motor Company
Join Date: Jan 2010
Posts: 125
Default Re: Electrical Problems

Try replacing your battery cables
92 Ranger XLT 2.3L I4 w/ 5 speed manual. Bone Stock, looking to mod when funds allow.
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problem MrPlumber Electrical Tech 15 11-12-2015 08:31 AM
Electrical Overkill? FX4 Electrical Tech 4 02-25-2010 01:09 PM
4x4 electrical problem matts93ranga Electrical Tech 2 11-05-2009 04:38 AM
electrical bug FX4 Electrical Tech 1 10-13-2009 01:42 PM
Electrical Grimlins STL Electrical Tech 2 07-08-2009 06:07 PM