Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-11-2013, 07:50 PM
jordanthefordman jordanthefordman is offline
Learning to use the forums
 
Join Date: Nov 2013
Posts: 2
Default Electrical nightmare!

Hello I am in need of some help. I just bought a 2003 ranger 3.0 2wd with 150,000 miles yesterday. I have an amazing 270,000 mile 2000 3.0 as well that I drive everyday but the newer one is having some issues.. The truck beeps for like 4 mins when I start it up and then about 30 mins later it'll do it again. There isn't any lights flashing and its not the seat belt beep. 2nd, the radio is hard wired to the battery and I was wondering if there is any reason the positive and constant wouldn't work going to the radio other than a bad fuse? And 3rd my rpm gauge stays at 4 grand when its started but goes down when vehicle is off. Any ideas?
__________________
JordanTheFordMan
Reply With Quote
Reply

Tags
3.0, beep, electrical, radio, rpm

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Holy Nightmare Redbullbrett Lifted Suspension 11 04-15-2011 02:48 PM
Weekend Nightmare BiggChris Interior Tech 6 04-13-2011 01:04 AM
Electric Nightmare Cherry Bomb Electrical Tech 3 02-14-2011 01:15 PM
1987 Ranger electrical nightmare behind dash 79Zed28 Electrical Tech 2 01-02-2011 07:26 PM
Anti theft nightmare!! Scrappie40 Electrical Tech 2 04-10-2010 11:09 AM