Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-11-2013, 11:15 AM
Ditchlover Ditchlover is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2012
Posts: 27
Default speedometer not working

Alright so I get in my truck start driving and boom no speedometer.
I hooked a reader to it and it hasn't thrown any codes. Both parts for tranny and rear axle are special order and take 10 days to get here. The catch is I have a 16 hour drive in 2 days halfway across the country.
This is my only ride I have, so no borrowing of vehicles and I cant wait in state to repair. Any help or idea would be appreciated.
I heard of obd2 cables to hook to your phone and use it as a speedometer but if the sensors are out that wouldn't work would it?
Reply With Quote
  #2  
Old 03-11-2013, 11:19 AM
bear_claw_91 bear_claw_91 is offline
Reformed Jeeper
 
Join Date: Mar 2012
Posts: 784
Default

Maybe check fuses? I blew a fuse on a van I had and the only thing that wasn't working that I could see was the speedometer.

Sent from my iPhone
__________________
2008 Ford Ranger Sport Extended Cab 4x4 4.0L V6 Automatic

&

1993 Ford Ranger STX Extended Cab 2x4 4.0L V6 Manual
Reply With Quote
  #3  
Old 03-11-2013, 11:37 AM
italian88 italian88 is offline
Ford Tough
 
Join Date: May 2012
Posts: 365
Default

If you dont get that obd2 cord for the phone or that doesn't work then just download a speedometer app if you have a smartphone until you are able to get new parts.
__________________
1999 Ford Ranger XLT 4x4 off road package, Step side bed, Extended cab, 3.0L vulcan v6, 4.10 open gears, Kicker ks-98's in all four stock speaker slots, After market jvc head unit, JL Audio single 12'' W3 sub eoofer in ported box, JX-500/1 class D amp, Memphis 8AWG wiring with inline fuse, Spectre cold air intake, 4 spd with o/d auto transmission
Reply With Quote
  #4  
Old 03-11-2013, 11:46 AM
Ditchlover Ditchlover is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2012
Posts: 27
Default

Ill check fuses, anyone happen to have a manuel and can tell me what fuse the instrument panel is?

Yeah my last resort would be a gps app witha speed setting on it
Reply With Quote
  #5  
Old 03-11-2013, 11:54 AM
italian88 italian88 is offline
Ford Tough
 
Join Date: May 2012
Posts: 365
Default

What kind of truck do you have? If it is listed on your signature I can't read it because I'm on the forum app.
__________________
1999 Ford Ranger XLT 4x4 off road package, Step side bed, Extended cab, 3.0L vulcan v6, 4.10 open gears, Kicker ks-98's in all four stock speaker slots, After market jvc head unit, JL Audio single 12'' W3 sub eoofer in ported box, JX-500/1 class D amp, Memphis 8AWG wiring with inline fuse, Spectre cold air intake, 4 spd with o/d auto transmission
Reply With Quote
  #6  
Old 03-11-2013, 12:08 PM
Ditchlover Ditchlover is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2012
Posts: 27
Default

98 xlt 4.0 4x4
Reply With Quote
  #7  
Old 03-11-2013, 12:13 PM
italian88 italian88 is offline
Ford Tough
 
Join Date: May 2012
Posts: 365
Default

Dang, I have a 99 3.0 xlt 4x4. I'm sure the fuse box setup is sheehy than mine or else I would help you out. Try googleing the fuse box mapping for your truck.

Sent from my old school HTC EVO Shift so I can screw off at work whenever I want
__________________
1999 Ford Ranger XLT 4x4 off road package, Step side bed, Extended cab, 3.0L vulcan v6, 4.10 open gears, Kicker ks-98's in all four stock speaker slots, After market jvc head unit, JL Audio single 12'' W3 sub eoofer in ported box, JX-500/1 class D amp, Memphis 8AWG wiring with inline fuse, Spectre cold air intake, 4 spd with o/d auto transmission
Reply With Quote
  #8  
Old 03-11-2013, 05:12 PM
rangerlocal rangerlocal is offline
Ermahgerd Ferd Rernjurs!
 
Join Date: Aug 2012
Posts: 1,942
Default Re: speedometer not working

Check rear ABS sensor and wiring on the rear diff. Made my speedo do weird things.
__________________
2000 Ranger XL, 2WD, 3.0l, 3.73 rear, 10" rear drum ABS, standard cab, long bed, A/C, 4r44e auto trans w/transgo shift kit, throttle cable mod, air box silencer mod, rear sway bar retrofit, white grill swap, CURT hitch, Westin step bars
Quote:
Originally Posted by writtenaudio View Post
Man wish i had tits, seems like its easier to get a job if you have tits.
Reply With Quote
  #9  
Old 03-12-2013, 07:25 AM
Treasure Hunter Treasure Hunter is offline
Learning to use the forums
 
Join Date: Mar 2013
Posts: 1
Default Re: speedometer not working

I agree with RangerLocal. Check the rear ABS Speed Sensor on top of the differential. I don't know if you have any other symptoms like ABS Light, Check Engine Light, Cruise not working, OD Light, no speedometer, transmission not shifting correctly can all be caused by this sensor. You can remove it just has one bolt like maybe a 10mm. Remove the bolt first and wiggle, turn it back and forth while pulling up. It has an o-ring on it and probably a little sludge around it which usually caused them to be a little tight. I would unhook the wiring last after you have it out it's easier to take off so you don't break the ears off of it. You can use an ohmeter on the sensor and if you have infinite ohms or very low ohms its bad. I'm not sure what the ohms are for the Ranger but an Expedition is around 1980 ohms new. Also, if you have a volt meter with key on you can check to see if you have voltage at the plug. It will be AC voltage not DC. My expy has around 3.65v. I also used the speedometer app on my phone until I got this fixed. The sensors are usually under $20 from a parts store.
Reply With Quote
  #10  
Old 03-12-2013, 07:30 AM
03RangerFX4 03RangerFX4 is offline
Ford Ranger Driver
 
Join Date: Jun 2011
Posts: 1,681
Send a message via Yahoo to 03RangerFX4
Default Re: speedometer not working

Fuse 11 controls speedo and other gauges on dash. It was the same for my 2000 explorer and my 2003 ranger.
__________________
2003 Ford Ranger 4 Door 4x4 FX4 4.0L
2015 Ford Focus
Reply With Quote
  #11  
Old 03-12-2013, 09:04 AM
Ditchlover Ditchlover is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2012
Posts: 27
Default

Well today I went out and started it up and magically my speedo was working again
I'm guessing some water just got in somewhere that it wasn't supposed to be. I have an app now as backup for when I drive home, hopefulky it breaks again while in home so I can fix it.

Thanks for all the hints guys.
Reply With Quote
  #12  
Old 03-26-2013, 09:18 AM
hguffman hguffman is offline
Liking the Ford Ranger Forum
 
Join Date: Mar 2013
Posts: 27
Default Re: speedometer not working

Hay y'all,

I have a 2001 Auto SuperCab 3.0L Ranger and was looking for some speedometer help. When I plug the OBD2 reader in I noticed that my gauge in the dash was reading higher than the speed on the OBD2 reader. Any thoughts?

I was under the impression that if the sensor is correct there is something skrewy with the dash gauge. Anyone else have an issue like this?
Reply With Quote
  #13  
Old 03-26-2013, 11:43 AM
Ditchlover Ditchlover is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2012
Posts: 27
Default

Do you have larger than stock tires? That could make your guage read different.
Reply With Quote
  #14  
Old 03-26-2013, 11:58 AM
rangerlocal rangerlocal is offline
Ermahgerd Ferd Rernjurs!
 
Join Date: Aug 2012
Posts: 1,942
Default Re: speedometer not working

Ford's speedometers are generally set 2-3 mph faster than you're actually going. It was that way in my truck (before I fixed it), two of our Foci, Taurus, and Thunderbird. The only exception was our 2009 Focus, which was pretty much dead on. Not sure if it's Ford's way of trying to keep us out of trouble or what. If it's no more than that, I wouldn't worry about it.
__________________
2000 Ranger XL, 2WD, 3.0l, 3.73 rear, 10" rear drum ABS, standard cab, long bed, A/C, 4r44e auto trans w/transgo shift kit, throttle cable mod, air box silencer mod, rear sway bar retrofit, white grill swap, CURT hitch, Westin step bars
Quote:
Originally Posted by writtenaudio View Post
Man wish i had tits, seems like its easier to get a job if you have tits.
Reply With Quote
  #15  
Old 03-26-2013, 12:07 PM
20Ranger06 20Ranger06 is offline
Ford Motor Co
 
Join Date: Jan 2013
Posts: 172
Default Re: speedometer not working

A speedometer is part of the dash as a guide, they can not be used in a court of law to avoid a ticket. The reason is that they are not legally certified as accurate. Only the Police have those.
__________________
2006 Ford Ranger XL Std Cab 2.3L 5Spd 4x2
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer not working plus other things j_parobeck Electrical Tech 0 01-31-2013 06:35 PM
Speedometer not working and ABS light on Blackbeauty162 Drivetrain Tech 1 03-08-2012 08:09 PM
speedometer not working right cheeba Electrical Tech 6 10-27-2010 06:12 PM
speedometer not working ngant17 Drivetrain Tech 0 05-30-2010 06:55 AM
speedometer quit working blackandgreen98 Electrical Tech 5 01-22-2010 10:56 AM