Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 02-22-2010, 07:40 PM
Kohler Kohler is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 3
Default A4LD 2nd to 3rd issue

I have a 94 Ranger xlt 4x4 with 71,000 miles on it. It shifts through all gears normally except 2nd to 3rd gear there seems to be a slight problem.
If I abruptly let off the accelerator at higher RPM's in 2nd gear there is a delay shifting into 3rd. It seems to hang in 2nd to long and abruptly shift hard into 3rd.

I can avoid the problem while driving If I keep on the accelerator the entire time, allowing the transmission to shift from 2nd to 3rd normally and smoothly. This does not happen in any other gears, ony 2nd ito 3rd. It does not flair, it only acts as though it hangs up a bit.

I have recently changed the transmission fluid and changed the vacuum modulator. The fluid is at a good level. Not sure here. Any ideas ?

Last edited by Kohler; 03-19-2010 at 07:30 PM.
Reply With Quote
  #2  
Old 03-19-2010, 07:30 PM
Kohler Kohler is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 3
Default Re: A4LD 2nd to 3rd issue

I have been waiting patiently.
Reply With Quote
  #3  
Old 03-19-2010, 07:46 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: A4LD 2nd to 3rd issue

They didn't answer my question on trannys either lol Here's the best idea I have at the moment. I have a shift solenoid going out in mine. It can act much the same way as your's does. It doesn't do it often though. I also have an OBD II truck you don't. Do you have a CEL?

And a lot of guys don't pay attention if you don't post often, you have 2 posts, I have seen them both lol Just a thought.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha

Last edited by richarddhoward; 03-19-2010 at 07:49 PM. Reason: brainfarts
Reply With Quote
  #4  
Old 03-20-2010, 01:05 PM
Kohler Kohler is offline
Learning to use the forums
 
Join Date: Feb 2010
Posts: 3
Default Re: A4LD 2nd to 3rd issue

I have no CEL. Hooked up to OBD1. No codes present. I have replaced the modulator. Guess im not one of the good ole' boys.
Reply With Quote
  #5  
Old 03-20-2010, 01:11 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: A4LD 2nd to 3rd issue

What do you mean by not on of the good ole boys? trannys scare most people, especially autos lol

I'm kinda at a loss for what to tell you now, sounds like you need to get it to someone who can check shifting pressures on the transmission in the valve body. Tranny's aren't fun to diagnose or pay to repair.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #6  
Old 11-02-2010, 08:41 PM
Dude03 Dude03 is offline
Learning to use the forums
 
Join Date: Nov 2010
Posts: 1
Exclamation Re: A4LD 2nd to 3rd issue

I have a 88 2.9 auto, that has the same prob, n the trans shop dude told me the A4LD is a Pinto trans w/ overdrive, So if it is on a V6, it cant really handle the HP or the torque that the 2.9, 3.0, or the 4.0 puts out. So a rebuild mite be the way to go?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 2.3L bog issue kschaffner 4-Cylinder Tech 0 02-14-2010 05:33 PM
91 2wd ranger, A4LD auto trans problems. stclist111 Drivetrain Tech 2 12-16-2009 05:37 PM
new 4x4 issue Kayledao Drivetrain Tech 3 09-05-2009 01:42 AM
hid issue sprtyboy Electrical Tech 1 05-24-2009 07:27 PM
a4ld trans dangerranger87 Drivetrain Tech 3 02-15-2009 07:49 AM